Previous 1 2 Next 16 Replies Latest reply: Mar 15, 2010 3:24 PM by turingtest2
haywire_tx Level 1 Level 1 (0 points)
I listen to a lot of audiobooks on my phone. Sometimes I'm ripping them from CDs I buy sometimes I'm getting them online. The problem I have is the tracks won't play in the right order on my phone. They will on my Mac. When I load the tracks into iTunes I open Get Info, I set the Track Numbers & Disc numbers under the info tab, I change the Media Kind to Audiobook & check Remember playback position, Skip when shuffling, & Part of a gapless album under the options tab. And select Yes where appropriate. The files are in the right order on my computer. They will play in the right order on my computer but not on my phone. The files are in the right order on my phone. If you start playing a file you have the screen that shows the album art. If you tap the little screen comes on that has the little ticker with the length of the file, and the play options. Above the ticker it will say 1 of 8 or 2 of 8 or whatever. The second number is always the number of tracks and it is right. But the first number doesn't always correspond to the actual track # you are playing. I might be playing track 32 and it says 1 of 32. It doesn't make sense. Why will it hop from 1 to 16 to 32 to 2 to 5. I don't remember it doing this before the new version of iTunes came out. It's very frustrating that I have to manually pick the next track for it to play since it won't just go to the next track.

32 GB 3GS, iPhone OS 3.1.2, Syncing with New MacBook Pro
  • wjosten Level 10 Level 10 (93,630 points)
    Here are three things to try:

    1. Make sure that Shuffle Mode is turned off: Settings > Shuffle > Off.
    2. Make sure you’ve named the tracks in such a way that sorting them in name order is the right order, e.g., “Kill the Messenger 01”, “Kill the Messenger 02”, etc.
    3. Make sure you’ve put the right track number and disc number information onto all the tracks. Leave the track numbers blank, and use the disc number only. It should be numbered sequentially, just like in the file names, except you don’t need leading zeros. This is frequently the problem; the straight importing procedure can leave semi-random information in the track fields if you are not careful to clear it out.

    As a last resort, you can create a new Playlist in iTunes, and manually add and order all of the tracks for the book. Then you will need to access the book via the Music > Playlists menu, but the tracks should appear in the right order.
  • haywire_tx Level 1 Level 1 (0 points)
    1. I would assume you are talking about Shuffle on the iPhone. Which I find at Settings>iPod>Shake to Shuffle. That is the only Shuffle I see.
    2. Most of my tracks are named like you suggested but not all are. I will try that.
    3. You say to "Make sure you’ve put the right track number and disc number information onto all the tracks." Which I have always done but then you say, "Leave the track numbers blank, and use the disc number only." So which way is it do I use Track #s, CD #s, or both?
  • wjosten Level 10 Level 10 (93,630 points)
    1. yes, on the phone.
    3. Use disk number for ALL tracks from that disk & leave track number blank.
  • haywire_tx Level 1 Level 1 (0 points)
    I tried it all except creating a playlist and nothing works. Why is it that hard. There is obviously a bug in iTunes or on the iPhone. It should be very simple. You number the tracks and the tracks play in that order. Very Very Frustrating. I haven't tried the playlist thingy but I shouldn't have to. I don't want my audiobooks and music mixed up. It should just work. Why doesn't it?
  • haywire_tx Level 1 Level 1 (0 points)
    I tried the playlist idea with one audiobook and it didn't work. It still played in the wrong order. Crazy.
  • Lawrence Finch Level 7 Level 7 (28,670 points)
    Go to a track. There is a icon consisting of an oval made from 2 arrows. This is the shuffle toggle. If it is blue you are in shuffle mode.
  • haywire_tx Level 1 Level 1 (0 points)
    I'm a lot smarter than that. No that is not selected. Besides that icon on the phone is not the shuffle icon it's the Play playlist once, repeat playlist, or repeat item icon depending on which setting you cycle through. There isn't actually a shuffle icon under audiobooks. There is under music which is the crossed arrows.
  • haywire_tx Level 1 Level 1 (0 points)
    I couldn't get the files to play in the right order as audiobooks or a playlist but they will play in the right order as music files. So I figured out a way to do it but it's not the solution I want. I like to keep my things organized. So my question is still not answered. How do you get Audiobook files to play in the right order. Get to work on that Apple it's frustrating.
  • ulyssez Level 1 Level 1 (10 points)
    I've had the same problem, went through the same frustrating fixing attempt, but finally solved it.

    The solution, as ridiculously simple as it may sound, is to turn off "SHUFFLE". The tricky part is that you can't actually turn off shuffle when playing an audiobook. In the audiobook control on top, there are three toggles, from left to right they are: repeat, jump back 30 seconds, and double/half speed. Whereas for music files, the three toggles are: repeat, genius and shuffle. What you need to do is to play a music file, turn off the shuffle from there, and then play the audiobook.

    It makes sense that you can't set Shuffle when playing audiobooks, since you generally won't want to play audiobooks in random order. The problem is that, even when playing audiobooks, the shuffle setting is retained from music player mode. It's very obviously a design defect; shuffle should be automatically OFF when playing audiobooks.

    Hope this helps.
  • christajoyb Level 1 Level 1 (0 points)
    Just so you all know, I've tried all of these things and NONE of them worked. The only thing that worked for me was searching in the iPod app for the book that I wanted to listen to and then listening to it from that list. It put it all in order. Really annoying way to do it, but there you go. At least we have a few different solutions for people.
  • Jason L Community Specialists Community Specialists (10,490 points)
    Hi,

    Are the audiobooks in a Smart Playlist?

    If they are, try the troubleshooting tips in this article: http://support.apple.com/kb/TS3044

    -Jason
  • Amelio Rate Level 1 Level 1 (0 points)
    ulyssez wrote:
    The solution, as ridiculously simple as it may sound, is to turn off "SHUFFLE". The tricky part is that you can't actually turn off shuffle when playing an audiobook. In the audiobook control on top, there are three toggles, from left to right they are: repeat, jump back 30 seconds, and double/half speed. Whereas for music files, the three toggles are: repeat, genius and shuffle. What you need to do is to play a music file, turn off the shuffle from there, and then play the audiobook.

    It makes sense that you can't set Shuffle when playing audiobooks, since you generally won't want to play audiobooks in random order. The problem is that, even when playing audiobooks, the shuffle setting is retained from music player mode. It's very obviously a design defect; shuffle should be automatically OFF when playing audiobooks.


    This worked for me. Thanks very much!!! I actually thought of this solution but didn't try it since it seemed so ridiculous that Apple would miss such an obvious bug.
  • ben peace Level 1 Level 1 (0 points)
    thanks is work thanks ,but like you say apple fix this bug
  • Twodogs1971 Level 1 Level 1 (0 points)
    I have the same problem but none of the above solutions work for me.

    In addition to the above issue I have re-named each file in Itunes to the name of the chapter in the book and added the track number (1-17) and disk number (1-5). These names however do not appear on my iPhone. On the iPhone they appear as 92 files beginning at 1 of 92, 2 of 92 etc and when it gets to the disk 2 files it starts back to 1 of 92. So there is no way to identify the file on the iPhone.

    I have shuffle turned off but apart from playing the files in the wrong order they also loose there filenames.

    Anybody got any other ideas
Previous 1 2 Next