1 Reply Latest reply: Jun 19, 2010 9:41 PM by tanmelvyn
tanmelvyn Level 1 Level 1 (5 points)
I have recently been experiencing some issues with my iPhone.

It has been "automatically" turning "off" my "Show My Caller ID"; resulting in me not being able to make any outgoing calls. This has been really frustrating.

I need to turn "on" my "Location Settings" (which I prefer to leave it off as it consumes more battery juice and I really don't need it as much - I can live with turning it on only when I need it, like using Maps). When I turn "on" my "Location Settings" the "Show My Caller ID" will then be turned "on", hence allowing me to make outgoing calls.

This is an issue as unless I subscribe to the "Block my caller ID" service with my cellular network, I am not able to access the "Show My Caller ID" function (its 'greyed' out).

I am with SingTel in Singapore.

Anyone with similar experiences?

MBP 15" / iMac 24" / iPhone 3GS / TC2TB, Mac OS X (10.6.2)