7 Replies Latest reply: Jan 17, 2010 1:40 AM by Terence Devlin
thefarnz Level 1 Level 1 (10 points)
I'm having trouble importing photos from my Kodak DX4900 Zoom. When I click on "import all" I get an error message saying "The following file could not be imported. (The file is in an unrecognized format)". The photo formats are: DCP_xxxx.JPG. According to iPhoto help that is a recognized format. What could be the problem. This has happened since my upgrade to Snow Leopard.
Thanks

MacPro1,1, Mac OS X (10.4.8)
  • Old Toad Level 10 Level 10 (128,820 points)
    Use Image Capture to upload the photos to a folder on your Desktop and see if you can import from there. If not, open them with Preview and save as a new jpg file. Then try importing the new files.


  • thefarnz Level 1 Level 1 (10 points)
    I tried uploading using Image Capture & got virtually the same error message. I admit I don't know how to use Preview to open them. Can you direct me?
    Thanks again
  • Old Toad Level 10 Level 10 (128,820 points)
    You have to get the files onto the hard drive before you can open them with Preview. If you have a card reader try using that to copy them to a folder.

    You might have to find another computer, PC or Mac to see if you can download them there and then burn to a CD or copy to a Flash drive. Once you have the photos off the memory card reformat the card with the camera and see if you can take some test photos and import into iPhoto. Could be a card format or damage issue.

    Once you have the files on the hard drive just drag them onto the Preview icon to open.
  • LeeHammond Level 1 Level 1 (0 points)
    I have the same error message when I copy JPGs from my network to my new iMac. These JPGs were created in CaptureOne on a PC. If I open in Preview and save as a JPG2000 file, then I can open in iPhoto. This is not a good workaround as I have hundreds of pictures to edit. There must be a better way!

    Lee
  • Terence Devlin Level 10 Level 10 (134,510 points)
    The usual cause of this issue is malformed metadata on the files.

    Graphic Coverter can batch process images.

    Regards

    TD
  • hilk09 Level 1 Level 1 (0 points)
    I am having the same problem with unrecognised format, after upgrading to Snow Leopard. Prior to this, never any issues with importing photo files (from the same camera). I have also tried formatting the camera (Canon IXUS 970) card. Surely there is a simpler method, than previously detailed, to import all the photos?
    What exactly does the graphic converter you've specified do to resolve the issue? Any help appreciated.
  • Terence Devlin Level 10 Level 10 (134,510 points)
    If, as is often the case, the cause of this issue is malformed metadata, then opening and saving the file in Preview will allow the files to be imported.

    Graphic Coverter can do this too but also has a batch processing capability - in other words, instead of tediously opening each file in Preview individually, then saving it, it will do this for you on multiple files.

    You could try a simple test:


    Hold down the option (or alt) key key and launch iPhoto. From the resulting menu select 'Create Library'

    Will the pics import into this new, blank library?

    Regards

    TD