12 Replies Latest reply: Jan 3, 2010 3:01 PM by David Bourne
Brian Trimble Level 1 Level 1 (0 points)
I have the following questions regarding updates and support of Java 1.5 related to the information provided herein:

Question 1 - Is there a way to "roll-back" the OS X Java 10.6 Update 1 update?

Question 2 - Why are we removing support for Java 1.5 with the current Java 10.6 Update 1?

Question 3 - Is there a known fix for resolving the Juniper SSL/VPN Network Connect 6.5R1 issue?

Juniper VPN "Network Connect" was working on 10.5.8 until I updated with the latest OS X Java Update which disabled Java 1.4 and left my Java 1.5 and 1.6 intact. The result when using Juniper SSL/VPN 6.5R1 was that I could establish a VPN session, but when attempting to load the "Network Connect" I received the error: "An error occurred while extracting one of the Network Connect components."

After research, it sounded like I stood a better chance of resolving this with an upgrade to Snow Leopard. The upgrade, my first OS X upgrade, went well from a Juniper perspective. The resulting Java preferences listed 1.5 (64 and 32 bit) along with 1.6 (64 and 32 bit) Following the upgrade to 10.6, I was able to establish a VPN connection and a Network Connect session - Success!

Then came the software update notice for 10.6.2 and Java 10.6 Update 1. Only having worked with OS X 10.5 (I purchased my first MacBook Pro July 2008), I became comfortable with Apple's update process and applied these updates. After updating, I could no longer establish a Network Connect session, receiving the same error listed above for 10.5.8: "An error occurred while extracting one of the Network Connect components." My Java Preferences now indicated only support for Java 1.6 (64 and 32 bit).

I am working with our staff who support the Juniper VPN and trying to get them to initiate a JTAC report. I also see multiple references that indicate I may need to reinstall Java 1.5 but before I do I would prefer to roll-back the Java 10.6 Update 1 update to see if that fixes my issue.

MacBook Pro, Mac OS X (10.6.2), Juniper SSL/VPN 6.5R1