3 Replies Latest reply: Dec 29, 2009 3:34 PM by Ryanmullen
HelloJenn Level 1 Level 1 (0 points)
I've been on iTunes seven for just about ever, because I had problems with downloading 8. Now I bought a new iPod and I need iTunes 9, and I can't do it.

"This version of iTunes has not been correctly localized for this language. Please run the English version."

I've tried deleting the cache, moving the library, deleting iTunes and reinstalling it from the website.

Help if you can.

MacBook, Mac OS X (10.4.11)