4 Replies Latest reply: Jan 6, 2010 11:10 PM by vinci_78
sozemediagroup Level 1 Level 1 (0 points)
Hi, I had stopped using logic express a while back for the simpler garageband alas my quality was hurt so i'm coming back. Problem is that now when vocals are going into the mic there is a delay coming out of the headphones. When I finish the recording the vocals and play them back they sound on point with no delay. Problem is that the delay throws off my singer as they hear their words a second later. How can I fix this?

MACBOOK, MAC MINI, Mac OS X (10.4.11), MACBOOK IS OS X 10.4.11 and mini is on leopard
  • sozemediagroup Level 1 Level 1 (0 points)
    I just saw on a youtube tutorial that logic naturally has a slight delay when you use the software monitoring on but when I turn it off I can barely hear myself at all even with the direct monitoring activated on my interface and turned all the way up.
  • DaddyPaycheck Level 6 Level 6 (16,035 points)
    How much RAM do you have installed in this machine?
  • hipnautica Level 1 Level 1 (10 points)
    This is a common problem with Latency which you can set within

    Logic Express > Preferences > Devices /CoreAudio I use Presonus Firestudio for my device and under that it lists I/O Buffer Size which I currently have set to 1024 Samples and I have I/O Safety Buffer checked.

    Recording Delay is set to 0

    I turn off Software Monitoring when recording effects, when trying to run live effects and record or perform live with effects on the vocals you will end up with god awful delays... this is a very disappointing feature.

    I'm currently staring to explore setting up External Effects to run through my Firestudio Project Send/Return 1, essentially creating an external effects loop, and then hopefully I can find a way to route Mic 1 and Mic 2 to this external effect loop and control the amount of effect on each track independently.

    I'm told this is possible but I've not found any clear support to do it.

    However for you for now turn off effects and turn off software monitoring when recording your vocals and you should be fine. You might have to experiment with your I/O Buffer settings too.

    good luck
  • vinci_78 Level 1 Level 1 (0 points)
    hey, I had a real irritating delay when I had my piano plugged into one of the usb plugs in the back of my computer - took me forever to figure out that it was that particular usb jack that has a delay. This might be way off, but try a different input jack!