Previous 1 12 13 14 15 16 Next 234 Replies Latest reply: Feb 12, 2015 3:34 PM by Alley_Cat Go to original post
  • vazandrew Level 6 Level 6 (17,210 points)

    Not true, its only a few percent it needs before it starts (which is 5 seconds if network meets requirements). It continues to load yes but that doesn't mean it will take longer unless the connection is so sporadic that it needs to pause and buffer.


    I don't think you've seen the lowest quality on Netflix (0.3 Mbps), it's unwatchable. Itunes is 3mbps regardless, and while its noticeably different from HD it's still a lot better in comparison to the other at its lowest.


    Bottom line this is a network issue and its up to you what you want to do about it.

  • bblake12 Level 1 Level 1 (0 points)

    You keep stating the same thing (Network Issues) over and over again while more and more people are reporting the same issue. ATV cannot be used to reliably rent and watch a streaming movie instantaneously like Netflix. I have gone through 2 movies this week with 5+ hours to wait until I could watch them. I switched to my Xbox and watch instantaneously. The problem is most likely with Apple and the ATV device. It should be built to handle the worst netwrok setting and only get better with better networks if they are going to offer on-demand streaming. Oh and by the way, it does not start when a small portion is loaded.



  • vazandrew Level 6 Level 6 (17,210 points)

    That's because it is network issues that cause this. I would hardly say the majority of users are experiencing this. Netflix is a separate service and it's constantly adapting to the network (can go as low as 0.3mbps). iTunes is fixed and yes it does start once a portion has loaded (a few percent, it starts after 5 seconds for me as well as others that have a reliable network). Netflix is also available on the device.


    HD streaming requires a sufficient network. What you are asking would require adaptive streaming and when one is using PPV it should be higher quality.

  • natrat22 Level 1 Level 1 (0 points)

    I have the same problem.  Downloads from all other devices in my home are fine yet when I order a movie on the Apple TV it takes 30-40 mins to allow playing and is downloading so slowly that you catch up to the movie and it pauses again for 10 minutes, ad nauseum.


    I've used two different modems, hardwired the apple TV to the modem and tried wireless, same issue.


    Basically we need to order the movie around three hours before we want to watch it then leave the ATV to download it before we commence watching it.


    It didn't always do this, it used to be fast.  Nothing has changed on my network apart from me trying different modems (and cables etc).

  • bblake12 Level 1 Level 1 (0 points)

    Last week I switched out my cable modem with a new Docsis 3.0 Motorola Modem, I then upgraded my Linksys N Router with a Netgear Dual N 450 router. This was about a $350 upgrade but it has fixed my issues. The 5Ghz band on my Linksys router never worked properly but the Netgear is fine. I am not sure if I needed to switch out the cable modem but for the minimal expense I decided to make the change. Now my  purchased movies start immediatly.



  • bblake12 Level 1 Level 1 (0 points)

    I feel vindicated sort of -


    Apple is issuing replacments for Apple TV units that have persistent Wi-Fi issues.

  • RichEE2K Level 1 Level 1 (0 points)

    What is most annoying from my perspective is I started downloading the movie a day ahead of time and had it "qued" up to play when I was ready to watch it. When I return to watch the movie, I had to wait for it to download all over again.


  • Linelle Lane Level 1 Level 1 (105 points)

    I bought an Apple TV last weekend, easy setup, then bought Season 2 of Game of Thrones through the ATV. For some reason, the first episode downloaded okay, although I admit I didn't watch it until the next day, so download could have been slow and I didn't notice.


    After that downloading was down to a crawl, 8-10 hours projected download time. This was from the cloud. Reset both wifi router and ATV multiple times. Trying to watch the show on iPad or MBP was a similar situation. Meanwhile, all other streaming sources (from other than iTunes) went quickly. I was beside myself.


    I wrote to Apple (via my ATV receipt link), told them my tale of woe and asked for a refund. Early the next day I had a very nice reply from a real person. She apologized for the trouble this caused me and told me a refund was currently in progress. All things considered, I was happy with the result. I turned around and bought the season from Amazon, which I am happily watching on my Roku-HD. Same price.


    I think something is wrong with iTunes.

  • benichols Level 1 Level 1 (0 points)

    I would like to add to the discussion here.


    Comcast Infinity user always with consistent >30mpbs download speeds (


    Buying a movie via the AppleTV is so painfully slow that I had comcast come out to check my connection (no problems seen).  This was not a problem > 6 months ago.  I KNOW this is an iTunes problem because I have no issues buying and watching movies instantly via Comcast On Demand (even the same movies).  It will take DAYS to download an HD movie on my AppleTV so I will likely never buy another movie again on my AppleTV.  BTW, the AppleTV is hard wired (ethernet cable cat 6) to a brand new Airport Extreme.


    So for those that claim "network issues" you are wrong - at least in my case.

  • DutchPower Level 1 Level 1 (0 points)

    comcast 36mbps here according to


    Through the Apple Movies app, I was attempting to watch a movie I've already purchased in my appleTV, and was given the message that it would be also taking 8 hours and 55 mins to download. A half hour later it was ready to play, but it stopped about every 3 minutes to load another 3 minutes.


    Apple servers are the problem here - not on my end.


    Netflix seems to work fine through the appleTV.


    I've spent a few hundred on movies (purchases and rentals) over the past year and never had this problem. It seems as AppleTV servers become more laden with data use, the problem has just started to crop up. I'm in Chicago and likely on a unique region specific set of servers and have latest gen ATV just to give some extra data on the issue I'm having


    Any reply regarding this by Apple?

  • txhotlink Level 1 Level 1 (0 points)

    I am having the same problem this is rediculous. With all apple's cash it needs to fix this issue!!!


    I have download speeds of 11Mpbs confirmed by Once I purchase or rent a movie it takes up to two hours to download at least half to allow you to start watching it and if you accidentally fast forward to section you dont have it makes you start all over again. What a joke.


    Apple get this fixed...

  • vazandrew Level 6 Level 6 (17,210 points)

    Speed is only one factor. There are many other things like interference, DNS etc that can cause issues. If you have done the proper troubleshooting feel free to contact Apple as this is a user forum.

  • rebelnjackson Level 1 Level 1 (0 points)

    great idea.. I have the same problem.   Stupidly spent $50 to download a tv series to load onto my ipad to take on an upcoming 14 hour flight.  It has been downloading to itunes now for about 40 hours.. 

  • Krash4882 Level 1 Level 1 (0 points)

    I'm having varying intermittent issues on two ATVs on my AT&T UVerse wireless network. 


    - ATV says it can't connect to iTunes Store (hit menu, go back into movies or tv, eventually it will work)

    - randomly says home sharing is off (my computer is always on and awake with iTunes and home sharing on, so I just turn it off and on or restart iTunes and it fixes it)

    - TV shows or movies going from instantly ready to watch to saying it needs 3+ hours before its ready (sometimes flips between 30 minutes and 12 hours - speed test 11mbps


    All software and firmware updated.  Restarts/resets/restores tried

  • vazandrew Level 6 Level 6 (17,210 points)

    Intermittant issues can often be a cause of interference. Have you checked istumbler or netstumbler to verify?


    In regards to the time before content is 'ready to watch' ..have you checked DNS, sometimes ISP throttling (or other factors on their end) can be an issue.