Previous 1 12 13 14 15 16 Next 235 Replies Latest reply: Dec 25, 2015 8:23 PM by Vargovanova Go to original post
  • jens glindorf Level 1 (0 points)

    We experienced a 10-14 hrs wait for download this evening.
    We cut the power to the AppleTV box - and when it came back on - film started instantly.

  • jens glindorf Level 1 (0 points)

    Hope that solves your problem too.

  • jody282 Level 1 (0 points)

    Just my two cents, but I don't think the issue is with Apple's services. There seems to be quirks with the Apple TV itself. I never had issues with my Apple TV. Movies streamed well, until today. I haven't used it in a while, so not sure if it was the iOS software update I just did or recent switching of my modem by AT&T. Tried several things and was ready to give up, download times for HD said 34 hours.  Then I went into the menu and chose the Reset option to set back to factory defaults. I reconnected to my wireless network and re-entered my apple id. Went to my rental and it started almost right away.

  • MeD8RTom Level 1 (5 points)

    I was having the same problem. I was waiting forever for the movie I rented (Hunger Games) to download. I restarted the ATV, and as soon as I hit Play my movie began to play right away. Maybe just coincidence, but it worked for me.

  • mlilly2233 Level 1 (0 points)

    I don't have issue with movie starting.  It does so ASAP.  My problem is on 3 occasions, the third one tonight, the ATV gets flipped off the movie and once that happens you are screwed.  I personally cannot get it to play again.  It says "you have already purchased, go to a Settings, iTunes Store and then Check for a Rentals".  It grinds for hours and inget fed up and go to friggin bed.  This is awful.  From no on I rent with my cable company because if you somehow stop the movie, at least they are smart enough to gave play button where the rent me button used to be.  Give me Roku.

  • PaulAFC Level 1 (0 points)

    My Apple TV was fine until the last few days, full HD films would play within seconds, now even on lowest res. waiting time is 2 hours, my Netflix seems to load fastest in SD, but iTunes movies and box sets, I don't watch now due to loading time.

  • Paxarous Level 1 (0 points)

    jens glindorf, thank you very much! I was experiencing the exact same problem, cut the power (per your suggestion) and voila! Streamed beautifully without a hiccup right after it rebooted.

  • Chuck0819 Level 1 (0 points)

    Had that same problem awhile back. Solution was to do a full restore via iTunes by hooking it up to my computer with a USB cable.  A little time consuming but did the trick.

  • Sir Irving Level 1 (0 points)

    It is funny, using the Netflix or the YouTube app on the ATV works fine but it does not as well with rental or purchased movies from iTunes. Sometimes, I have to download a movie directly on my iPad and then airplay it to the ATV.

     

    It is a shame that we have to wait about an hour to watch a movie. I have a nice connection and I hope the next firmware update allows you to play instantly without "save on buffer before play".

  • Alley_Cat Level 6 (19,190 points)

    AppleTv rentals are fixed size whereas Netflix is rate adaptive reducing quality as a trade-off for near instant starts on slower connections.

  • Vargovanova Level 1 (0 points)

    It's nearly 2016 and Apple TV still takes hours t prepare a movie for viewing!  This is astonishing.

Previous 1 12 13 14 15 16 Next