6 Replies Latest reply: Jan 27, 2010 3:43 AM by hixet wood
DavidRedmayne Level 1 Level 1 (0 points)
When I use google (or any search engine) and click on a provided link, the browser re-directs to www.google2.com then another 'search engine'. This happens for the first time only - if you click the link again, the correct page loads.

This happens with Firefox and Chrome too! I've run iAntiVirus which detects nothing! Any ideas?

Thanks

Mac Mini Intel, Mac OS X (10.6.2)
  • Golden Shoes Level 5 Level 5 (4,015 points)
    Since there is no google2.com domain, that sounds like your ISP may be interfering with your browsing. Try changing your DNS Servers:

    Quit Safari if it's running.
    Open System Preferences > Network > Advanced and in the window where DNS Servers are located, add these two at the top of the list:

    8.8.8.8
    8.8.4.4

    click Apply Now and quit System Preferences. Then restart Safari and see if the problem continues.
  • DavidRedmayne Level 1 Level 1 (0 points)
    Thanks Golden Shoes - worked first time!
  • SEPTBOY Level 1 Level 1 (0 points)
    i had the same problem and i tried GOLDEN SHOES'S solution, and it worked first time for me, too!!! i dont understand what the solution does, but i am very grateful.
  • SEPTBOY Level 1 Level 1 (0 points)
    hi, golden shoes. i, also, used your advice found here to solve my problem with safari redirecting. i dont understand what your solution means, and i was wondering if you'd have a moment to explain 1) what the ISP is doing interfering and why, and what we can do about that, 2) how does the 8.8.88 and 8.8.4.4 solve the DNS problem?

    thanks so much for your help!!! not often does one stumble across the perfect solution. David
  • shorts Level 2 Level 2 (455 points)
    For those wanting to know about the DNS numbers, if you do a whois on them you'll find that the IP addresses are Googles.
  • hixet wood Level 1 Level 1 (0 points)
    Golden Shoes has remedy for 10.4 etc I have 10.3.9 and when I follow his route to Network -there is no ADVANCED so I cannot proceed to alter DNS servers as recommended. Has anyone a remedy for this annoying intrusion --which will work with 10.3.9?