5 Replies Latest reply: Jan 18, 2010 6:38 AM by dicty2
TimoHesse Level 1 Level 1 (0 points)
Hi everybody.

I just seem to not find the right article about how to delete individual items of my autofill-list in Safari. Maybe I'm not searching for the right words. Please help.

You know, when you type something in the address field or a search field on a website Safari remembers the words. That's fine, I want that, but from time to time I want or need to delete just a few of the suggestions and not the whole history. Using Firefox on a Windows Machine you just had to mark the particular word and hit the delete button. How do I do it with Safari?

Thanks a lot.

Mac OS X (10.6.2)
  • Carolyn Samit Level 10 Level 10 (100,425 points)
    HI and Welcome to Apple Discussions...

    From the Safari Menu Bar click Safari / Preferences - Autofill

    Click the Edit buttons.

    Google Search Basics











    Carolyn
  • Golden Shoes Level 5 Level 5 (4,015 points)
    First off, what you're referring to is Autocomplete, not AutoFill.

    You can't delete individual items from your History, or even from the Google search window. If there are some sites you don't want to be suggested because you never read them anymore, you'd need to delete those from your Bookmarks list(s). If you just don't want any suggestions made when typing a URL in Safari, press the spacebar before you start typing and that will prevent it.

    As for the Google search suggestions, you can't get rid of those unless you clear your History before quitting Safari. You could install Glims, which gives you the option to turn off all Google search suggestions, as well as limit the number of them.
  • TimoHesse Level 1 Level 1 (0 points)
    You're right, it is autocomplete not autofill. Guess that was my first mistake when I tried searching for answers. Thanks.

    So you say it's not possible to delete individual items from the autocomplete-suggestions-dropdown-menu at, let's say, bookbutler.com, right? No addon or anything? ****, it's making me crazy.

    Message was edited by: TimoHesse
  • Golden Shoes Level 5 Level 5 (4,015 points)
    Sorry, you just can't do that; no add-on that will do it, either.
  • dicty2 Level 1 Level 1 (0 points)
    I spent a lot of time on this and found the solution was a bookmark that was 'hidden' under a misleading title. I kept getting 'easyorchids.com' (which I had looked at once, years ago) when I wanted 'easyjet.com'. It turned out that easyorchids.com was hidden under 'orchid propagation'.

    The solution is to go to 'show all bookmarks' then put the offending autocomplete (in my case 'easyorchids') into the search box at the top of the page. This will return any bookmarks where this string appears (there were two in my case). Select all of them and press the delete key. Hey Presto.

    I'm not saying it will solve all problems but it worked for mine.