10 Replies Latest reply: Jan 2, 2010 1:45 AM by kjvarga
ironpaw Level 1 Level 1 (0 points)
So I just got this brand new Airport Express a couple of days ago, and I've had the darndest time trying to get this thing to work with my cable modem. I've conducted a number of experiments, and have performed factory resets on the airport more times than I care to talk about, but so far nothing has worked. Here is what I've gathered so far:

1) No matter what, whenever I try to connect to the Airport Express' wireless network, I get a connection timeout or some other error. This happens whether I attempt connecting via the Airport Utility, or manually using the airport icon in the toolbar.

2) As a result of #1, it's completely impossible to configure my airport express wirelessly, because when the Airport Utility tries to connect it just ends up giving me an error.

3) As such, I have tried configuring the airport express by hooking it up to my computer via ethernet cable. Once I do that, I am able to configure to my heart's delight, but then when I plug the Airport back into my cable modem, I am once again no longer able to connect wirelessly because of connection timeouts.

4) My connection timeout issues happen whether the Airport's light is solid amber, flashing amber, or solid green. They would probably still happen if the light was fuchsia or cerulean. As far as I can tell, the status light makes no difference whatsoever.

5) I have the most up-to-date firmware on my airport express.

6) I have the most up-to-date version of the Airport Utility.

7) I have run an ethernet cable directly to my laptop from my cable modem and the internet works fine, so the problem is not coming from my ISP.

8) My laptop (15" Macbook Pro running OSX 10.5.8) is able to connect and maintain connections to other wireless networks without any problems.

I'm at a loss. All I want is wireless internet. It can't be that hard, right?

Help!

Thanks in advance.

MacBook Pro 15", Mac OS X (10.5.8)
  • Bob Timmons Level 10 Level 10 (86,970 points)
    Welcome to the discussions!

    You have the AirPort Express (AX) configured to "create a wireless network", correct?

    Once you have the AX configured and before you connect it to the cable modem, are you pushing the reset button on the modem and also powering down the cable modem for at least 25-30 minutes and pulling the modem's battery? (If the battery is easily accessible).

    Please give that a try if you have not already done so, and post back with your results.
  • ironpaw Level 1 Level 1 (0 points)
    Hi Bob - I have already tried that to no avail (My cable modem has no battery, so I unplugged it and let it sit for over an hour).

    And yes, my AEX is configured to create its own network.

    Again, no matter what I do, I've found it impossible to connect to the AEX wirelessly.
  • Bob Timmons Level 10 Level 10 (86,970 points)
    Just a hunch.

    On your MacBook open System Preferences and click Security

    Click the Firewall tab

    Is is set to allow all connections?

    Do you have any other anti-virus programs running? If so, turn them off as well to see if that makes a difference.
  • ironpaw Level 1 Level 1 (0 points)
    Yes, it is set to allow all connections.

    I don't have any anti-virus program running, but I went ahead and shut off bluetooth and anything else on my macbook that could potentially use wireless, and I'm still getting the same result as before.
  • Bob Timmons Level 10 Level 10 (86,970 points)
    Any way to test using another computer to see if it can connect? If the other computer cannot connect either, it's time to suspect a possible defective AX. If it can, you know the AX is working correctly and it becomes a troubleshooting task with your MacBook.

    As a test, maybe set the wireless security to "none" temporarily to see if you can connect with your computer that way?

    What Radio Mode are you using? Maybe try a few different settings there as well.

    AirPort Utility > Manual Setup > Wireless tab > Security & Radio Mode settings.

    Really not sure what else to suggest at this point, but will think on it.
  • ironpaw Level 1 Level 1 (0 points)
    I don't have another computer to use, but I did just try connecting to the AEX with my mobile phone (a MyTouch) and it seems like it's having basically the same problem .

    The security setting is "none" currently and I'm still having the same problem.

    I'll try the radio mode and get back with results.
  • Artemisalm Level 1 Level 1 (0 points)
    In your network preferences are you connected to "Using DHCP" and below that "automatically"?
  • ironpaw Level 1 Level 1 (0 points)
    Figured it out!

    Turns out all I had to do was switch the radio mode from 802.11n (802.11 b/g compatible) to 802.11n (802.11a compatible).

    For anyone else that may be having this problem in the future, you can make this adjustment in the airport utility, under the "wireless" tab, in "radio mode" drop-down menu.

    Thanks to Bob for all your help. Much appreciated. Case closed.
  • Bob Timmons Level 10 Level 10 (86,970 points)
    Thanks for the feedback.

    I'm still puzzled though, as the 802.11n (802.11b/g compatible) mode should allow virtually any modern device to connect as long as it supports WPA/WPA2 encryption and it has the right password for the network.

    Can your iPhone connect to the 802.11a/n setting OK?
  • kjvarga Level 1 Level 1 (0 points)
    I had a similarly perplexing experience today. My AE - which I have been using trouble free for months - was blinking amber this morning after a particularly heavy download session. Usually a modem restart fixes the problem...but not this time.

    After many many resets I was completely unable to connect to the modem wirelessly. I was able to connect when connected to the AE over ethernet. However after applying settings to the AE I was unable to connect wirelessly or over ethernet.

    Setting the AE to use 802.11n (a compatible) did not immediately fix the problem, but I've no doubt that I would still be without luck if I hadn't applied that setting. However after removing all previously stored Preferred Networks, shutting down the computer and modem and then connecting the AE to modem and restarting everything I got green lights on the AE.

    My computer still could not "see" the AE using the Airport Utility. The network did appear in my network list tho, so I selected it and was able to finally join the network. Only after joining the network did Airport Utility pick up the AE.

    That's almost 3 hours of my Saturday afternoon wasted, but I'm just glad to have wireless internet again.

    The key here appears to be configuring the AE while connected via ethernet and then trying out the various settings while it's connected to the modem.

    It ***** trying to debug internet-related problems because you clearly need the internet to debug them! (ed: wow, suck* is a banned word!)

    Message was edited by: kjvarga

    Message was edited by: kjvarga