2 Replies Latest reply: Dec 16, 2009 2:59 AM by michael.richardson
michael.richardson Level 1 Level 1 (0 points)
Hi,
I'm having an issue when trying to play any video online. Every time I click play, it appears to start to load the video but then stops (freezes - like the browser has crashed). About 10/20 seconds later I get a box appear saying ...

"A script in this movie is causing Adobe Flash Player 10 to run slowly. If it continues to run, your computer may become unresponsive. Do you want to abort the script? Yes/No"

I've tried installing and using Firefox instead but the exact same thing happens. Pressing Yes or No makes no real difference as the application just seems to crash and then I have to Force Quit.

I have tried downloading and reinstalling Adobe Flash Player 10, but it makes no difference. If anyone has any ideas how I can resolve the issue then any help would be much appreciated!
Many thanks!

MacBook (Late 2008), Mac OS X (10.6.1)
  • Carolyn Samit Level 10 Level 10 (96,815 points)
    HI Michael,

    You need to UNinstall the Flash Player plugin you have and reinstall a fresh copy.

    Uninstall Flash

    Install Flash

    Then maintenance...

    From the Safari Menu Bar, click Safari / Empty Cache. When you are done with that...

    From the Safari Menu Bar, click Safari / Reset Safari. Select the top 5 buttons and click Reset.

    Might be a 3rd party plugin causing the problem. Go to ~/Library/Internet Plugins. Move any 3rd party plugins to the Trash.

    Also, if you are running Safari in 64 bit mode, try running in 32-bit mode instead. Right or control click the Safari icon in the Applications folder, then click: Get Info In the Get Info window click the black disclosure triangle next to General so it faces down. Select 32 bit mode. Also, (in that same window) make sure Safari is NOT running in Rosetta.

    If nothing above helps, download and install the 10.6.2 combo update available here.

    Mac OS X v10.6.2 Combo Update

    And repair disk permissions...

    Quit any open applications/programs. Launch Disk Utility. (Applications/Utilities) Select MacintoshHD in the panel on the left, select the FirstAid tab. Click: Repair Disk Permissions. When it's finished from the Menu Bar, Quit Disk Utility and restart your Mac. If you see a long list of "messages" in the permissions window, it's ok. That can be ignored. As long as you see, "Permissions Repair Complete" when it's finished... you're done. Quit Disk Utility and *restart your Mac.*








    Carolyn
  • michael.richardson Level 1 Level 1 (0 points)
    Hi Carolyn,
    Many thanks for your help, I've tried your steps and the problem seems to be fixed
    Just out of interest, what caused this to happen? The only thing I can think of is that I recently have been starting to use the 'CleanMyMac' application....do you think this may have caused the problem? If so, what settings should/shouldn't I use when using this program to stop similar problems occuring?

    Many thanks!