1 Reply Latest reply: Jan 9, 2010 10:45 PM by drfong
Danhard133 Level 1 (0 points)

I have a 2nd Generation iPod Touch. Recently, I tried to update the Apps on my iPod directly on the iPod by visiting the updates section of the 'Apps' app. After typing in my password, the updating apps went, as usual, grey and said 'waiting' with a progress bar.

One week later, they still say 'waiting' even though there is no doubt that my Wifi is working- I am using it now. Restarting my iPod doesn't work, neither does trying to download other apps- they all get stuck on 'waiting'.

I cannot delete them, because there is no option to delete them. I also tried updating them on iTunes and then syncing- but it doesn't work because for some reason everytime I click update on the iTunes store, nothing happens!

Does anyone else have this problem, since last Wednesday? What do i Do??!

Sony Vaio AR51M, Windows Vista
  • drfong Level 1 (0 points)
    I also have this problem with my 3rd gen iPod Touch, and I've been able to install apps wirelessly in the past.

    I have a perfect wireless connection and can access the Internet through Safari and stream my Pandora radio.

    I've restored and synced the iPod multiple times, deactivating and reactivating my computer as well, but the problem remains the same. After requesting the app, it doesn't initiate the download.

    In addition, if I request "My Account" info from Settings, I get the timeout message "Cannot access iTunes Store"