Previous 1 2 3 Next 68 Replies Latest reply: Jan 2, 2016 12:08 PM by Shumi D
sciamos Level 1 (0 points)
Each time I start Safari, the toolbar is missing and I have to go into the VIEW menu and turn it back on. Each time a new window pops up, same thing.

I have tried ensuring that all windows have the toolbar before closing it down, but this has not helped.

This just started about two weeks ago.

Anyone have some ideas? I had installed nothing new.

MacBook Pro (2009.5), 4gb
  • Martin Warne Level 1 (30 points)
    Same for me!

    It's really quite annoying and I can't find a preference setting anywhere to put the toolbar back by default.
  • ~Bee Level 7 (31,425 points)
    Hi sciamos --
    Welcome to apple discussions!
    Have you (or Martin) recently added any internet "enhancers" to your Mac?
    Like SafariStand, BookMacsters, or other haxies that claim to make browsing better?
  • Dino Ilarde Level 2 (335 points)
    The same thing has been occurring with me. I updated my version of ClicktoFlash last week and thought that might be the culprit, but after dumping it today, the problem remains. I've also reset Safari and trashed, as suggested elsewhere in this forum. The only other thing I've done in the last week is update FlashPlayer, which, in the past, has never produced any problems.
  • sciamos Level 1 (0 points)
    Glims but months ago and this started two weeks ago...
  • Carolyn Samit Level 10 (103,360 points)

    It helps us to help you if you provide which Mac OS X you are running on your Mac. Please click My Settings on the right side of this page and complete your forum profile. Thanks!

    From the Safari Menu Bar, click Safari / Empty Cache. When you are done with that...

    From the Safari Menu Bar, click Safari / Reset Safari. Select the top 5 buttons and click Reset.

    And make sure Safari is not running in Rosetta. Right or control click the Safari icon in your Applications folder then click Get Info. In the Get Info window click the black disclosure triangle so it faces down. Where you see Open using Rosetta... make sure that is NOT selected.

    You posted in the Snow Leopard forum here so.. read the following.

    If you are running Safari in 64 bit mode, try running in 32-bit mode instead. Right or control click the Safari icon in the Applications folder, then click: Get Info In the Get Info window click the black disclosure triangle next to General so it faces down. Select 32 bit mode.

  • Dino Ilarde Level 2 (335 points)
    Carolyn, speaking for myself, I currently run Safari in 32-bit mode because of work-related stuff. Also, Rosetta is deselected.
  • sciamos Level 1 (0 points)
    No Rosetta and all the resets didn't work.

    I also cannot figure out how to remove Glims to give that a try!
  • Dino Ilarde Level 2 (335 points)
    I happened to have System Preferences open and discovered a Preference Pane that I never installed (not knowingly, anyway). It's called Spice Rack and it installed a plug-in of the same name. I trashed it and all is well now.
  • sciamos Level 1 (0 points)
    I finally found a program that removed GLIMS and I am still suffering the issues of the disappearing toolbar

    I've tried all of the suggestions to no success...
  • Dino Ilarde Level 2 (335 points)
    sciamos, try what I did, and check for any unwanted Preference Panes in System Preferences. It was a total fluke that I even found it, but it was something I couldn't recall installing myself. I think that maybe a web site I'd visited installed it in order for me to view multimedia, or something like that. Whatever the case, it sure worked negatively on Safari.
  • Jonas Hansson Level 1 (20 points)
    I had the plugin for an application called Videobox installed. This gave that exact effect. Uninstalling the plugin (for instance using the Videobox application to do so, the Safari uninstall command is under Videobox' main menu) helped fix it.


  • sciamos Level 1 (0 points)
    Still happening. I've removed all plugins.

    I'm thinking of erasing it and using the Snow Leopard DVD to reinstall... sound good?
  • sciamos Level 1 (0 points)
    Tried a Safari reinstall - no go - still have the toolbar disappearing.

    Can't Apple do an update?
  • oregonjan Level 1 (0 points)
    I had the same problem, the fixes listed above did not fix the toolbar. I also looked in system preferences and had the tasty app thing also, which I did not download. removed it and all is well.
Previous 1 2 3 Next