Skip navigation

Safari Mac Toolbar keeps disappearing - help!

243587 Views 56 Replies Latest reply: Apr 5, 2014 6:25 AM by nelmafromok RSS
  • Martin Warne Calculating status...
    Currently Being Moderated
    Feb 12, 2010 6:01 AM (in response to ~Bee)
    No, nothing at all.

    Since my last post I have upgraded to Snow Leopard, but that hasn't really made any difference with this issue.
    MacBook (unibody), 250 Gb HDD, 4 Gb RAM, Mac OS X (10.6.2)
  • Tsimi Calculating status...
    Currently Being Moderated
    Mar 14, 2010 10:51 PM (in response to sciamos)
    I'm also struggling with the recent problem in which the Safari toolbar keeps disappearing. I've tried all the great many recommended suggestions to cure this to no avail. Why doesn't Apple itself do something about this serious problem? So far Apple has just sat back and done nothing!!!!

    It is a real nuisance to have to keep going up to the menu have the toolbar added. That toolbar is needed every time you need to go back to a previous page or to enter a new internet address to go to.
    iMac6.1, Mac OS X (10.5.8)
  • Rookaloo Calculating status...
    Currently Being Moderated
    May 23, 2010 10:57 AM (in response to Tsimi)
    No place to type in a URL. Snow Leopard is updated. Safari has been reinstalled. "View" says all bars (Status, Toolbar, etc.) are showing but none are. Called Apple; got nowhere.
    MacBook Pro, Mac OS X (10.6.3), Safari 4.0.5
  • sleepykat Calculating status...
    Currently Being Moderated
    Jun 11, 2010 1:42 PM (in response to sciamos)
    This keeps happening to me, too! The bookmarks in the toolbar all disappear, for no apparent reason. I can drag them all back from the folder, but while the computer is sleeping, they will all disappear again. Sometimes they disappear from the folder, too, so I can't drag them back. I have tried everything. I am not going to drag them back to the toolbar twice a day. I may just have to use a different browser! It just started this week.
  • ~Bee Level 7 Level 7 (30,590 points)
    Currently Being Moderated
    Jun 11, 2010 1:46 PM (in response to sleepykat)
    sleepy --
    Did you ever download another toolbar to use with another application?
    15" MBP; 20"iMac Duo; 12 PB G4; mini; and a few more., Mac OS X (10.6.3), LaCie Ext. HD
  • greendogusa Calculating status...
    Currently Being Moderated
    Jul 3, 2010 6:24 PM (in response to sciamos)
    Just bought a new imac, had the Store do the data transfer. Everything was good. I'm not a computer whiz, but I did some syncing with MobileMe and noticed my bookmarks tool barstarted disappearing at random times. I found this discussion board, and when I looked up after reading the comments, there was my bookmarks tool bar!!! WTFlowers?
    imac
  • Tsimi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 1, 2010 2:11 PM (in response to Martin Warne)
    I also upgraded to Snow Leopard and still have the problem of having to go the View menu periodically to select "Show Toolbar". What is amazing to me is how long Apple itself has ignored this problem and provided NO answers from their own staff to clear up this problem. I've spent hours looking at the discussions of this issue and, so far, have found no answers that work.

    APPLE, ANSWER THIS PROBLEM!
  • gielletm Calculating status...
    Currently Being Moderated
    Aug 18, 2010 12:24 PM (in response to sciamos)
    Hi all, same problem here, the toolbar keeps disappearing each time I restart Safari. I've no idea of what's going on but it's the most annoying thing I've ever found on a Mac!
    MacBook, Mac OS X (10.6.4)
  • gielletm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 18, 2010 12:35 PM (in response to gielletm)
    Hi, I've done it! I fixed this stupid issue deleting the following file from Home > Library >Safari
    1. LastSession.plist
    2. LocationPermissions.plist
    3. Configurations.plist.signed
    I don't know if those files contain something that is important, but till now everything seem to be ok.
    I hope that this tip could help someone else!
    MacBook, Mac OS X (10.5)
  • craig42a Calculating status...
    Currently Being Moderated
    Aug 28, 2010 6:24 AM (in response to gielletm)
    OS 10.5.8
    Safari version 4.x (up until yesterday)
    Safari version 5.x

    About two weeks ago this began happening to me. No reason. VERY annoying. Upgrading to version 5 did not change anything, as i hoped it would.

    What I do know is that I performed no new installs at the time it began happening two weeks ago. The only change that I did make was adding the Apple "download button" tool into the toolbar. Did this cause it? That would be strange.

    Also, I am running Cosmopod and WebSnapper in the toolbar. Someone here mentioned finding SpiceRack in the Sys Pref pane and I did find that. I never installed it, but in examining it I see it allows you to add things on to your toolbar. Websnapper fell under its control, so maybe its a by-product of TastyApps.com? If not, then who, would be a question. I uninstalled SpiceRack. This did not affect Websnapper. I am testing this new arrangement right now. If this does not work I will follow some of the other advice here and report back.
    MacBook, Mac OS X (10.5.8)
  • ~Bee Level 7 Level 7 (30,590 points)
    Currently Being Moderated
    Aug 28, 2010 6:30 PM (in response to craig42a)
    craig --
    CosmoPod is not compatible.
    And the Tasty apps are nothing but trouble.
    15" MBP; 20"iMac Duo; 12 PB G4; mini; and a few more., Mac OS X (10.6.4), LaCie Ext. HD
  • craig42a Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 30, 2010 8:18 AM (in response to ~Bee)
    Update on my disappearing toolbar issue. I uninstalled SpiceRack from the Sys Pref pane, as I mentioned in prior message here. So far, so good. For the most part the toolbar has remained when I open a new window in Safari. I think SpiceRack was the culprit. I did not disable Cosmopod and WebSnapper and am still using them. Never had a problem with them before and they continue to be non-problematic.

    Since this is a simple thing to do, this should probably be the first step anyone takes when troubleshooting this same problem. If you don't have SpiceRack, then you need to do some of the other fixes people suggested.

    Thanks to all who posted suggestions, and the original poster, who all helped to hunt down this problem.
    MacBook, Mac OS X (10.5.8)
  • warsaw Calculating status...
    Currently Being Moderated
    Sep 21, 2010 4:30 PM (in response to sciamos)
    Same problem here, 10.6.4 and Safari 5.0.2. I have WebSnapper installed too.
    MacBookPro '15 mid 2010 i5 2,4 ghz, Mac OS X (10.6.4)
  • TastyApps Calculating status...
    Currently Being Moderated
    Sep 26, 2010 5:41 AM (in response to sciamos)
    Hi guys,

    I'm the author of SpiceRack here at TastyApps... I am very sorry for the disappearing toolbar bug.

    The culprit here is not SpiceRack, by the way, but Web Snapper's Safari button. We were made aware of it not too long ago, and a new beta is currently being tested to make sure it is stable. As soon as we are satisfied with it, it will be released officially. Please contact me directly (jean at tastyapps.com) if any of you is willing to participate in the beta testing, and I will get you all set-up.

    Unfortunately, we don't have time to look at all the forums out there, so unless one of you takes the time to contact us directly, we might never know, or discover way too late, about a bug... So please, please, please when something likse hits hapens, contact the developer. It'll make for a much better experience for everyone.

    Thanks.
    Mac OS X (10.5.7)
  • ~Bee Level 7 Level 7 (30,590 points)
    Currently Being Moderated
    Sep 26, 2010 8:23 AM (in response to TastyApps)
    Hi jean --

    Thanks SO much for posting in here.
    It's very much appreciated. In the future, I'll ask posters
    here to contact you, if their problem seems to Web Snapper related.
    Very nice of you to pop in here.
    15" MBP; 20"iMac Duo; 12 PB G4; mini; and a few more., Mac OS X (10.6.4), LaCie Ext. HD

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.