Previous 1 14 15 16 17 18 19 Next 279 Replies Latest reply: Jan 7, 2014 10:17 PM by Ponzi Go to original post
  • Litobyte Softworks Level 1 Level 1 (0 points)

    I don't use any external cable. The problem were on the iMac with all the USB detached.


    How can I check what firmware Am I on ?

  • numax Level 1 Level 1 (0 points)

    this referes not to you. the question was about mbp's and sata II

  • Deniz Durmus Level 1 Level 1 (5 points)

    Hi all, I have a 2009 Macbook pro (5,3) with a OWC ssd installed, and it wouldn't even boot up with the EFI 1.7 update, so I had downgraded to 1.6 and had been running it like that for quite a while, though I would still get some sleep lag and spinning beachball from time to time.

    I just changed the hd cable, with a 2010 model hd cable (part#: 922-9314) that is designed for the faster controller, and now I'm running 1.7 without any issues; haven't noticed any sleep lag or the beachball so I assume those were related to the defective cable as well.

    I really think apple should own up to this issue and offer replacement hd cables for people. It's such an easy and cheap fix, that I don't understand why they are refusing to service this issue. I had gone to replace the battery and asked the genius if I could pay for and have them replace the cable, and he said he could only change it with the exact same cable, which would not have helped at all.

  • dlee_nueva Level 1 Level 1 (0 points)

    I purchased my refurbished 2009 MBP (5,3) at the end of 2010 and I didn't notice the beachball of dooms until I upgraded to Lion last year. 


    Thinking it might be the memory, I replaced the memory.  When the beachballs continued to roll, I went a bit further and purchased a Crucial M4 SSD.  The beachballing continued.


    Troubleshooting this issue lead me to the 1.6 downgrade.  That did resolve the beachball issues but I was very disappointed that I may have purchased a "lemon", a laptop that was not futureproof for even a minor spec bump in SATA technology.


    Along with your post, there was another instance I heard replacing the SATA cable allowed their MacBook Pros to go at SATA II speeds.  I had the means to order the part you described so I decided to go for it.


    Using a 2010 MBP SATA II cable (part#: 922-9314), I replaced the existing cable, which oddly enough had the same part number as the new one!  The new cable was different in that it had the "Foxconn" logo printed on the ribbon whereas the former one did not. 


    I re-upgraded my MBP to the 1.7 firmware and for about two days, I have not experienced those beachballs of doom as of yet (knock on wood).  I tested my MBP by playing a Quicktime movie while running the Blackmagic disk speed test and I did not encounter any issues.

  • yamata45 Level 1 Level 1 (5 points)

    dlee_nueva and others,


    Any updates on the use of the new cable? Have the problems went away? Is the nightmare over?



  • dlee_nueva Level 1 Level 1 (0 points)

    Yes, in my case the nightmare is over.  I've had the part for almost a month and I have no problems.


    If I ever get an app to stall/beachball, it's usually isolated to one application (Mail for example) and will not take down the whole system as the case before.  I am still getting mid 200's read/write speeds on my SSD which is consistent with SATA II.  My old 09 MBP is almost just as fast as my 2012 MacBook Air.


    I've now upgraded to Mountain Lion and I'm having no issues whatsoever.


    I highly suggest you try to obtain this replacement part (2010 MBP SATA II cable, part#: 922-9314) if you have still have this issue.

  • dlee_nueva Level 1 Level 1 (0 points)

    I meant read/write speeds under 200 mb/s.  If I was getting mid 200's, the MacBook would have to support SATA III which the 09's certainly do not.

  • ojbravo Level 1 Level 1 (0 points)

    Potential Compatible HDD: 


    Just wanted to chime in for anyone who is finding this post for the first time as I just spent the entire morning reading through all 16 pages...  I have a mid-2009 15" MacBookPro5,3 with EFI Firmware v1.7 and I am wanting to upgrade my OEM Hitachi 5K500 hard drive from 500GB (5400) to 1TB (5400).  I had previously replaced my optical drive (>3months ago) with a 120GB SSD from OWC ( and have had no issues at all to date.


    After reading this forum, I am hesitant to make the leap, but I found OWC is selling two versions of the Hitachi 5K1000 (1TB).  One version is the SATA-III 6GB/s and the other is the exact same hardware with different firmware installed making it backwards compatible with SATA-II 3GB/s and SATA-I 1.5GB/s machines.


    Here's the link:


    As the OEM drive that came with my machine is a SATA-II 3GB/s drive that is running at a negotiated speed of 1.5GB/s (apparently because apple modified the firmware before shipping it), I am hopeful that OWC's pre-installed firmware fix will also work.


    I will update this post next week when the new drive arrives.


      Model Identifier: MacBookPro5,3

      Processor Name:          Intel Core 2 Duo

      Processor Speed:          3.06 GHz

      Number of Processors:          1

      Total Number of Cores:          2

      L2 Cache:          6 MB

      Memory:          8 GB

      Bus Speed:          1.07 GHz

      Boot ROM Version:          MBP53.00AC.B03

  • Josh Holloway Level 1 Level 1 (0 points)

    So I'm seeing some hard drive issues with a Mid-2009 15-inch MacBook Pro, and in troubleshooting and researching the problem, I've stumbled upon this recurring problem. Can someone tell me if these symptoms seem like the same issue reported here?


    Original CTO hard drive (Seagate 500GB 7200RPM) stopped booting. Tried formatting the drive and starting over, but MBP will not format the drive. Tried putting in replacement hard drive (Toshiba 250GB 5400RPM), but MBP will not format that drive either. Both drives work when used with an external enclosure, but will not boot if put inside the computer. I'm trying a third drive now that I think may just be SATA I.


    (Full issue details here: )


    Does this seem like I'm having the same issue reported here? If so, what's my best course of action? I see people are reporting success with using the optical drive bay or replacing their hard drive cables with one from a 2010 MBP.

  • ojbravo Level 1 Level 1 (0 points)

    Update:  I've been running the Hitatchi 1TB drive for about 6 weeks now with no problems at all!  Everything is wonderful, OWC FTW!!!

  • yamata45 Level 1 Level 1 (5 points)

    Just to let ya'll know, I ordered a new SATA cable for the internal hard drive on the MBP. Replaced the old one with it.


    It did NOT fix my issue.


    The only thing that worked was downgrading the Firmware back to 1.6 per the instructions in this thread. That worked. Now, I cannot upgrade to Mountain Lion LOL


    Oh well. I have a 1TB drive in my Mid-2009 MBP

  • ojbravo Level 1 Level 1 (0 points)

    Per my setup above, I was able to run 1.7 firmware and upgrade to Mountain Lion with the 1.0 TB drive in my mid-2009 MBP (plus the 120GB SSD in the optical bay).  Zero problems.  I understand that some folks can't get it to work, but I just wanted to let others who are interested know that it is most definitely possible.  Just order from and you should be good to go.


    Here is the exact model I ordered:




  • ifraaank Level 1 Level 1 (0 points)

    yamata45, did you order a 2009 MacBook SATA cable, or a 2010 MacBook SATA cable? :-)

  • yamata45 Level 1 Level 1 (5 points)



    I ordered the 2010 Cable, as stated in this thread and a few others, the exact part number as mentioned. It did not solve the issue.


    I only got my MBP's mainboard to work with the drive by reverting back to the previous firmware. That was the only thing that worked for me. I tried 3 different models of HDD's, and the 2010 cable. The firmware revision was the only thing that worked.