7 Replies Latest reply: Dec 17, 2009 7:12 AM by romad
romad Level 3 Level 3 (590 points)
Whenever I start up my PowerBook, I get a message asking me if I want to "Allow" or "Deny" this to accept incoming connections. I also get a message asking the same question for "configd". The messages warn that if I deny it I'll be unable to connect to a network or the Internet. However, when I click on "Allow" I STILL can't connect. The only way I've found to be able to connect is to go to System Preferences>Security>Firewall and select "Allow all incoming connections" which I interpret as disabling the Firewall.

Active: iMac (G5, G4), Powerbook G4, iPhone, iPod, MP2100 Retired: iMac G3, A2c, Mac OS X (10.4.11), Mac OS 10.5.8, Mac OS 9.2.2, iPhone OS 3.0, Newton OS 2.1
  • baltwo Level 9 Level 9 (61,995 points)
    From the prefPane: "The firewall will block all sharing services, such as file sharing, screen sharing, iChat Bonjour, and iTunes music sharing. If you want to allow sharing services, click Advanced and deselect the “Block all incoming connections” checkbox." Additionally, with the firewall on, basic internet services are available. As for mDNSResponder start with a google search.
  • WZZZ Level 6 Level 6 (12,755 points)
    mDNSresponder/Bonjour, also known as zero-configuration networking, enables automatic discovery of computers, devices, and services on IP networks.


    Maybe you'll find something in this rather long thread that addresses your situation.
    http://discussions.apple.com/thread.jspa?threadID=1314540&start=0&tstart=0
  • romad Level 3 Level 3 (590 points)
    Ah, which prePane are you referring to? I don't have that in the Firewall tab of the Security Control Panel in Mac OS 10.5.8. I have:

    Allow all incoming connections
    Allow only essential services
    Set access for specific services and applications
  • romad Level 3 Level 3 (590 points)
    Bingo! That describes it exactly! I realize now that the problem started occurring after my most recent battery conditioning (leave PowerBook on until it runs the battery down and then recharge the battery.)

    I'll have to try the suggested fixes.
  • romad Level 3 Level 3 (590 points)
    Following the suggestion to re-install the latest 10.5.x COMBO Update seems to have worked, at least on a restart. Now I'll have to shutdown the PowerBook and then re-boot to see what happens.

    Message was edited by: romad

    OK. I shutdown and then after a minute, powered up again. NO mDNSResponder or configd messages! I did get something about an IP address in use but I can connect to the Internet.
  • baltwo Level 9 Level 9 (61,995 points)
    Sorry, I used the Snow Leopard version, which I didn't think was any different than Leopard's. Glad to hear you've solved the issue.
  • romad Level 3 Level 3 (590 points)
    Yep, for all of Apple's statements about Snow Leopard not having major changes from Leopard, there do seem to be a bunch popping up.

    Leopard is the last OS I can use since I only have G4 & G5 machines. Maybe when I can get an Intel iMac or MacBookPro for less than $500, I can move into Snow Leopard.