Skip navigation
This discussion is archived

Snow Leopard vs. HP LaserJet 4MV

5648 Views 13 Replies Latest reply: Jun 4, 2010 1:40 PM by greg sahli RSS
Greg A L Calculating status...
Currently Being Moderated
Dec 16, 2009 4:24 PM
I got a new 27-inch, i7 iMac (love it) with Snow Leopard (10.6.2) and see that AppleTalk is no longer supported. This made talking to my über-cool HP 4MV a royal pain. So…

I configured the 4MV an I.P printer. Through the HP's control panel, I set it up with an I.P. of 10.0.1.201
I then downloaded all 1+ GB of printer drivers and selected the HP 4V/4MV Postscript driver (V. 5.3.0).

I set the 4MV's “MIO MENU” as follows:

Novell: OFF
DLC/LLC: OFF
TCP/IP: ON
ETALK: ON

Then, in “Print & Fax”, I hit the + button to add a printer, added the new I.P. address of 10.0.1.201, and that FINALLY allowed the computer to see the printer. In System Preferences>Printer & Fax>Options and Supplies>Driver, I was even able to set that it had the Optional Lower Tray and its extra memory. The computer ‘sees’ that the printer is there. BUT…

Instantly after I try to print something, the Print Queue slaps up a yellow triangle alert and reports that “Network host ‘10.0.1.201’ is busy; will retry in 5 seconds…”

This goes on and on.

Any ideas?

UPDATE
I found out what the problem is. When you hit the + button in “Print & Fax” to add a printer, there is a selector for “Protocol”. I had tried “HP Jetdirect - Socket”. That is NOT what you want. Go with the default, which is “Line Printer Daemon - LPD”.
iMac 27-inch i7, Mac OS X (10.6.2), To Postscript-equipped HP 4MV printer
  • cmcgarr Calculating status...
    Currently Being Moderated
    Jan 24, 2010 8:43 PM (in response to Greg A L)
    I installed Snow Leopard today and my HP4MV print driver won't show up.

    I printed a test page and did the IP address with no luck.

    I'm really frustrated at this point. I can't afford to be left without a printer. I'm in grad school and I sure the heck won't go to Kinkos.

    Please help.
    Mac Pro Intel, Mac OS X (10.6.2)
  • Witczaker Calculating status...
    Currently Being Moderated
    Feb 7, 2010 1:31 PM (in response to Greg A L)
    I just wanted to thank you for your post.
    My situation was slightly different, but by reading your post I figured it out. My MacPro is connected to a wireless router supplied by our Phone company, after upgrading to Snow Leopard, I lost my connection to my HP 4MV which has been my workhorse for years. I tried changing the IP address on the printer as you suggested, but even though the Printer setup would add the printer to my list of printers, when I tried to print, the MacPro could not communicate with the HP 4MV. Eventually, here is how I solved it. I went to "About this mac/More info" menu selected Network/Ethernet1, which is the port I have the cable from the wireless router coming into. This showed me the address of my MacPro, the address of the Router, and the Subnet Mask.

    Now I went back to the MIO settings menu on the HP 4MV and made the IP (IP Byte) address similar to the address of my MacPro keeping all the numbers and dots the same as the MacPro but changing the last number to something different (201). Then I made sure the Subnet Mask numbers (SM Byte) on the 4MV were identical to the ones I saw on the MacPro. Then in the Gateway settings (GW Byte) in the MIO menu I put in the Router numbers I got off the MacPro. That did it, I plugged in the IP address in the printer setup "Line Printer Daemon - LPD" and it worked.

    Thank you again Greg, you are the man.
    MacPro, Mac OS X (10.6.2)
  • Erich R. Griebling Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 12, 2010 12:42 PM (in response to Greg A L)
    Seems like I've spent the better part of my life solving this one. Apple no longer supports ethernet-connected printers, and HP no longer has telephone support for the 4MV (probably no one alive any more).

    1) Find the 4MV's IP address. It's on the printer Self Test page, along with ALL of the other settings. Who would ever have thought to look there?!

    2) Apply the IP address when adding a new printer. Use the Line Printer option, and the generic postscript driver, if one comes up automatically (as did mine).

    3) Go to print something. When selecting the printer in the print dialog box, DON'T select the one you just set up, but note the designation "Nearby Printers" and hit that one instead. Worked for me.
    What obviously happened is that the OS network probe found the printer's IP address and identified it as being "nearby".

    You can all send me $0.50 for figuring this out, and I'll be rich!
    iMac, Mac OS X (10.6.2), AirPort Express Ethernet printer connection
  • Erich R. Griebling Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 14, 2010 7:35 AM (in response to Erich R. Griebling)
    Well, I lied. The next day, the 4MV wouldn't respond. Wasted several more hours fooling with it. Could not understand where the "Nearby Printers" list came from. Turns out, that list comes from my 4G laptop! Once it was awakened, the 4MV showed up as a Nearby Printer on by brand new iMac!

    So it takes legacy hardware for the newest technology to function? The old 4G functions as a print server. Thank you Apple.

    Message was edited by: Erich R. Griebling

    Message was edited by: Erich R. Griebling
    3.33 iMac PowerBook G4, Mac OS X (10.6.2), AirPort Express Ethernet printer connection
  • direwolf8 Level 4 Level 4 (1,280 points)
    Currently Being Moderated
    Mar 15, 2010 12:18 PM (in response to Erich R. Griebling)
    Apple no longer supports ethernet-connected printers


    Did you mean "appletalk connected printers?" They certainly support ethernet connected printers. That's all I use.
    G5, Mac OS X (10.5)
  • Greg Olijnyk Calculating status...
    Currently Being Moderated
    Apr 1, 2010 1:10 AM (in response to Witczaker)
    I have just spent the best part of a day trying to resolve the 10.6 vs 4MV issue after having swapped over to a new iMac and not being able to print anything. 2 hours was spent on the phone to Apple support going through the whole thing with no result (they would get back to me).

    Thanks to the daunting but doable instructions regarding the reprogramming of the 4MV posted by Witczaker with MIO menu instructions by playingwithwords I was finally able to claim success. Half the battle is working out the control panel on the 4MV, the inner workings of the MIO menu are not explained in any HP literature.

    Maybe Apple support should search their own Discussion pages more often.
    Mac OS X (10.6.3)
  • Max Crace Calculating status...
    Currently Being Moderated
    Apr 12, 2010 7:05 PM (in response to Witczaker)
    Thanks to all here for the info. I printed out the second para in Witczaker's post, and followed his example. Thankfully I still had my HP4MV manuals and the network setup manual, because I had forgotten everything about how to use the front panel controls. Until Snow Leopard, it always just worked with no effort, likewise the Linksys routers. I had the exact problem some of you did. But after following the post to the letter- the printer worked perfectly and all is well. The 4MV is a solid workhouse and I have used it probably way beyond it's original anticipated lifespan, but it just keeps running, and I would have really been bummed out if Snow Leopard had not been able to work with it. So thanks again!
    MacPro 2 x 2.8 GHz Quad-Core Intel Xeon, Mac OS X (10.6.3)
  • cmcgarr Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 7, 2010 2:58 PM (in response to Max Crace)
    I woke this morning and my 4MV won't print a thing. Now it seems to have a mind of it's own.

    It's been working after following the steps in the thread here but after spending half the day resetting, printing out test sheets for the IP address there is still no success.

    Anyone have any solutions?

    Casey
    Mac pro, Mac OS X (10.6.3)
  • sig Level 8 Level 8 (35,770 points)
    Currently Being Moderated
    May 7, 2010 4:38 PM (in response to cmcgarr)
    I have a 4MP and once I installed SL it was a no print. I got an HP Jetdirect 300x on eBay for $20 and now the 4MP runs like a charm.
     MacBook Pro 2.8 Ghz 15" / 4 Gb Ram, Mac OS X (10.6.3), iPhone 3GS
  • Bruce De Benedictis Level 4 Level 4 (1,685 points)
    Currently Being Moderated
    May 8, 2010 5:16 AM (in response to cmcgarr)
    If it is working one day and not the next, that sounds like the address of the printer is changing. You will need to read the instructions for the printer interface and set it with a fixed address, preferably outside of the area with the DHCP pool.
    MacBook Pro
  • Lor A S Calculating status...
    Currently Being Moderated
    Jun 3, 2010 9:31 AM (in response to Greg A L)
    I've read through the posts below but still haven't succeeded in getting my HP4mv (1996) to print with my new imac. I can set the MIO menu on the 4mv's control panel as Greg A L outlined, but am I understanding that you also input numbers into the printer's control panel? If so, can you describe how to do that? I can't find any access to reconfiguring the printer's IP address on the printer. Your new IP address looks like an airport express IP . . . should I be using a router to connect ethernet to airport?

    I did find my printer's IP address and followed Wiczaker's instructions. (I have the ethernet cable connected directly from printer to imac.) In both cases, I used the printer/fax instructions, LPD and no matter what I do, I get the yellow triangle. Help!
    imac, Mac OS X (10.6.3)
  • greg sahli Level 7 Level 7 (23,475 points)
    Currently Being Moderated
    Jun 4, 2010 1:40 PM (in response to Lor A S)
    The MIO menu is where the "printer's IP" is set.
    You need to clarify if you are permanently connecting the ethernet to the printer direct from computer, and computer gets internet via WiFi?

    If so, you also need to set the computer's second network interface - ethernet (wireless would be the first) with a manual IP address, and not in the wireless IP address range/subnet.

    PS - in the future start a new subject rather that tagging onto an old one - you'll get more responses.
    G4-867-DP

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.