Previous 1 5 6 7 8 9 Next 134 Replies Latest reply: Jan 20, 2016 3:24 PM by gerome760 Go to original post
  • Johann Beda Level 1 Level 1

    If you are not using an ethernet connection (the ethernet port is not plugged in) then it is not possible for anyone to "hack" your system through ethernet.

  • danfromoklahoma city Level 1 Level 1

    Resetting the router will usually do the trick.

  • lenmak Level 1 Level 1

    Thanks Dan and others for responses.

    Over a year ago I wrote:

    >Summary: Airport to internet works fine, ethernet to my MacMini is self assigned on both machines and mini

    >can't connect. AFP connection works OK, can transfer files by drag and drop, so hardware is not the issue. >Tried most of the other "solutions" suggested in this thread- no dice. Is there NO-one at Apple networking >reading this stuff with understanding?

     

    As an ex-help desk person I am embarrassed to report it was PBKAC (i.e my fault combined with being confused by the error message) :-( . After a month or so of seething, I thought to check my security settings thoroughly. I had turned off internet sharing for the ethernet port. Turned on again and presto, all was well. :-)

  • DrpabloC Level 1 Level 1

    Thanks so much kickmyass.

     

    I've never had this problem before in a decade, until it suddenly appeared and seemed unfathomable. My wifi was still working fine, and booting up from a mirror HD did not give the problem so I knew it wasn't a hardware issue.

     

    Spent many hours trying to fix this issue, trying all the other suggested fixes in this Discussion, but to no avail.

    But now just tried your cure and it's worked instantly. Suddenly my Router IP address via ethernet reappeared in the Network system settings, and all is well. Thanks a million. The link you posted details the cure, thanks for sharing it. (THANK YOU TOPHER KESSLER!). You have saved me a precious Saturday!

     

    P.S. I had this problem on dual 2GHz PowerMac G5 running OSX 10.5.8.

  • Michael Viergutz1 Level 1 Level 1

    THANK YOU !

     

    This problem was driving me crazy !

  • ONCanada Level 1 Level 1

    Thanks a million. I am using a MacPro and just upgraded from osx 10.6.8 to 10.8.5. After the update finished and the system restarted, I could no longer connect to the internet. My system would get ip addresses in the 169.254 range on both Ethernet and wifi instead of getting a 192.168 address assigned by my router. Many solutions were tried and the one that worked for me was deleting the com.apple.alf.plist file. Thanks kickmyass.

  • MHTSOSMAN Level 1 Level 1

    I think i find a solution. I open the router configuration and put an address reservation in every device to my network. I think it worked..

  • renatafromsan francisco Level 1 Level 1

    Is it an "Ipv6" problem?

     

    I'm a total non technical person but...after wrestling with this for a few hours (wifi would connect fine, but ethernet got that error message), I adjusted the "Ipv6" option to "local-link only" in the Network settings, after clicking on the ethernet connection.  I've got a new iMac, running Mavericks, and was frustrated the ethernet connection wasn't working; using it through a Powerline adapter.

     

    So far, seems to have solved everything and ethernet is green/connected.

  • brollyjohn Level 1 Level 1

    Same problem still persisting in Mavericks so upgrading is not a solution.

     

    This problem has been persisting since snow leopard.

  • USD Business Level 1 Level 1

    I also had this problem, and after spending hours on the phone with out any help I figured it out. I just simply copied the IP address from the Wi-Fi, which is labeled under the turn Wi-Fi off button, then pasted the ip address to the ethernet by selecting using DHCP with manual address and putting the IP address in the blank.

    Hope this helps!

  • fabienlefrapper Level 1 Level 1

    Thank you so much renatafromsan francisco!

    Here is the trick

     

    I adjusted the "Ipv6" option to "local-link only" in the Network settings, after clicking on the ethernet connection

     

    iMac 27 mid-2011

    Mavericks 10.9.1

    Airport enabled

  • mikey86uk Level 1 Level 1

    Im now having the same problem for the last few days on my mid 2011 27" iMac, running the latest version of Mavericks.

     

    Ethernet works fine after i reset my router, but i think once it goes into sleep and then wakes it then for some reason decides to self assign a ip address.

     

    Changing the Ipv6 to local link shows something like a mac address as the ip address, is this right?

     

    I do have Apple care, so maybe worth phoning them in the morning.

  • H. William Rhea III Level 1 Level 1

    My sons MacBook kept having this problem and it drove us nuts trying to figure it out.  We tried everything here and on other sites to no avail. 

     

    We have now fixed the problem for him, but I don't think the same fix will work for everyone.  For us, we had a bad port on the hub.  That's it!   He plugged his MacBook into other ports and it worked fine.  ****!  All those hours wasted and our problem was actually a hardware issue.

     

    BTW:  The hub is an older Asante model and the bad port kept pulling an 169.x.x.x number and was green, but never connected.

  • RobertTheScot Level 1 Level 1

    Hi,

     

    There is an easy solution to this and I hope it works for you.

     

    1. Go to your network preferences.

     

    2. Select your ethernet connection.

     

    3. Go to location and select new location.

     

    4. Make sure the configure Ipv4 setting is set to: "Using DHCP with manual address.

     

    IMPORTANT

    5. Type in a new IP address. For example 192.168.1.70 (this will depend on how many IP addresses are allocated on your router network, to find out, download an app like "Fing" and it will tell you all the IP addresses that are allocated. Make sure to use one not being used by your system. Dont fill out any of the other boxes as this will be done by system.

     

    6. Save the changes you have made.

     

    That should solve it hopefully!

     

    See screen shot below for what you should be looking at.

     

    Screen Shot 2013-12-31 at 09.02.12.png
  • StephanDavid Level 1 Level 1

    This worked for me very well.
    Even when I was able to access Internet, I couldn't access other computers on network, or our network printer. Then came the Self-Assigned IP. Arggh!! So I trashed this plist file as well as the SystemConfiguration prefs folder.  For now, it's all working again. Thanks!

Previous 1 5 6 7 8 9 Next