Previous 1 2 3 4 5 6 Next 124 Replies Latest reply: Dec 4, 2014 12:38 PM by BLCSLO Go to original post
  • saripurigopi Level 1 Level 1 (0 points)
    I've the same problem. I'm able to connect using wireless but not able to using wired. The below step worked fine. I'm using MacBookPro, snow leopard.

    Turn off the AirPort,
    connect the ethernet cable, remove FTP proxy check from Advanced setting. use DHCP.
    try renew DHCP, from advance TCP/IP.
    it is able to connect to router and get IP.

    But when i try to enable AirPort its not able to get the ip address. strange problem. As these(wired/wireless) interfaces are different, it should be able to connect to AirPort also.
  • nulp Level 1 Level 1 (0 points)
    Same problem, rebooting every single device and still the same self-assigned IP issue.

    On Network Preferences for Ethernet:
    Changed: Configure IPv4 from Using DHCP to "Using DHCP with manual address"
    Then using another computer plugged to the same Ethernet got a IP Address like this: XXX.XX.X.58.
    Finally on Network Preferences for Ethernet I manually added a similar IP Address just increasing or changing the las digits like this: XXX.XX.X.59 (Range:0-255)

    When I first entered a new IP Address I got a message saying that "Another device on the network is using your computer's IP address, so I keep changing the last digits until I got no message.

    That did the trick for me.

    Hope This Helps someone else.
  • suzyz Level 1 Level 1 (5 points)
    My macbook pro 13" laptop - 10.5.8-just 1 year old - about 3 months into use, it started dropping connection, airport card changed new router/modem (I'm on my 3rd now) - doesn't matter whether it is wireless or ethernet, still constantly loses signal and or network. My Ipad doesn't drop - does this mean there is absolutely something wrong with the computer itself? The genius bar paid little attention and sort of blew me off when I took it in. I would appreciate some advice here - I have Applecare and they are always very nice when I call but don't seem to be able to help me. I am not computer savvy enough to follow some of the instructions I see from time to time.
  • RapJack Level 1 Level 1 (0 points)
    My troubles with this issue started when I attempted to use my airport card in my iMac 27 connected via wired ethernet (using osx 10.6.4), to broadcast an IP address to use with my new WiFi iPad. It worked fine at first: the iPad could use the IP address, the Mac seemed happy as pie about the arrangement... then I put the Mac to sleep and went to lunch. That's when the bug bit. When the Mac awoke, no ethernet connection could be established, regardless of resetting the DHCP lease, turning off the Airport card, etc etc. The only thing I could do to reestablish a good connection after sleep, was to restart the Mac, each time.

    *My final fix* was to use Time Machine to restore my entire main Library folder to a point prior to fiddling with the airport to use with the iPad. That fixed the problem, but I now need to find a new way to feed WiFi to the iPad.

    - Scott
  • Qcon Level 1 Level 1 (0 points)
    I just got a hand-me down G5 and having the same issue. Was this ever resolved? Thanks!
  • JBH5 Level 1 Level 1 (5 points)
    same as the others! tried all the fixes ( short of new machine or system re-install...weird.
  • tawfik Level 1 Level 1 (0 points)
    i changed configure ipv4 to Manually, assigned a unique ip address to the mac mini server, corrected the subnet mask address (it was 255.255.0.0) and changed it to my network's default (255.255.255.0), i put in the router's ip address as my adsl modem's ip address because it has the dhcp not my airport extreme, i put in the dns server ip address as provided by my isp, in the advanced window, i switched off Configure Ipvf6, and finally i unchecked the Use Passive FTP Mode box under the proxies tab.
    now it works ok and i'm downloading the latest update to the operating system to see what will happen next.
    i hope this helps someone : )
    tawfik
  • tawfik Level 1 Level 1 (0 points)
    so i installed the latest updates to 10.6.5 server and still won't fix the problem, so i reverted to my solution above and it all works again.
    cheers,
    tawfik
  • DJ Staple Level 1 Level 1 (0 points)
    Same Problem Here. (2010 MBP / OSX 10.6.6 / Problem when using Ethernet only / Wifi OK)

    *Possible Fix.*

    I turned off Use Passive FTP Mode (don't know if this matters. It didn't help when thats all I did)

    Set my DNS server to 8.8.4.4 / Using DHCP / Apply

    Worked after that.

    If it doesn't work maybe reboot your router after DNS server change.

    Let me know if this works for anyone else. This problem drove me nuts for a long time. Good Luck.
  • DJ Staple Level 1 Level 1 (0 points)
    Quick follow up. I changed my DNS Server settings from 8.8.4.4 (Google's) to blank. Ethernet is still working.

    So thats good.
  • XXII Level 1 Level 1 (0 points)
    I was having the same issue. Spent a few frustrating hours with tech support for my ISP and then finally found this forum. I turned off Use Passive FTP Mode and it worked almost immediately. Thanks!
  • GilCarroll Level 1 Level 1 (0 points)
    Frustrating. I tried everything all over google. Nothing worked. Then I tried something in frustration, and it worked for me...in system preferences/network, click 'Advanced' and select tcp/ip. Under 'Configure IPv6' I changed it to manually config from automatically. I did not save the changed, but changed it back. That actually seems to have done the trick. I cannot verify, since now I cannot break it again But that is okay...
  • cjchand Level 1 Level 1 (0 points)
    saripurigopi wrote:


    Turn off the AirPort,
    connect the ethernet cable, remove FTP proxy check from Advanced setting. use DHCP.
    try renew DHCP, from advance TCP/IP.
    it is able to connect to router and get IP.

    But when i try to enable AirPort its not able to get the ip address. strange problem. As these(wired/wireless) interfaces are different, it should be able to connect to AirPort also.


    Thanks a million for posting that! I was going crazy trying to figure this out.

    In short, I can either get AirPort to DHCP an address or Ethernet, but not both at the same time. If I turn off AirPort, DHCP will work on the Ethernet port. If I unplug the Ethernet and turn on AirPort, plugging the Ethernet back in results in a self-assigned IP address.

    The really odd thing is I sniffed the traffic via Wireshark on the Ethernet port and I can see both the DHCP Discover and Offer are happening on that port. So, it's gotta be something in software that's preventing the DHCP Offer from making it to the intended interface in the OS.

    Hope that helps someone!

    Cheers,
    Chris
  • mjboyce Level 1 Level 1 (0 points)
    I had this problem until I disengaged VPN. Once I disengaged VPN, the ethernet came online. I then re-engaged VPN and ethernet kept connected with the same DHCP assigned IP. I had also deselected "use passive ftp" - once DHCP was back, I reselected it without consequence.
Previous 1 2 3 4 5 6 Next