Previous 1 5 6 7 8 9 Next 130 Replies Latest reply: Jul 23, 2015 6:52 PM by kaz-k Go to original post
  • kickmyass Level 1 Level 1 (0 points)

    i had "self assigned ip" problem with my powerbook g4 10.5.8.

    try this and it works fine with me now ...



    To do this, go to the /Macintosh HD/Library/Preferences/ folder and remove the file called "" Then reboot the system and log in again.

    Read more: dresses-after-installing-os-x-10.6.8/#ixzz1oc3WF3mw

  • Dayna1985 Level 1 Level 1 (0 points)

    Thank You Pippy2K.

    I was able to solve my issue by changing my wifi channel to 1 as you suggested. Many thanks!

  • Astec Level 1 Level 1 (0 points)

    Thank you kickmyass. That issue was kicking mine. Deleting the "/Machintosh HD/Library/Preferences/" and then rebooting solved it.


    Just so that you know, I experienced this issue on the MacBook ( white unibody, late 2009 ) using Lion ( 10.7.3 ).

  • lenmak Level 1 Level 1 (0 points)

    Sorry guys but nope - didn't work. [Hard to believe that three years on, no-one has a consistent explanation of this bug.] Happened to me last week. Macbook(2008) 10.6.8 working fine last Wednesday. Circumstances: Spent Thursday at my son's house, plugged his ethernet cable in, worked away happily, installed latest java update. Noticed that Airport had been left on and had connected to son's home network operating from the same router. Was this the source of confusion? Where was  the internet connection? Maybe network software tries (and succeeds)  assigning same IP address to en0 and en1? Subsequent confusion perhaps then results in self-assigned address on one or other. Using Property List Editor from Developer's toolkit, I saw duplicated IP addresses for en0 and en1 in but deleting this file and reboot = no duplicates, but same problem.

    Summary: Airport to internet works fine, ethernet to my MacMini is self assigned on both machines and mini can't connect. AFP connection works OK, can transfer files by drag and drop, so hardware is not the issue. Tried most of the other "solutions" suggested in this thread- no dice. Is there NO-one at Apple networking reading this stuff with understanding?

  • Ever, Greatest Level 1 Level 1 (0 points)

    Try changing to WPA security

  • noondaywitch Level 6 Level 6 (8,130 points)

    lenmak wrote:


    Is there NO-one at Apple networking reading this stuff with understanding?


    This forum (and all the others) are user-to-user. No Apple employees unless they're doing it on their own time.


    Yes, having ethernet and Airport active on the same network can cause this. Turning airport off and renewing the DHCP lease in Network preferences > ethernet is usually sufficient.

  • Kabal303 Level 1 Level 1 (0 points)

    This fixed my problem!

  • jdpayne Level 1 Level 1 (0 points)

    Fixed my WiFi connection by deactivating the ethernet connection.

  • LeoMacUser Level 1 Level 1 (0 points)

    I have something like this error on my machine since, well, today...


    My situation: running Mac OSX 10.6.8 and a VM Fusion installation for WinXP. At work I use an ethernet cable to connect with our business network, and VM is set to bridged to also connect to this network like an unique machine. This has worked perfectly for almost 3 years now, but today I got puzzled by this strange behaviour... plugged in the ethernet cable, but did not receive an IP address from DHCP, only the "self-assigned 169.254.x.x". The strangest thing is, that my VM WinXP did received a correct DHCP address (10.248.x.x). So the adapter itself does work and the network does give out IP addresses.


    I tried to:

    - turn off Airport

    - turn off the Passive FTP option

    - turn on Airport to connect through wifi

    - rebooting the Macbook

    - rebooting / turning off the VM

    - DHCP with manual IP address

    - Manual IP config


    All without any success.


    Before trying the more advanced options mentioned in this topic, is there a possibility to see some sort of logging about the en0 ethernet problem? I've looked in Console, but could not find anything familiar.


    Also, I haven't (de)installed anything special lately, only a Twitter app. I can't imagine this could be (part of) the problem.


    Any thoughts?

  • LeoMacUser Level 1 Level 1 (0 points)

    Okay, i tried the remove "" trick, but without any success. Also, turning off the firewall did not gave me an IP address from DHCP.

  • LeoMacUser Level 1 Level 1 (0 points)

    Going crazy over here...

    Last night I did a reset of the file permissions and booted from cd to fix the disk (just to be sure).

    I also deleted the plist files ( + NetworkInterfaces + preferences) and had a clean reboot, including resetting the PRAM/NVRAM by using CMD-Option-P-R at startup.

    Then used my home ethernet cable to my own modem/router, and voila, I got correct ethernet connection and a IP address from the DHCP.


    I thought, great, this things is up and running again.... untill I got at work again this morning.

    Popped in the ethernet cable, waited, and waited, and then: self-assigned IP

    I also started my WìnXP VM Fusion, and that little ******* did receive a correct IP from our company DHCP(!)


    Next thing I did was calling the IT-boys. They said nothing had been changed and they have no such thing as MAC address filtering whatsoever, so that cannot be the problem... unforntunately they also don't know how to fix it....


    Also tried (multiple times) to delete and re-enter the Ethernet in the Network Config, rebooting after deleting those plists again, running Onyx to clear all the cache I could find, ...


    I'm running out of options here. Anybody any thougts??

  • timetravel0 Level 1 Level 1 (0 points)

    LeoMacUser I'm in your identical situation.

    I'm forced to use a VM at work in order to connect to the internet.

    Tried everything, also reinstalled OSX but nothing.

  • kickmyass Level 1 Level 1 (0 points)

    hi had this problem again on and off specaily at my office network. upgrade to 10.8.4 not working for me too but its working fine now since i change my HD and fresh reinstall all my apps. good luck

  • WaltzKing Level 1 Level 1 (0 points)

    It's a long shot, but one thing that might be happening in this latest bunch of reports is that the problem might actually be more on the DHCP server end than on the client end.  It might be that the DHCP server has no more IP addresses to give out - seems unlikely given that the VM gets an IP address but that might be a case of the VM remembering and grabbing the last IP address it had.  It might be that another device is using the last IP address you had but isn't replying in time when you try to use it, and that is confusing either the server or your Mac or both.  It might be that the IP address you use at home it confusing things in a similar way.  It might be that some device on your work network has your MAC address. 


    Again, all long shots but they might be possible.  I'm not sure how you would go about working around them or troubleshooting them without some serious network sniffing tools.


    What happens if you assign your Mac a fixed IP address at work instead of trying to rely on the DHCP server?  You could use the IP address your VM gets (making sure the VM isn't running, of course, and making sure another device hasn't gotten it).

  • apple505 Level 1 Level 1 (0 points)

    So....I have a question......I wonder if someone from another wireless network could hack my macbook through dhcp(ethernet) even if I am not using an ethernet connection? firewall is on and all of my sharing preferences are OFF...also I am behind a router... I know that this is a strange question....but please answer ASAP...I have covered all of the other bases to make sure my mac has not been hacked...just want to make sure that this isn't possible...



Previous 1 5 6 7 8 9 Next