Skip navigation
This discussion is archived

Won't send my mail

8090 Views 30 Replies Latest reply: Mar 29, 2010 6:49 PM by Belle0201 RSS
1 2 3 Previous Next
Geoff K Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 17, 2009 5:17 PM
Why does mail occasionally refuse to send my mail. When it does I get a box that says "Cannon send message using the server..." It suggests using a different mail server, but I don't have one. It has a connection doctor button that says everything is OK. When this happens I can not send mail to that specific address again. I've tried new mail, hand typing in the address, closing everything and restarting, but that address is incognito to my computer.

It doesn't happen often but is very frustrating when it does.

Geoff
iMac, Mac OS X (10.5.5), iMac G4 1GHz 1.23Gmemory
  • Kappy Level 10 Level 10 (221,015 points)
    Currently Being Moderated
    Dec 17, 2009 7:00 PM (in response to Geoff K)
    That error generally occurs when your email server is offline. May be frustrating but there's nothing you can do about it.
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; MBP 2.16 Ghz, Mac OS X (10.6.2), iMac C2D 17"; MB 2.0 Ghz; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Kappy Level 10 Level 10 (221,015 points)
    Currently Being Moderated
    Dec 18, 2009 9:11 AM (in response to Geoff K)
    The email server is at your ISP. There's nothing you can do to prevent their hardware not working. This happens to everyone at some time or another. Servers fail, need maintenance, suffer power outages, etc. Usually it's not a regular thing, but it happens.

    You're fretting about something over which you have no control. When your email server comes back online all will be normal again.

    If the problem is prolonged then call your email ISP and inquire about the service to determine if the outage is at their end or yours.
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; MBP 2.16 Ghz, Mac OS X (10.6.2), iMac C2D 17"; MB 2.0 Ghz; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Kappy Level 10 Level 10 (221,015 points)
    Currently Being Moderated
    Dec 18, 2009 11:13 AM (in response to Geoff K)
    Well, you didn't tell us that. It would help to provide the specific error messages you've received. If there is some sort of block related to the email address of the recipient then call your ISP to find out what can be done.

    Many ISPs now employ sophisticated anti-spam software to prevent spam from being sent or received by their subscribers. In some cases the content of a message or recipient address may trigger the spam filters. However, this occurs at the ISP not your computer. But without the error messages you have received we can't really tell if this is a problem with your email application or its configuration.
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; MBP 2.16 Ghz, Mac OS X (10.6.2), iMac C2D 17"; MB 2.0 Ghz; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Ruth Haug Calculating status...
    Currently Being Moderated
    Dec 18, 2009 12:08 PM (in response to Geoff K)
    I have the same problem! The Mail program in my iMac 24" and my 17" MacBook Pro occationally won't send mail, in the Mac Book Pro it is so bad that I have started using Thunderbird instead. Even if I haven't changed anything, I sometimes - and all day today get the message "cannot send message using the server [my regular one]" and the suggestion to try a different one, which I don't have (in the Mail program).
    This problem is with two of my Intel Macs, but my older iMac PowerPC G5 does not have this problem, neither does my old Mac Pro (PowerPC) laptop!!!
    Even tho' I have the same Mac OS (10.5.8) and version of Mail: 3.6 (936)

    So perhaps there is a bug in the program of the Intel version??
    several, Mac OS X (10.5.8), Mail: 3.6 (936)
  • Kappy Level 10 Level 10 (221,015 points)
    Currently Being Moderated
    Dec 18, 2009 12:23 PM (in response to Ruth Haug)
    Bug? Unlikely as I've used Mail from Tiger through Snow Leopard without ever seeing such a problem.

    Now you may have an installation specific problem or a configuration problem but that's hard to tell. You can start by creating a new user account then logging into that account. Operate for a while from that account and see if you still experience the same issue.
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; MBP 2.16 Ghz, Mac OS X (10.6.2), iMac C2D 17"; MB 2.0 Ghz; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Ruth Haug Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2009 12:30 PM (in response to Kappy)
    I have reinstalled the accounts and the configurations are exactly the same as in the PowerPC! Besides, I didn't change anything before the problem started...
    And they've been there earlier (months ago) as well, but stopped after about a day, without me doing anything...
    several, Mac OS X (10.5.8)
  • Kappy Level 10 Level 10 (221,015 points)
    Currently Being Moderated
    Dec 18, 2009 12:36 PM (in response to Ruth Haug)
    My suggestion did not involve reinstalling anything. I suggested you create a new user account then log into that account. You will need to open Mail and create a new mail account based on the incoming and outgoing server domain addresses they provided. Use the same username and password that you currently use in order to access your mail account.

    Did you migrate from a PPC to an Intel Mac?
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; MBP 2.16 Ghz, Mac OS X (10.6.2), iMac C2D 17"; MB 2.0 Ghz; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Ruth Haug Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2009 2:44 PM (in response to Kappy)
    I tried creating new user accounts, but when I was done
    I got the same error message: Cannot send message to ...
    (but incoming mail works fine, only I can't use a mail program that won't let me reply and forward.)

    And no, I did not migrate. Had a clean start on new Mac.
  • Kappy Level 10 Level 10 (221,015 points)
    Currently Being Moderated
    Dec 18, 2009 3:25 PM (in response to Ruth Haug)
    Have you provided an outgoing server domain name in the configuration? And, did you set up a mail account that is correct for your server - POP, IMAP, etc.?
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; MBP 2.16 Ghz, Mac OS X (10.6.2), iMac C2D 17"; MB 2.0 Ghz; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Ruth Haug Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2009 3:52 PM (in response to Kappy)
    YES! And it has been working for years, except for a few times, one of them being today
    And the same settings still work on my PPCs!
    (And all my other programs work OK.)
  • Kappy Level 10 Level 10 (221,015 points)
    Currently Being Moderated
    Dec 18, 2009 3:59 PM (in response to Ruth Haug)
    Have you tried:

    1. In Mail Accounts preferences click on the Advanced tab, uncheck the IDLE box if there is one.

    2. In your outgoing server configuration don't use any authentication or if your email ISP requires it be sure you use the right one.

    Repairing the Hard Drive and Permissions

    Boot from your OS X Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Installer menu (Utilities menu for Tiger and Leopard.) After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list. In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive. If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer. Now restart normally.

    If DU reports errors it cannot fix, then you will need Disk Warrior and/or Tech Tool Pro to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.
    Mac Pro 2.66 Ghz; MBP Unibody; MBP C2D 2.33 Ghz; MBP 2.16 Ghz, Mac OS X (10.6.2), iMac C2D 17"; MB 2.0 Ghz; 80GB iPod Video; iPod Touch; iPod Nano 2GB
  • Ruth Haug Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 18, 2009 4:14 PM (in response to Kappy)
    1.There is no IDLE box.
    2. I don't use any authentication. Not required.

    Do you really think the HDs have similar errors on both the 16 month old MacBook Pro and the iMac 24" (the latter is only 3 months old)??

    I have heard & read that there are bugs in Mail...
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.