1 2 3 Previous Next 30 Replies Latest reply: Mar 29, 2010 6:49 PM by Belle0201
Geoff K Level 1 Level 1 (0 points)
Why does mail occasionally refuse to send my mail. When it does I get a box that says "Cannon send message using the server..." It suggests using a different mail server, but I don't have one. It has a connection doctor button that says everything is OK. When this happens I can not send mail to that specific address again. I've tried new mail, hand typing in the address, closing everything and restarting, but that address is incognito to my computer.

It doesn't happen often but is very frustrating when it does.

Geoff

iMac, Mac OS X (10.5.5), iMac G4 1GHz 1.23Gmemory
  • 1. Re: Won't send my mail
    Kappy Level 10 Level 10 (226,760 points)
    That error generally occurs when your email server is offline. May be frustrating but there's nothing you can do about it.
  • 2. Re: Won't send my mail
    Geoff K Level 1 Level 1 (0 points)
    Why would my server be offline?

    How can I prevent it?

    Is the server in my computer or at the centurytel motherhouse?

    How can I clear the obstruction and send an email to the person it is refusing to send to?

    Geoff
  • 3. Re: Won't send my mail
    Kappy Level 10 Level 10 (226,760 points)
    The email server is at your ISP. There's nothing you can do to prevent their hardware not working. This happens to everyone at some time or another. Servers fail, need maintenance, suffer power outages, etc. Usually it's not a regular thing, but it happens.

    You're fretting about something over which you have no control. When your email server comes back online all will be normal again.

    If the problem is prolonged then call your email ISP and inquire about the service to determine if the outage is at their end or yours.
  • 4. Re: Won't send my mail
    Geoff K Level 1 Level 1 (0 points)
    But other emails at the same time went through and the web connection didn't break. Doesn't that mean I was successfully connected to my ISP? And even if there was a momentary disconnect of the email client when that specific email was in the wires, why can't I send it now? It sounds like something in my computer has registered a problem and can not clear it even though the problem was momentary?

    In the past this problem has been with specific ISPs on the other end, one of them my place of employ. However, it hasn't happened with either of the two that, for a while, were frequent headaches. When it did happen with those it would self correct after a restart. Now it is not.

    The bottom line is I can send email except for one specific address. With that address I get the can't do it message. The address is likely good as it comes from a large company and I replied rather than manually type in the address. In fact, Mac won't let me enter it manually. It autofills.

    Geoff
  • 5. Re: Won't send my mail
    Kappy Level 10 Level 10 (226,760 points)
    Well, you didn't tell us that. It would help to provide the specific error messages you've received. If there is some sort of block related to the email address of the recipient then call your ISP to find out what can be done.

    Many ISPs now employ sophisticated anti-spam software to prevent spam from being sent or received by their subscribers. In some cases the content of a message or recipient address may trigger the spam filters. However, this occurs at the ISP not your computer. But without the error messages you have received we can't really tell if this is a problem with your email application or its configuration.
  • 6. Re: Won't send my mail
    Ruth Haug Level 1 Level 1 (5 points)
    I have the same problem! The Mail program in my iMac 24" and my 17" MacBook Pro occationally won't send mail, in the Mac Book Pro it is so bad that I have started using Thunderbird instead. Even if I haven't changed anything, I sometimes - and all day today get the message "cannot send message using the server [my regular one]" and the suggestion to try a different one, which I don't have (in the Mail program).
    This problem is with two of my Intel Macs, but my older iMac PowerPC G5 does not have this problem, neither does my old Mac Pro (PowerPC) laptop!!!
    Even tho' I have the same Mac OS (10.5.8) and version of Mail: 3.6 (936)

    So perhaps there is a bug in the program of the Intel version??
  • 7. Re: Won't send my mail
    Kappy Level 10 Level 10 (226,760 points)
    Bug? Unlikely as I've used Mail from Tiger through Snow Leopard without ever seeing such a problem.

    Now you may have an installation specific problem or a configuration problem but that's hard to tell. You can start by creating a new user account then logging into that account. Operate for a while from that account and see if you still experience the same issue.
  • 8. Re: Won't send my mail
    Ruth Haug Level 1 Level 1 (5 points)
    I have reinstalled the accounts and the configurations are exactly the same as in the PowerPC! Besides, I didn't change anything before the problem started...
    And they've been there earlier (months ago) as well, but stopped after about a day, without me doing anything...
  • 9. Re: Won't send my mail
    Kappy Level 10 Level 10 (226,760 points)
    My suggestion did not involve reinstalling anything. I suggested you create a new user account then log into that account. You will need to open Mail and create a new mail account based on the incoming and outgoing server domain addresses they provided. Use the same username and password that you currently use in order to access your mail account.

    Did you migrate from a PPC to an Intel Mac?
  • 10. Re: Won't send my mail
    Ruth Haug Level 1 Level 1 (5 points)
    I tried creating new user accounts, but when I was done
    I got the same error message: Cannot send message to ...
    (but incoming mail works fine, only I can't use a mail program that won't let me reply and forward.)

    And no, I did not migrate. Had a clean start on new Mac.
  • 11. Re: Won't send my mail
    Kappy Level 10 Level 10 (226,760 points)
    Have you provided an outgoing server domain name in the configuration? And, did you set up a mail account that is correct for your server - POP, IMAP, etc.?
  • 12. Re: Won't send my mail
    Ruth Haug Level 1 Level 1 (5 points)
    YES! And it has been working for years, except for a few times, one of them being today
    And the same settings still work on my PPCs!
    (And all my other programs work OK.)
  • 13. Re: Won't send my mail
    Kappy Level 10 Level 10 (226,760 points)
    Have you tried:

    1. In Mail Accounts preferences click on the Advanced tab, uncheck the IDLE box if there is one.

    2. In your outgoing server configuration don't use any authentication or if your email ISP requires it be sure you use the right one.

    Repairing the Hard Drive and Permissions

    Boot from your OS X Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Installer menu (Utilities menu for Tiger and Leopard.) After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list. In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive. If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer. Now restart normally.

    If DU reports errors it cannot fix, then you will need Disk Warrior and/or Tech Tool Pro to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.
  • 14. Re: Won't send my mail
    Ruth Haug Level 1 Level 1 (5 points)
    1.There is no IDLE box.
    2. I don't use any authentication. Not required.

    Do you really think the HDs have similar errors on both the 16 month old MacBook Pro and the iMac 24" (the latter is only 3 months old)??

    I have heard & read that there are bugs in Mail...
1 2 3 Previous Next