8 Replies Latest reply: Dec 21, 2009 10:16 AM by RioCreations
RioCreations Level 1 (90 points)
Hi everyone,

I was doing my last homework assignments on my MacPro today using Safari, Microsoft Word 2008 and I had EyeTV open at the same time. That's not much. All of a sudden the Beachball of death appeared after copying some text from a Website. I tried Clicking elsewhere, Force quitting but to no avail. It lasted way too long so I shut the Mac OFF by pressing the ON/Off button hoping to Restart everything that way.

But now, all I get is a white monitor. What is happening ?!? Help ! anyone !?!
I tried shutting the power bar OFF/ON, Restarting the Mac a few times, removing the main HD and sliding the tray back in, I removed the RAM and blew dust off of the trays. I don't know what else to do...

I sent this S.O.S. from an old G4 but it's not mine anymore...

Help... :'-(


2x2.66GHz Dual-Core Intel Xeon Mac Pro, Mac OS X (10.5.5), 4GB RAM | NVIDIA GeForce 7300 GT 256 MB | 1 x WD 250 GB | 2 x WD 500 GB | XP SP2
  • The hatter Level 9 (60,925 points)
    So, this suggests to me that you really don't have Disk Warrior; bootable backups; haven't tried Single User Mode and FSCK; or at the least SAFE BOOT (but something, not nothing, should be done IMMEDIATELY after such an event).

    Your drive's directory is corrupt, damaged, shot, in an unknown state. you could burn incense for what good pulling RAM, drives or shaking off some dust....

    WHY it happened is more interesting... Word + Safari and the web site's CSS/java or whatever else that sent Mac OS into beachball heaven.

    Install Mac OS on a new partition somewhere. Designate as "emergency only" and have Disk Warrior / Drive Genius / TechTool Pro - whatever your favorite medicine for an ill file system.

    A really really badly damaged directory can prevent booting - from any drive (including DVD that are bootable) so may need to pull it for now.

    You may need to pull your hard drive(s) - an external FW case can be handy for plugging in a drive AFTER the system is up, in order to mount and do repairs.

    Two backup sets, minimum, for all volumes.

    Preventative maintenance, not always going to find errors ahead of time, but don't rely on Apple First Aid either.

    2x2.66GHz Dual-Core Intel Xeon Mac Pro Mac OS X (10.5.5) 4GB RAM | NVIDIA GeForce 7300 GT 256 MB | 1 x WD 250 GB | 2 x WD 500 GB | XP SP2

    Have you had trouble with the 7300? with 4GB RAM? with your drives? still running 10.5.5?

    See you have XP. And WD drives. Backup your drives. Download WD software diagnostic - new version posted 12/2009 Diagnostic Utility - and scan all your drives. Best way to map out problems and insure they are working.

    Same goes for RAM. 3 yrs, time to rerun Memtest again. 7300s are also failing for many (mine felt like it was on the brink of going so I got 8800GT when they were still being sold).

    Just what off the top of my head to an SOS. I think MacFixit use to have some tutorials, Ted Laundau had an excellent book, and all the old MicroMat3 threads from their forums were a treasure trove until taken off line.
  • RioCreations Level 1 (90 points)
    Hi hatter,

    Thanks for the info but I can't even get back into any of my internal HDs. I do have Disk Warrior but can't get in. No data of my work was lost since I was working off a Kingston 8GB USB memory key when everything jammed up and I have the habit of saving often. I am sort off panicking right now since my College assignments are do for "yesterday" to finish my diploma but that's irrelevant to the present problem.

    I tried pressing the C key upon Start but this time I get a flashing question mark (?) within a folder icon. I feel like a mouse stuck in a maze but cannot move anywhere because my legs have been locked down. :'-(

    PS: I updated the Profile info of my MacPro

  • The hatter Level 9 (60,925 points)
    As I said, sometimes the directory is so damaged YOU CAN'T BOOT and need to REMOVE your drive(s).

    Glad you have Disk Warrior. Now... do you have a spare FireWire case for SATA or something?
  • RioCreations Level 1 (90 points)
    I have a spare External FireWire 1TB HD that I had already formatted to Mac Extended Journal (or something like that). Can that help me in any way?
  • RioCreations Level 1 (90 points)
    I tried the PRAM thing but it didn't work. I also tried pressing down the C key and inserted the install Disc 1 but still nothing so I ejected it and shut everything down. I'm at a loss for ideas. :'-(
  • The hatter Level 9 (60,925 points)
    What is a backup plan never tested; and when needed doesn't help?

    As I said twice: remove your hard driveS and rebuild your system - from scratch if necessary.

    Once you have a bootable system, import your data.

    A hard restart or freeze "knocks out" unsaved changes - to the directory, the journal, the volume information block. And can prevent (block) booting from ANY system - includes "C" to boot from a DVD or CD.

    ... and that is one reason to have spare backups and drives; to have a spare case (or dock station) for your "ill" hard drive so you can attempt to repair and mount - after - the system is up and running and booted plug in the USB/FW cable and turn on.

    (I'd be careful and suspect the memory card you used to be in jeopardy as well. Maybe led to freeze, or the USB cable or connection to be bad.)
  • RioCreations Level 1 (90 points)
    Hi hatter,

    I removed all my HDs. I started the Mac up and held down the C key and then Eject. The latch opened and I inserted the my Startup Disc #1. At least it opened up and I would have been able to use it but I could not install anything since no HDs were in the Mac anymore. I ejected the Disc.

    Then I went and bought a new internal Sata HD and inserted it with the drive bay #1. No other drives. Holding down the C key and pressing Eject, I inserted the Install Disc #1. All I got was the blinking question mark (?) in the Folder icon. Nothing happens.

    Am I missing something?

  • RioCreations Level 1 (90 points)
    Hi hatter,

    I read all your info again and started thinking and decided to persevere with some trials:

    I removed all my internal HDs.
    I restarted the Mac while pressing the C key and then Eject and the latch opened.
    I inserted the Leopard Install Disc #1.
    It finally opened up but could not install it on any HD since the Mac was empty.
    I Shut it down again.
    I put back the new virgin HD in bay #1 and Restarted while pressing the C Key and then Eject and the latch opened.
    I inserted the Leopard Install Disc #1 but it would not turn while the new uninitialized HD was inside.

    I decided to cheat a bit:

    I removed the HD and Restarted while pressing the C Key and then Eject and the latch opened but the Mac had no HD installed.
    I inserted the Leopard Install Disc1 anyway and got to the Menu I wanted in Disc Utility to Initialize a new HD.
    I opened the side panel of the Mac while the Install Disc #1 was turning.
    I carefully without any sudden jerks slipped the new uninitialized HD back into bay #1 and carefully closed the Mac's side pannel without latching it closed.
    The Disc Image finally appeared in Disc Utility and I was able to initialize the new HD.
    I then proceded with the fresh installation of Leopard into the new HD and it took about an hour or two.
    I restarted the Mac to make sure that it was working fine and it did !!!
    I shut it all down again and decided go futher with my testing.
    reinserted all the HD #2 and #3 back into their respective slots and inserted the initial #1 into bay #4 to see if I could perhaps retrieve some data. That obviously means that HD #4 is now removed for now.
    I Started the Mac back up and JEOPARDY !!! All drive appeared on the Desktop again. Hugh !!! *** !!!
    I used Disc Utility to Verify the origical Disc #1 and it said it appeared to be OK.
    I used Disc Utility to Verify Permissions and AHA !!! The persissions got repaired. It took a little while to perform the task but it got done.
    Now, just by curiosity, I restarted the Mac into the repaired Disc in Bay #4 via System Prefs > Startup Disc and Wow !!! Everything is back to normal... Weird !!!

    Now I am back in business and work is getting done...

    Anyway, I just thought I should let you know about my adventure and thanks again for all your help!

    I will give you your Green Star. I would give you and Olympic Gold Star for your help but they haven't invented Mac Olympics yet.