9 Replies Latest reply: Dec 22, 2009 3:25 PM by DavidThompson
DavidThompson Level 1 Level 1 (0 points)
I have an external WD 500Gb MyBook and I'm trying to copy it's data to my 20" iMac (late 2007) via it's USB.

The drive connects and is available in Finder, I will select a number of folders to copy from it to my HDD. After an unrepeatable amount of time (tried this a dozen times and each time it fails but after different amounts of time) the copy will fail. I get a 'This disk was not ejected properly' and a 'Finder can't complete the operation Error code -36'. (I've included a link to a screen shot below)

http://i49.tinypic.com/2cftlrp.png

Once this error occurs the drive then disappears from Finder. It needs to be power cycled before it will appear again.

Additionally I've run the disk through Disk Utility and it doesn't report any problems.

... does anyone have any idea whats going wrong here, how I can fix it and get my data off the external HDD ?

20" iMac (late 2007), Mac OS X (10.6.2), 4Gb RAM, 320 Gb HDD
  • Kenichi Watanabe Level 7 Level 7 (30,465 points)
    If this disk was marketed to the Windows audience, it may have been formatted as FAT32 when purchased, which is a Windows format that Mac OS can also use. However, it is not the ideal format for large drives and long-term use with Mac OS X. Do you know what formatting it currently uses? You can check by doing a +Get Info+ on the drive's icon in Finder, or by running Disk Utility and selecting the drive in the sidebar. The drive being formatted as FAT32, instead of the Mac native format, should not by itself cause this problem, but it could be part of the cause.

    In the Finder copy, where is the destination of the copy? Is it to somewhere in your user home folder, such as your Documents folder?

    +Error Code -36+ is an input/output error of some type. The cause may be on the internal drive, so you should first back up your data on the internal drive, in case there is data corruption on it or the drive itself is becoming unreliable. After your personal data is safe, restart from the Mac OS X installation disc (for the currently installed system release); insert disc and restart with the C key held down.

    This will get you to Installer's first screen. Go up to the menu bar, and under Utilities, select to run Disk Utility. Select the internal drive in the sidebar. Look at the bottom of the window and make sure it says "Verified" for +S.M.A.R.T. Status+. On the +First Aid+ tab, use +Repair Disk+ (not +Repair Disk Permissions+ ). Note if any errors are reported, and if there are errors reported, note if they are repaired by Disk Utility. Although you said you did it already, you should also run +Repair Disk+ with the external drive selected in the sidebar, just to double-check.

    You can then quit Disk Utility and Installer to restart normally.

    Please post back with details about the formatting of the external drive, the destination of the copy to your internal drive, and if Disk Utility found any data corruption errors with +Repair Disk+.
  • DavidThompson Level 1 Level 1 (0 points)
    @Kenichi ... I've included the information below, but no the External drive isn't FAT I formatted it before using it on a previous MBP. The internal drive's SMART is Verified and the External one reports Not Supported. I restarted the iMac off the snow leopard set up cd and ran disk util repair disk on both and both returned no errors. After all this I restarted the iMac and tried to copy files off the External HDD to my home dir, this time it copied off about 30Gb before it died in exactly the same way.

    Disk Description : WDC WD3200AAJS-40RYA0 Media
    Total Capacity : 320.07 GB (320,072,933,376 Bytes)
    Connection Bus : SATA
    Write Status : Read/Write
    Connection Type : Internal
    S.M.A.R.T. Status : Verified
    Partition Map Scheme : GUID Partition Table




    Disk Description : WD 5000AAKS Externa Media
    Total Capacity : 500.11 GB (500,107,862,016 Bytes)
    Connection Bus : USB
    Write Status : Read/Write
    Connection Type : External
    S.M.A.R.T. Status : Not Supported
    USB Serial Number : 57442D574341505731393737373438
    Partition Map Scheme : Apple Partition Map

    Mount Point : /Volumes/Media
    Capacity : 499.97 GB (499,973,603,328 Bytes)
    Format : Mac OS Extended
    Available : 11.14 GB (11,143,708,672 Bytes)
    Owners Enabled : No
    Used : 488.83 GB (488,829,894,656 Bytes)
    Number of Folders : 222
    Number of Files : 2,214

    Verify and Repair volume “Media”
    Checking non-journaled HFS Plus Volume.
    Checking extents overflow file.
    Checking catalog file.
    Checking multi-linked files.
    Checking catalog hierarchy.
    Checking extended attributes file.
    Checking volume bitmap.
    Checking volume information.
    The volume Media appears to be OK.
    Volume repair complete.Updating boot support partitions for the volume as required.
  • den.thed Level 7 Level 7 (25,110 points)
    Hi David, I'm sure that Ken will return shortly!

    In the mean time, I notice that the 500GB drive is partitioned Apple Partition Map scheme and have seen others with the Error -36 problem when copying data into Snow Leopard from that scheme.

    You might try copying the Data off that 500GB drive in smaller chunks to see if you can isolate the problem to a certain type of file.

    Then once you have all the data backed up, reset the 500GB's Partition Map Scheme to the native Intel GUID Partition Table like your 320GB Internal HD.

    Dennis
  • Kenichi Watanabe Level 7 Level 7 (30,465 points)
    I think copying off the data in smaller chunks is a good idea, just to get the data safe. If you have space on the internal drive to do it, you can also try making a disk image of the external drive using Disk Utility, and saving the image file to the internal drive; then mount the image file and copy off the data you were trying to copy earlier. To make a disk image, select the external drive's volume (indented under the drive) in the sidebar, and from the menu bar
    +File -> New -> Disk Image from "<name of volume>"...+ See if it makes a difference if Finder is not doing the transfer. After the data is safe, you can trouble-shoot the cause of this problem...

    When you did the previous Finder copy, the destination was somewhere in your user home folder? Have you tried copying to a different location in your user home folder?

    If the iMac and drive have not been powered off (shut down), not just restarted, since you noticed this problem, be sure to do so. You should also try a different USB cable and different USB port on the iMac, if you have not tried doing that already. If you are using a USB hub, connect it directly to the iMac's port.

    Also, note where the external drive power supply is plugged into power. If it's connected to a power strip that is old or has many other devices connected, as a test, connect it directly to a wall power outlet to see if that makes any difference. Make sure all the sub-connections along the power cord and brick (if applicable for your drive) are tight.
  • DavidThompson Level 1 Level 1 (0 points)
    Thank you guy's for all your suggestions.

    Copying off smaller chunks worked, tedious but worked. For what it's worth trying to copy off more then 10Gb at a time would result in the same error above.

    I tried changing cables and moving the power etc etc but all to no avail

    After I got all the data off the drive, I reformatted it's to OS X Extended Journaled and as per your suggestion changed the partition type to the GUID one. As a test tried copying about 40+ Gb to the newly formatted drive ... but again had exactly the same error :-/

    I'm now at a bit of a loss ... do u guy's think the drives pooched or worth trying to fix ... ?

    Again, thank you for your help.

    - David
  • den.thed Level 7 Level 7 (25,110 points)
    Glad to hear that you were able to recovered the Data off of it.

    My next move might be to check with WD Support to see if there is a firmware update for that model or if it's under warranty shoot for a replacement.

    http://support.wdc.com/?wdc_lang=en
  • Kenichi Watanabe Level 7 Level 7 (30,465 points)
    If you want to take it apart (because the drive is not under any type of warranty at this point), you can test the hard drive mechanism apart from the hard drive enclosure. Often, the drive is OK but the enclosure is faulty. You can test the drive using another drive enclosure, or a USB adapter like this one.

    http://eshop.macsales.com/item/Newer%20Technology/U2NV2SPATA/

    I don't know if that drive is the current SATA type or the older IDE/PATA type. The adapter above works for either type, but enclosures are one or the other.
  • DavidThompson Level 1 Level 1 (0 points)
    good idea but doesn't look like one's available

    http://support.wdc.com/product/download.asp?groupid=102&sid=81&lang=en
  • den.thed Level 7 Level 7 (25,110 points)