13 Replies Latest reply: Jan 29, 2010 3:40 PM by metalcoat
Yanni_T Level 1 (0 points)
Hello everyone,

I keep getting an error "The iTunes library file cannot be saved. You do not have enough access privileges for this operation." in random times when I use iTunes. I said in random times because I don't get an error when I import files to the library or to my iPhone and even though I click on "Don't show this message again." I still get it after I restart my PC.

The thing is that I don't have any problems even though I get the error. All my files are in the Library and I can access them successfully. I can also Synch my iPhone and the files are stored in the My Music folder.

My Windows account has Administrator privileges and like I said before I only get the error without having any problems (in other threads people have problems that's why they get the error - but I don't. That's odd..). Some information you might need, my OS is Windows 7, my iTunes version is and I have an iPhone 3Gs 16GB. Of course before I made this post I made a search on the Support forum to find a solution but none of the previous threads managed to help me.

I'm looking forward to your reply, thank you in advance.

Self built, Windows 7, None
  • balance-digital Level 1 (0 points)
    try right clicking the itunes icon, click properties and then click the checkbox that tells it to always run itunes as an administrator. seems to have worked for me and I had the same probs with the same versions of windows and itunes.
  • Yanni_T Level 1 (0 points)
    Hello balance-digital,

    thank you for replying. I tried that and now I get an error everytime I try to open iTunes. The error I get is "iTunes.exe has been set to run in compatibility mode for an older version of Windows. For best results, turn off compatibility mode for iTunes before you open it.". The thing is I didn't enable compatibility mode, if I go on Properties>Compatibility, "Run this program in compatibility mode for:" is unchecked. I only enabled "Run this program as an administrator". Also now it takes way too much time to open iTunes, it used to be instant and now with Administrator rights and compatibility problems, it takes about a minute.

    Also even though I run the program with Administrator rights, I still get the error "The iTunes library file cannot be saved. You do not have enough access privileges for this operation.".

    Thank you.
  • RationalBus Level 1 (0 points)
    Unfortunately I cannot provide any assistance. However, I am having exactly the same problem. I believe everything is working fine for me except this message keeps popping up. The only problem I have had is saving some playlists. I am uisng 64 bit though which I was not sure if you were as well so I thought I would throw that into the mix. I am looking forward to a reply as this is a nuisance.
  • Yanni_T Level 1 (0 points)
    I'm using 64bit too and so far I have't had any problems with creating playlists. But I've only created 2 playlists and the rest are Genius playlists.
  • RationalBus Level 1 (0 points)
    Wait a second. I may have fixed my (our) problem. I saw another post somewhere that talked about making sure your itunes folder was NOT read only. Well, the folder itself was not read only. However, there was a temp file in the folder which was read only and I could not unset it from being read only. I tried deleting that temp file and was not able to. I reboot my computer and before launching itunes, I was able to delete that temp file. I then launched itunes, made changes to my playlists (I would have always seen the error in that case) and then synched my iphone. This worked with no errors or messages. I do hope this fixed the problem but only time will tell for sure.
  • Katrina S. Level 7 (24,095 points)
    That's some good detective work. iTunes does use a TMP file to save the new library before it renames it. Which kind of makes sense - if it deleted the existing library while it was in use, that could cause problems.

    Anyway, these kind of odd permissions problems have been around since Windows 95....heck,even DOS days. Rather than rebooting your PC to release the phantom lock on the file, it sometimes works to just rename the problem file.
    If it happens again, try renaming it from IT.tmp to IT.tmp.OLD.

    This may not be true in your case, but it could have gotten into that state if both itunes and security scanning software tried to put an exclusive lock on the file at the same time.
  • merfy123 Level 1 (0 points)
    I have exactly the same problem as you and get the same response when trying the suggested solutions. I am running ESET Smart sexcurity and have excluded my itunes folders from the virus scan. One thing I did do was to move the music files to a different partition where there is more space and so the itunes library is my "c" drive whilst the music is on the "d". I also notice that I'm getting a large number of temporary files created in the same directory as my library and when I dlete them there doesn't appear to be a difference.
  • iancairns01 Level 1 (0 points)
    This is basically the exact same as me. I'm Windows 7 using Nod32, I've my iTunes in (C:) and Music on my external (H:) Drive. In my C: Drive itunes music folder i had 900.tmp files, i have deleted these, could someone explain what these are for? My Itunes Library has been wied three times and i've no idea why, i'm wondering is it to do with these messages. I really wish Apple could give a definitive answer as this seems to have happened to a lot of people.
  • Katrina S. Level 7 (24,095 points)
    iancairns01, those .tmp files means some other software has a lock on the iTunes Library.itl file.
    Every time you play a song, podacst, etc....itunes makes a tmp file, when it is done it renames it to iTunes Library.itl with the updated play count.

    Something else has a lock on the ITL file, so itunes cannot rename it.
    A common culprit is security software. If it is scanning the ITL file, tell it not to do that.
  • Mareshalu Level 1 (0 points)
    I have the same pb on win7 64. I did everything I could find around the nets and same results. Any other suggestions guys?
  • Katrina S. Level 7 (24,095 points)
    If you're an advanced PC user, get Process Monitor from SysInternals

    Set it to monitor what is accessing iTunes Library.itl and iTunes Library.xml

    ProcessMonitor helped redkeefy and he found that some Sony software was causing the problem on his Vaio.
    Others in that same thread found that Windows Live OneCare was causing problems. OneCare has been replaced by Microsoft Security Essentials for windows 7. Maybe there is a similar setup issue.

    The older version of Process Monitor (FileMon), helped me years ago when lastfm was causing trouble with itunes (lastfm is fine now- the lastfm folks fixed it really quickly when I sent them the SysInternals log file of them locking the ITL too long)
  • Mareshalu Level 1 (0 points)
    Ok for now it seems to not show the error anymore.
    What I did:
    1. Edit upper and lower filters in the registry.(followed some guide from apple for registry cd drivers being damaged).
    2. Edited security of both iTunes Library.itl and iTunes Music Library.xml to allow all users full control. Plus the whole itunes folder.

    Thanks to all providing good help for us the end users.
  • metalcoat Level 1 (0 points)
    Well your problem relates to NOD32 if you have it, or additionally another anti-virus. Simply open NOD32, Click Setup. Then click toggle Advanced mode. Once you have done that you click "enter entire advanced setup tree" under anti-virus and antispyware click exclusions. Next you add the path where itunes stores its info. So for me its c:\users\username\my music\itunes. And your off.