Previous 1 2 3 4 5 Next 101 Replies Latest reply: Sep 4, 2015 6:06 PM by drewvader Go to original post
  • calvinennis Level 1 (0 points)
    makmacapplefan wrote:
    In Safari 4.0.4 screen turns black when you try to view pdf...

    Solution:
    1. Make sure that in your Adobe Acrobat or whatever Adobe you are using under Adobe>Preferences>Internet "Display PDF in browser using:..." is NOT active.
    2. Quit Safari
    3. Open Finder: Macintosh HD>Library>Internet Plug-Ins, and delete any plugins related to pdf.
    At least two of them: AdobePDFViewer.plugin and PDF Browser Plugin.plugin
    4. Open Safari and ENJOY.


    Hmm I thought I had already done this step and was just living with the black screens, but I tried again and now PDFs are showing up correctly.
  • Chaddio Level 1 (0 points)
    This worked really well for me. Thanks!
  • Margaret Alexander Level 1 (0 points)

    thank you, thank you...for the suggestion to remove the internet plug-in. this worked! had tried lots of other suggestions. problem cropped up after a recent adobe update. perhaps something changed at that point.  anyway, lots of time wasted and boy am i glad to have read the plug-in suggestions.

     

    margaret

     

    p.s.also fixed the similar problem i was having in firefox

  • keithfrominvercargill Level 1 (0 points)

    I tried removing the PI's but didn't work until I re-booted.  Might have worked on a restart but as an ex windows user I still go for broke!  When I bought this new machine last October I spent a fascinating 1 1/2 hours with a nice guy with English as a 5th language removing, re-installing, generally achieving nothing.  When he decided he needed to call in his supervisor I called quits and just used Firefox from the "Develop" menu item.  It still bugged the **** out of me until today I decided to see how many others might have had the problem.  Nice to see I wasn't alone!!!  I always thought I must have cocked up the migration from my old iMac.

  • WittyID Level 1 (0 points)

    getting rid of AdobePDFViewer.plugin worked perfect with 5.0.5 Safari

  • philsgreenjacket11 Level 1 (0 points)

    makmacapplefan - I love you. Thanks for the clear and concise instructions.

  • leoniemac Level 1 (0 points)

    Ahhhhh... thank you, thank you, thank you! Have been frustrated by the pdf black screen for a while now. But voila. Fixed. Very happy

  • Avidmac Level 1 (0 points)

    What about Safari 5.1. Couldn't find the referenced PDFs. Adobe reader works but PDFs still won't open in Safari.

  • DonMahoni Level 1 (0 points)

    For a long time I couldn´t download dmg files or open PDF´s in Safari, every time when I tried to open or download a file Safari just opend a black screen and nothing else happend!

     

    However..... I found a very simple solution which helped to solve both problems (Safari 5.1)

     

    Step 1:      Open FINDER -> Macintosh HD -> Libary -> Internet Plug-Ins

     

    Step 2:      Transfer "ALL" files to your desktop! (do not just copy!!!)

     

    Step 3:     Open Safari and empty cache and close Safari

     

    Step 4:     Reopen Safari and try to open a PDF file or to download a dmg file ( at this point it was already working for me again!)

     

    Step 5:     Transfer files from Desktop back to FINDER -> Macintosh HD -> Libary -> Internet Plug-Ins

     

    FINISH!!!!

     

    If you experience any trouble again after Transfering the files back start again by step one and move at Step 5 always just one file to identify the file which seems to create the trouble!

     

    I hope this simple steps helps for you guys as well

     

    Don Mahoni

  • Lemon Tree Level 1 (0 points)

    makmacapplefan, you're the greatest!  This worked, immediately!!!  THANK YOU!

     

    makmacapplefan wrote:

    In Safari 4.0.4 screen turns black when you try to view pdf...

     

    Solution:

    1. Make sure that in your Adobe Acrobat or whatever Adobe you are using under Adobe>Preferences>Internet "Display PDF in browser using:..." is NOT active.

    2. Quit Safari

    3. Open Finder: Macintosh HD>Library>Internet Plug-Ins, and delete any plugins related to pdf.

    At least two of them: AdobePDFViewer.plugin and PDF Browser Plugin.plugin

    4. Open Safari and ENJOY.

  • wily55 Level 1 (0 points)

    I've been having this problem for some time, Safari won't use preview to display PDF's on a page, it uses Quicktime and creates an image, not a file.

    I'm using Safari 5.1.1 and Lion 10.7.2.  I followed the directions given by Lemon Tree above and restarted both the computer and Safari to no avail.  I've tried 2 different websites that only offer to view a bill using an image (no download option) and Quicktime displays the first document page as an image with no way to send it to Preview or any other reader.

     

    Sorry that this solution did not work for me, but I hope there's one out there.

  • davidmalvern Level 1 (0 points)

    Brilliant thankyou - it's worked for me. This has been driving me nuts for a while.

  • Dieds Level 1 (25 points)

    makmacapplefan, you're advice worked perfectly! I've had the same issue for some time now and it's a relief to have finally fixed it. Thanks very much!

  • Lesley V. Level 1 (0 points)

    makmacapplefan, thank you.  Your advice worked perfectly!  It was making me nuts, too.  Thanks again.

  • CherylSL Level 1 (0 points)

    In Adobe Preferences, I tried disabling  "Display PDF in browser using:..." but it is greyed out and will not let me change it.  Can anyone give me a work around?

Previous 1 2 3 4 5 Next