Previous 1 2 3 4 5 6 7 Next 100 Replies Latest reply: Jul 4, 2014 12:20 AM by cabro4 Go to original post
  • bach000 Level 1 Level 1 (0 points)

    It works! Thanks for posting the detail procedures.

  • OxfordBag Level 1 Level 1 (0 points)

    Me too. I see (using italics to represent greyed-out text):


    [checked checkbox] Display PDF in browser using:


         [checked checkbox] Display in Read Mode by default


    Unchecking the "Display in Read Mode by default" checkbox makes no difference to the greying out or the unchangeability of the upper checkbox.


    Have I understood makmacapplefan's instructions correctly?

  • xairbusdriver Level 2 Level 2 (160 points)

    I discovered that I was also unable to view PDFs in Safari. Hadn't really bothered me until a poster in another forum questioned why he couldn't. I suggested that he needed some Plug-In. To make a long story short, the more recent version of Safari already have that Plug-In. BUT, if you ever install Adobe Reader or Acrobat, you'll probably end up with it taking control of viewing the PDFs. And I've seen that dieabled checkbox several of you have mentioned. Nasty programming by Adobe, in my humble opinion!


    I was able to remove that check mark by simply deleting the Plug-Ins that Adobe had installed (mine were not in my ~/Library but the main Library/Internet Plug-Ins). Unfortunately, even restarting the Mac or Safari didn't change anything...well, I could now get a white blank screen instead of a black one but that wasn't too interesting, either way! The problem is that while Adobe set a vartiable to a value, deleting its Pug-In(s) doesn't re-set the variable. That's what has to be done.


    In an attempt to re-set that variable, someone posted a Terminal command very early in this thread:

    1. defaults write WebKitOmitPDFSupport -boolean-neg

    as suggested above. Then closed and re-launched Safari.

    No apparent affect, but probably no harm done.

    The problem is that "neg" is not a valide Terminal value for a Boolean (or "bool"). And if entered exactly as posted, it actually puts the value "-boolean-neg" into the .plist file. Amazingly, that doesn't seem to cause any problems, fortunately.   The appropriate values could be any of the following: true, yes, false, no. The first two are equal to putting a 1 (one) in the .plist. The other two values place a 0 (zero) in there.


    But, do you see what the name of this variable is?! WebKitOmitPDFSupport. What this means, therefore, is that IF we want Safari to display a PDF the value must be false/no/0 (zero). In other words, it's a double negative! You can view what's in that variable in Terminal by using:


    defaults read WebKitOmitPDFSupport


    If it is anything other than zero, you will NOT be able to view a PDF in Safari. So, the Terminal command to restore that capabilty is:


    defaults write -bool false


    You can also make this change by opening the in a TEXT editor (not TextEdit or Word or Pages!) like TextWrangler. Then, search for something like "WebKitOmitPDFSupport" and you should find only one occurance looking similar to this:



    Now, change the "true" to "false" and you should be able to view a PDF in Safari, again! At least until you re-install something like Adobe Reader/Acrobat/etc.


    Finally, use the Safari->Help->Installed Plug-Ins and look very, very carefully for "pdf" in the list (probably in the 'extensions' column. Anything that has that entry will probably negatively affect Safari's PDF display capability! For example, Speed Download "intercepts" any .pdf file and forces it to be downloaded! I had to deselect that setting in Speed Download.


    I hope this helps what seems to be a Battle of the Bits!!

  • Robert Arthurson Level 1 Level 1 (0 points)

    I have an iMac running Mac OSX version 10.6.8 and I recently downloaded Adobe Reader 10.1.3 (Preview has some limitations). And like all the earlier correspondents, I was more recently afflicted with the dreaded "black screen" when trying to use Safari to view embedded pdf pages. Having read some other posts on the problem, I went looking for but was unable to find any AdobePDFViewer.plugin, in Library or anywhere else. I removed Adobe Reader and tried to find all possible "appendages" to remove, too. This did not help. Having read xairbusdriver's post I thought the approach sounded promising because it suggested a way to get to the heart of the problem. But I had never opened Terminal before and I clearly don't know what to do to drive it because I did not get the result I wanted.


    However, I re-read xairbusdriver's last paragraph and went looking for any remaining Adobe-related plug-ins which previous searching had not found. The first plug-in I found was one called AdobePDFViewerNPAPI.plugin. I moved it to the Trash bin, emptied this and re-opened Safari and .... the problem is fixed!


    Thanks xairbusdriver!

  • dschonst_Oz Level 1 Level 1 (0 points)

    Thanks Robert!

    Wasted an hour trying to download .pdf ex banking site!

    If you are in Sydney I will shout you a beer!


    Will give Adobe a serve when I find the time.

    Have deleted Adobe Reader.



  • AGeiberger Level 1 Level 1 (0 points)

    I just was having the same problem and your solution worked like a charm. (Go to the Adobe application's Preferences for Internet and uncheck the box saying "Display PDF in browser using . . . ") Thanks!

  • OxfordBag Level 1 Level 1 (0 points)

    Thanks. This helped. It took me a while to pluck up the courage to perform what felt like brain surgery. Eventually I approached it sideways and tried Firefox. I had the same problem with the blank pdfs, and discovered I needed to disable an Adobe plug-in. That worked, and then I did pretty much the same with Safari – moved the plug-in (like Robert Arthurson). It now works fine and I'm much happier.

  • kerwinfromnj Level 1 Level 1 (0 points)

    Can someone help me? I was getting black when trying to open online PDF's and then I deleted the two plug ins and I was able to download the pdf but now I can't read pdf's sent to me or ones already on my computer. I get a "file is damaged and cannot be repaired" error message.

  • dba2271 Level 1 Level 1 (15 points)

    A simple search in spotlight for AdobePDFViewerNPAPI.plugin, Delete then restart safari. Less than a minute. Yeah!! Thanks Robert!!

  • Tbox17 Level 1 Level 1 (0 points)

    Thanks for the tip Mak,  It worked like a charm.  I had the black screen for PDFs.  Then I deleted the two plug-ins you mentioned, and viola, PDFs now work again in Safari.  Thanks for the great advice.

  • Gregory Speck Level 1 Level 1 (20 points)

    Thanks for your help. I has to use Chrome for the last 3 weeks to get PDFs to print and view, now Safari is back up and running.  That last plugin




    Trash and reopen Safari

  • rex2700 Level 1 Level 1 (0 points)

    Thank you. Worked like a charm.

    For those non-techies do a search "command+f" keys. Type in " AdobePDFViewerNPAPI.plugin" delete this file. Reopen safari - you're good to go.

  • GeorgeRoger Level 1 Level 1 (0 points)

    I recently upgraded to 10.6.8, got the "black screen" on Safari, and followed the recommendation to find and delete AdobePDFViewerNPAPI.plugin. Success! Thank you.

  • wily55 Level 1 Level 1 (0 points)

    Since upgrading to Mountain Lion and the new Safari this problem has been solved for me.

  • lionjillmac Level 1 Level 1 (0 points)

    Worked perfectly! Thank you for this quick fix.