Previous 1 3 4 5 6 7 Next 101 Replies Latest reply: Sep 4, 2015 6:06 PM by drewvader Go to original post
  • J Evans Jennings Level 1 (15 points)

    Glad it helped you.  That's the reason these support communitie sexist.  Sorry about my spelling. 

  • Mad Momo Level 1 (0 points)

    Thank you, JimTN. I followed every bit of well-meaning advice on this thread and none of them worked until I read your line about just using Preview and deleting Adobe Reader. Now, although I have to take two extra steps by downloading the PDF to Preview, at least I can read it.

     

    In Safari, click on the PDF. You will get a black screen. Move your cursor (do we still call them that?) to the end of the url.

     

     

    Then type option+return. The PDF is now in your download queue.

     

     

    Double click and Preview will open it.

     

    No more Adobe Reader on my Mac either. Viva la Revolucion!

  • Gwen Kelley Level 1 (5 points)

    Dark screen opens on pdf's... This problem has really been bothering me since I had Maverick added to my system. Your solution works... although not as efficient as I would like - It does work!!!

     

    Thanks!

  • thesassymom Level 1 (0 points)

    Thank you so much!!! Fixed in a matter of seconds. I can stop pulling my hair out now.

  • jhmoljhmol Level 1 (0 points)

    Genius!  Thanks.  Followed simple directions from makmacapplefan... everything is good.

  • Shaun7777 Level 1 (0 points)

    Wow...after all this time I finally have this issue fixed! Thanks for the tip, it's the only reasonable one that's worked.

  • melizaq Level 1 (0 points)

    Thank you sooo much! I've been stumped by this for a while and really appreciate the post

  • emt_kopan Level 1 (25 points)

    I've been plagued by this problem for a while too. I finally figured out what was wrong. I started by deleting Adobe Reader and any plist files associated with it such as the NAPI**** whatever it was. Then I found another plist for PDF Browser. I don' t know if this was something else I had installed or if it was part of the Adobe reader but once I deleted it, emptied the trash, and restarted Safari; everything was back to normal. Finally after a year or two of seeing a black screen it is fixed.

  • kegill Level 1 (0 points)

    Just did a nuke-and-reinstall on my MBPr; using Mavericks.

     

    I had never - NEVER - had this problem until the nuke-and-reinstall (which pulled no library resources - library was corrupted). Even though I changed Safari permissions re PDF files, it didn't "take." In other words, even though I said "show this PDF" (so to speak), Safari showed only a black page.

     

    These are the steps that worked for me.

    1. Force quit Safari.
    2. Go to Macintosh HD>Library>Internet Plug-Ins and move AdobePDFViewerNPAPI.plugin to "Unused" (the move is really "copy" and requires admin authentication), then delete AdobePDFViewerNPAPI.plugin (authentication required here, too) from the Plug-Ins directory.
    3. Reboot Safari.

     

    NOTE: I have the full Adobe Connect suite. Acrobat X Pro is not set to be the default app for PDFs.

     

    The debugging process

    After reviewing the thread, specifically makmacapplefan's post from 2009, https://discussions.apple.com/message/10808523#10808523

    I looked at this HD and fired up external drive to look at my TimeMachine backups.

     

    The same two Adobe plugins were in the Internet Plug-Ins directory there as here, yet I did not have this problem two days ago. So I'm not convinced that the existence of the plugin is the source of the problem. I ran two tests.

     

    Test 1 > 

     

    • Force-quit Safari (7.0.2).
    • Leave only the older plugin (AdobePDFViewer.plugin, 2010) in the Plug-Ins directory.
    • Move AdobePDFViewerNPAPI.plugin (2013) to "Unused"
      Macintosh HD>Library>Internet Plug-Ins>Unused
    • Re-launch.

     

    The PDFs that had been black were now readable. The 2010 Adobe reader plugin does not show up in Safari preferences>security>Internet plugins as something to configure.

     

    Test 2 > 

    • Make only AdobePDFViewerNPAPI.plugin active.
    • [Force quit, yadda yadda.]
    • Black screens where there were readable PDFs.
    • In Safari preferences, we now have Adobe Reader 10.1.10. The “allow” or “allow always” does not work. Screen captures are of ineffective Safari security settings.

     

    https://dl.dropboxusercontent.com/u/5317130/publicly-shared/safari-preferences-a dobePDF.png

    https://dl.dropboxusercontent.com/u/5317130/publicly-shared/safari-preferences-a dobePDF-ask.png

     

     

    Kathy


     



  • nnkainz Level 1 (0 points)

    I did try any possible suggestions above. Sadly, my Mac pro still got the problem. I try my wife Mac pro which is late 2013, and i got same problem. I did everything. I used many different browsers... but it is the same. Please help !

     

    Thanks

  • cabro4 Level 1 (0 points)

    No help and way over my head, too. Time for a store techie.

  • drewvader Level 1 (0 points)

    Don't reinstall I had this problem too.

    All I had to do and All you'll have to do is free up some space to fit the pdf file

Previous 1 3 4 5 6 7 Next