Previous 1 2 3 Next 101 Replies Latest reply: Sep 4, 2015 6:06 PM by drewvader
ri130983 Level 1 Level 1
Yes, I know there are other posts on this topic and I've followed the advice on all the posts.
I spoke to Apple Care today as well...

Using Safari when I go to a website with an embedded PDF it comes up blank (black screen). I've tried with Firefox and it works no problem.
I've completely removed Safari, I've completely removed Adobe and all plugins with Apple Care. I reinstalled Safari... same problem. I reinstalled Adobe Reader... same problem.
I've gone through numerous posts. Updated Flip4Mac, changed preferences in preview, changed preferences in Adobe.

None of these options are working.
Apple Care said I should reinstall the OS. I've backed everything up, but reinstalling sounds a bit drastic to me. I thought I would try here and see if anyone had any other ideas.

Thanks for the help.


MacBook Pro, 15-inch, 2.2GHz Laptop Computer, Mac OS X (10.4.11), Apple MacOS X 10.5 - Snow Leopard
  • QuickTimeKirk Level 9 Level 9
    Your profile lists 3 different OS's. Which one is giving you trouble?
  • ri130983 Level 1 Level 1
    10.6.2 - Snow Leopard

    Updated profile. Sorry about that.
  • QuickTimeKirk Level 9 Level 9
    Then you are using Safari 4.0.4 and it can display PDF's without any "help" from Adobe browser plug-ins.
    Under the Safari Help menu choose "Installed Plug-ins". Any from Adobe (except Flash) being used?
  • ri130983 Level 1 Level 1
    Nothing shows adobe except for Shockwave.

    For PDF plugins I show:
  • makmacapplefan Level 1 Level 1
    In Safari 4.0.4 screen turns black when you try to view pdf...

    1. Make sure that in your Adobe Acrobat or whatever Adobe you are using under Adobe>Preferences>Internet "Display PDF in browser using:..." is NOT active.
    2. Quit Safari
    3. Open Finder: Macintosh HD>Library>Internet Plug-Ins, and delete any plugins related to pdf.
    At least two of them: AdobePDFViewer.plugin and PDF Browser Plugin.plugin
    4. Open Safari and ENJOY.
  • Regal909 Level 1 Level 1
    Slightly different issue but same topic. Our issue is that there are no navigation tools like the ones at the top of the Acrobat Reader window. We want to be able to navigate a page at a time, or go to the last or back to the first page of the PDF, etc.

    We are happy to continue using the Acrobat plug-in, but can't seem to get the tools to appear, and there are no equivalent tools in the build in Safari viewer.

    How do we get the tools to appear at the top of the Acrobat Plug-in Window?
    Or, are there any equivalent tools in the Safari PDF Viewer other than the four (Zoom Up, Zoom Down, Open In Preview, Save To Downloads) that appear when you mouse over the bottom of the page?

    Thanks in advance,
  • DOJORODA Level 1 Level 1
    in Terminal, enter:

    defaults write WebKitOmitPDFSupport -boolean-neg

    I tried this and now I can view PDF's QUICKLY!
  • MacLeam Level 1 Level 1
    Don't waste your time reinstalling the OS ... the problem will still be there. It'll still take Safari about five minutes to start up... Safari will still stumble when encountering flash videos... and PDF pages will still make it draw a blank. Somebody at Adobe must be blowing someone at Apple. Perhaps, someday, Apple will make a browser that acts like it's made for Mac.
  • michal WLaf Level 1 Level 1
    Problem solved! I did the same as <<makmacapplefan>>. What worked for me was deleting the file HD/Library/Internet Plug-Ins/PDF Browser Plug-in. Restarted the Mac and can now view pdfs in Safari.

    Not sure what MacLeam's gripe is; Snow Leopard runs fast and furious for me.
  • FR Level 1 Level 1
    I was getting the black screen also when trying to view PDFs.
    Here's what worked for me.
    Go to HD/Library/Internet Plug-Ins
    Find the file iNetGet.plugin
    Open this file with TextWrangler
    Expand the Contents Folder and select the Info.plist file.
    Search (command f) for PDF
    Delete the section between <dict> <array> that includes references to PDF
    File save
    I did this and now PDFs open fine in Safari
    Hope this works for anyone else.
  • vasu Viswandha Level 1 Level 1
    I have the same problem. Tried all the options given. No use. From Safari help, I see PDF plug in. Did move PDF plugin's from Library. No use.

    Mac OS 10.6.3
  • cstacy Level 1 Level 1
    I did two steps:
    I'm using the latest Snow Leopard and the Safari 5.0 from its release a few days ago.

    1. defaults write WebKitOmitPDFSupport -boolean-neg
    as suggested above. Then closed and re-launched Safari.
    No apparent affect, but probably no harm done.

    2. then I deleted Macintosh HD/Library/Internet Plug-Ins/PDF Browser Plugin.plugin (dated 2 Sep 2009 1:09 PM, 1.7 MB)
    and re-launched Safari again.

    This solved the problem for me.
  • Poikkeus Level 4 Level 4
    Your solution solved one of my major problem. Interestingly, your post is the only one that really worked for me. Thanks for your good detective word.
  • dwboston Level 1 Level 1
    Removing the PDF Browser plug in the Internet Plug-ins in the Library (see post below) worked for me to. I'm actually having the problem on Safari 5.0 using Snow Leopard 10.6.4. PDF's pages in Safari would be a big dark gray screen, even trying to save them as a PDF would provide an error prompt. Firefox did not have any problems with PDFs. But getting rid of the PDF Browser plug in has done the trick.
Previous 1 2 3 Next