3 Replies Latest reply: Dec 25, 2009 8:13 AM by V.K.
Richard Liu2 Level 1 Level 1 (5 points)
I'm looking for a tool that can help me tagging my files and messages. In the past few weeks I've tried bunches of 3rd party software like Tags, TagoMan, Yep, Yojimbo, Together, DevonThink, etc. When I finally settle down with my choice, I deleted all other softwares and their spawns (Preference, Service-bundle, etc.) But soon I realized that the global shortcut keys assigned to these software in their own preference settings, still remains in the system.

After I've uninstalled these 3rd party softwares, some software, such as DevonThink, still forbid me to assign certain global keyboard shortcuts I've previously assigned to other software. An error dialog says "The key combination can't be used because it's already used by a system-wide keyboard shortcut" will pop up when I trying to do that.

I've no idea how the Snow Leopard "Service" works. But one thing I'm sure: these assigned shortcuts, and their corresponding services, did not appear in the "Keyboard" system preference. And I've no way to clean them up.

Is there any way to show / clean-up / or reset all the global keyboard shortcuts ?

iMac (2006) / MacBookPro 13 (2009), Mac OS X (10.6.2)
  • V.K. Level 9 Level 9 (56,130 points)
    how exactly did you delete all that extra software? any software that installs services like you mention likely was installed using installers. in that case it has to be uninstalled using uninstallers too. the uninstallers should be provided with those programs. I suggest you look for them and use the uninstallers. also, do look in keyboard system preferences->keyboard shortcuts->services. see if any of those services are listed there. if so disable them.
  • Richard Liu2 Level 1 Level 1 (5 points)
    No, those services-shortcuts are NOT shown in the "Service" list in Keyboard system preference, but the system still keep the record of global keyboard shortcut to an already-removed service. I've tried the "Restore Defaults" button, it didn't work.

    Only few of these 3rd party softwares provide uninstaller, and most of them won't really clean-up all files. Google "FusionVMDKPlugIn.plugin" to see the example. Maintaining applications such as CleanApp can only trash the application, stuffs in ~/Library/ApplicationSupport and plist files. I've to traverse through ~/Library and /Library to manually remove all dashboard widgets, contextual menu items, ServicesBundles, and other files generated by those "service" items.

    Message was edited by: Richard Liu2
  • V.K. Level 9 Level 9 (56,130 points)
    well, I don't know what's going on then. I've never see the popup you are describing even if some global services shortcuts are set. it still seems that one of those 3rd party programs you used installed some stuff that was not deleted.

    try deleting the following items though

    ~/library/preferences/pbs.plist and ~/library/preferences/byhost/com.apple.HIToolbox...