5 Replies Latest reply: Feb 3, 2010 2:11 AM by Leodhasach
Xiozio Level 1 Level 1 (0 points)
i have a mac pro and every time i plug a flash while i'm working on the mac the mac does nothing and i have to Close and save my work then restart my computer when the computer opens it reads the flash thumbdrive and that' s extremly annoying and inconvienant as i have to plug all my usbs even the mouse before opening the computer. the question is , does mac have a special compatible flash drives (or moises)that it can read instantly or is it kind of a problem with mac .I need any info please .

Mac pro, Mac OS X (10.5.7)
  • 1. Re: Mac doesn't recognize flash
    Samsara Level 4 Level 4 (1,320 points)
    Does that happen with any port you put it into?

    Maybe the next time it's in and working correctly, launch Disk Utility and format it. That might change things, but I'm not sure. Good luck.

    Welcome to Apple discussions, by the way.
  • 2. Re: Mac doesn't recognize flash
    Johnb-one Level 3 Level 3 (770 points)
    okay, Xiozio, this should help you out a little bit. Basically, the mac sees
    the flash drive as a separate drive. I was always told to eject the drive first before removing it....if you're doing that, then go with what Samsara said...

    regards
    JB
  • 3. Re: Mac doesn't recognize flash
    Leodhasach Level 1 Level 1 (0 points)
    I'm having exactly the same issue with a Mac Pro in the office. It won't recognise any external USB devices. However if you leave it plugged in and reboot then the drive will appear on the desktop. This seems to only affect the ports on the box itself, bizarrely if I plug anything into the USB ports on the monitor (Apple 24") it works straight away.

    I've tried disk utilities from the install disk, opened up a console and ran fsck -fy, I've also done the bog standard verify permissions and checked for new software updates. Still nothing doing. Very odd! It's not a total disaster because we can use the monitor ports but ideally I'd like to have them all working!

    My colleague suggests that 'plug and play' isn't working but I can't find any settings to tinker with this.
  • 4. Re: Mac doesn't recognize flash
    The hatter Level 9 Level 9 (58,880 points)
    If flash memory isn't showing up, first question would be how and where was it formatted, and what format option?

    I know I read someothing over on http://www.macfixit.com
  • 5. Re: Mac doesn't recognize flash
    Leodhasach Level 1 Level 1 (0 points)
    Aye but if it previously worked why would it then stop working? Unless the USB ports themselves are faulty?