4 Replies Latest reply: Jan 3, 2010 12:37 AM by texlark
tmp310 Level 1 Level 1 (0 points)
Everytime I try to get into the Itunes store, I get a pop up that says "Itunes could not connect to the Itunes store. Make sure your network connecttin is active and try again." Well, obviously theres nothing wrong with my internet connection. I dont know what to do!!! Someone please help me!

HP, Windows Vista
  • gibby540 Level 1 Level 1 (0 points)
    I can't get in either. My guess is that everyone is trying to cash in their gift cards the day after Christmas and the iTunes store cannot handle the extra traffic. I would give it some time.
  • tmp310 Level 1 Level 1 (0 points)
    Yeah, that would make since but I wasnt able to get on last night either. Plus, my sister is able to access it so I dont know why I cant.
  • bigdipper55 Level 1 Level 1 (0 points)
    I kept getting this same error and tried everything to fix it. Finally I went into internet settings and clicked on the advanced tab and clicked "restore advanced settings" that fixed it. Hope this helps.
  • texlark Level 1 Level 1 (0 points)
    The Fix (& It's NOT Your Firewall)

    A. Symptoms

    When you try to connect to the iTunes Store you may receive the alert message "We could not complete your iTunes Store request. An unknown error occured (-9808). There was an error in the iTunes Store. Please try again later."

    B. Resolution

    Check your computer's date, time, and time zone. Set the correct date, time, and time zone if needed. If your computer's date, time, and time zone are all correct and you still see this alert message, this issue can be resolved by modifying certain settings in the Internet Options control panel:

    1) Go to the Start menu and choose Control Panel.

    2) Select Internet Options.

    Note: If you are using Windows Vista you may need to select Classic View on the left before you can see Internet Options.
    Note: If you are using WIndows 7 you may need to change "View by" to either Large icons or Small icons before you can see Internet Options.

    3) Click the Advanced tab.

    4) In the Settings box, scroll down to the Security section.

    5) Deselect the option to "Check for server certificate revocation (requires restart)."

    6) Select the options for "SSL 3.0" and "TLS 1.0."

    7) Apply the changes and restart your computer.

    Disclaimers
    Important: Information about products not manufactured by Apple is provided for information purposes only and does not constitute Apple’s recommendation or endorsement. Please contact the vendor for additional information.

    Article source: http://support.apple.com/kb/TS2753