2 Replies Latest reply: Dec 27, 2009 12:07 AM by OzBelle
OzBelle Level 1 Level 1 (0 points)
My daughter got an iPod Touch 3rd Generation for Christmas which was on version 3.1.1. iTunes told us an update to 3.1.2 was available and would we like to update it, we selected yes. The update downloaded and then the iPod wouldn't restore and is stuck in recovery mode with the iTunes symbol and the USB on the screen and giving us an error message 1604. We have tried different ways to get it to restore but it wants to update it to 3.1.2 which apparently has a problem with it. How can we get it to restore back to 3.1.1?

Optima, Windows XP
  • MistyPony Level 1 Level 1 (5 points)
    I had the same problem yesterday. I tried restoring countless times, reinstalling iTunes... teh whole nine yards. I eventually called Apple, they didn't know what was wrong with it either.

    Unfortunately, its the Touch, not iTunes... you are going to have to return it to where you bought it, and exchange it for a new one. Call Apple, and they will give you a number to give to the store. Alternately, you can go to an Apple store, if you bought it at a retailer (Best Buy, Walmart, ect.) and see what they can do.

    Best of luck! ~*~
  • OzBelle Level 1 Level 1 (0 points)
    We have already done that with one of them, might have to try and do it again and not go anywhere near update 3.1.2. Will try and contact Apple in Australia to get some help. Thanks for your comment.