12 Replies Latest reply: Feb 1, 2010 9:39 AM by Robertmtk
c.burton Level 1 Level 1 (0 points)
I have been working with Silicon Labs and Davis Instruments to try to get this driver installed on my iMac without any success. The driver was working on 10.4.11, but after I upgraded to 10.6.2 it is no longer recognized and does not show up in /dev, i.e. no cu.CP2102... or tty.CP2102... . I went to the Silicon Labs web site and downloaded the VCP driver kit that is used to talk to the Davis device (https://www.silabs.com/Support%20Documents/Software/MacOSX_VCPDriver.zip), performed the installation, and restarted.

I looked at System Preferences, then at Network Preferences. The <CP2102 USB to UART Bridge Controller> shows up as a grayed out Modem with Inactive Status. Clicking on the Advanced button, it shows the CP2102 as an Apple Modem. Under the WINS tab, it lists the CP2102's NetBIOS Name as IMAC-C7DFF1 and indicates that name is currently being used (possibly by another USB to UART adaptor I use to talk to an old Garmin, i.e. usbserial-FTCUSRHZ, and showing the same NetBIOS Name). Not sure if this is the reason that the CP2102 is not being seen.

I searched Console, Kernel, Install, and System logs for CP2102, among other things. I did not see any problems in those logs over the installation timeframe. I did notice that the CP2102 gets turned off after 10 seconds of no activity several times in the past in Kernel log, but not as a result of this set of installs. I scanned the various logs over the half hour of the install process, but did not see anything else of interest.

I opened System Profile and clicked on the USB selection. I expanded each of the USB entries and found the one that shows the CP2102. It shows

CP2102 USB to UART Bridge Controller:

Product ID: 0xea61
Vendor ID: 0x10c4 (Silicon Laboratories, Inc.)
Version: 1.00
Serial Number: 1205096541
Speed: Up to 12 Mb/sec
Manufacturer: Silicon Labs
Location ID: 0xfd110000
Current Available (mA): 500
Current Required (mA): 100

So, the CP2102 is being recognized, but the driver (cu. and tty.) cannot be found (or possibly is not installed).

I tied more things:

1. Performed a Mac reset of SMC and PRAM, with no joy.
2. Reinstalled Snow Leopard. Reinstalled the Si Labs driver package, and restarted. The CP2102 driver still does not show in the /dev directory (either as cu.CP2102... or tty.CP2102...).
3. I looked in /System/Library/Extensions and found the SI Labs kernel extension SiLabsUSBDriver.kext. I decided I should perform an operation I read about, i.e. touch /System/Library/Extensions, and reboot. Still no joy.
4. The System Profile still shows the same CP2102 entry.

Silicon Labs indicated that some how, based on System Profile information, the Product ID was changed from 0xEA60 to 0xEA61, thus pointing to the USBXpress driver and not the VCP driver. Silicon Labs only has Windows PC tools to fix the Product ID problem, so they cannot help.

Finally, I did some additional investigation to try to obtain more information. I moved my USB items around and looked in /dev. Here is what I observed (last boot of my Mac was 12:31 PM on 12/22 and the moving things around occurred at about 10:00 AM on 12/27):

crw-rw-rw- 1 wheel 18, 3 Dec 22 12:31 cu.Bluetooth-Modem
crw-rw-rw- 1 wheel 18, 1 Dec 22 12:31 cu.Bluetooth-PDA-Sync
crw-rw-rw- 1 wheel 18, 17 Dec 27 10:00 cu.usbserial-FTCUSRHZ

crw-rw-rw- 1 tty 15, 1 Dec 27 10:04 ptmx

crw-rw-rw- 1 wheel 9, 0 Dec 27 10:04 random

crw-rw-rw- 1 wheel 18, 2 Dec 22 12:31 tty.Bluetooth-Modem
crw-rw-rw- 1 wheel 18, 0 Dec 22 12:31 tty.Bluetooth-PDA-Sync
crw-rw-rw- 1 wheel 18, 16 Dec 27 10:00 tty.usbserial-FTCUSRHZ

crw--w---- 1 tty 16, 0 Dec 27 10:04 ttys000

There are a couple of devices that I cannot identify: ptmx, random, and ttys000. ttys000 is certainly out of place and I am wondering if it is the CP 2102 device. Its permissions certainly seem strange too (i.e. crw--w----) as well as its owner and group (tty and 16). In addition, the ptmx owner and group seem strange (tty and 15) as well. Just about everything else is owned by wheel or operator.

Looking at /etc/group, there is no group = 15 and the group name for 16 is "group." Looking at /etc/passwd, the owner tty (whose owner number is 4) really points to _uucp (Unix to Unix copy protocol). All of this information seems a little strange.

I would certainly like to get this driver installed properly, so I can talk to Davis device. Any help would be greatly appreciated.

24" iMac, Mac OS X (10.6.2)
  • Robertmtk Level 1 Level 1 (0 points)
    Hey,

    I just found your post and I#m having the exact same problem! I#m using the USB-Datalogger vom Davis (Windows version) and it worked fine on 10.5. I used my own objective-c program to read the serial device (cu.SLAB_USBtoUART)! After switching to 10.6 the old driver didn't work. So I downloaded the latest one from Silabs site and couldn't find any device in the /dev folder! So it seems that the driver doesn't support the usb datalogger.

    I talked to Davis but they don't want to know about drivers for mac and send me ti Silabs. So I talked to Silabs and they said that sit's not their problem and the current OS X driver isn't 10.6 compatible right now! I asked for protocol information or Mac sources but they don't want to help. The only source I get is the linux one from their page. But I don#t know how to implement the source into my objective-c app.

    It's a pitty that Davis isn't interested in Mac support and that Silabs doesn't open their protocol Maybe here is somebody that can help to implement the linux source into an obj-c app ??

    Robert
  • Robertmtk Level 1 Level 1 (0 points)
    Are you still looking for a CP2102 driver to get your Davis station to work? Try this way: Download WeatherLink for Mac (MacLink v5.1.0) from Davisnet.com. Look into the installer package and copy the installer (Silicon Labs USB Driver Installer.mpkg) to your desktop.

    Sorry just found out that the kext load when I connect the davis logger but there is no device in /dev!!
  • c.burton Level 1 Level 1 (0 points)
    I downloaded WeatherLink 5.1.0 and installed it several months ago. No Joy. I downloaded the SiLabs driver for the Mac 1.02 and tried that. No Joy. I have been working with Davis for a month and a half. They sent me a new DVD with 5.1.0 for the Mac. Removed the existing version and installed the new version from the DVD. No joy. Worked with SiLabs and they suggested that the Product ID (PID) should be 0xEA60 instead of 0XEA61, but they have no way to modify it on a Mac, so I borrowed a friend's PC and did the PID change and the PC would not talk with the console. That does not seem to be the problem. As I indicated in my original post, I even tried re-installing Mac OS X 10.6 and repeating all the steps. No Joy. Pretty frustrating and cannot get the data off of the console.
  • garyshainberg Level 1 Level 1 (0 points)
    All,

    I am having the same problems, with the same needs, I have tried most options and I can not event get the USB drivers to appear as a new port, I have also spoken to Davis and whilst they are helpful they do not have a solution except install their 5.1 update which does not work for me, in fact this would not even install until I moved their config file to root and created a dummy rain.db file !!!.

    I have just tried a complete NEW build of 6.2 with updates and installed the drivers as a "virgin" install and guess what, nothing.

    In system profile I don't even see the CP2102 entry.

    I have top say I am at my tether on this and windows may win the day - ahhhhh


    Any other thoughts would be appricated.

    -Gary
  • c.burton Level 1 Level 1 (0 points)
    I have been told by Davis that the Product ID (PID) for the Mac is 0xEA60 and the PID for Windows is 0xEA61. To solve the problem on the Mac only, you apparently have to get a PC and connect to the Vantage Pro console with the PC. Then you have to perform the following steps to reprogram the PID using the PC using Windows:

    1. Install the USBXpress driver on the PC running Windows.
    2. Then run AN144SW "CP210xSetIDs.exe" with "CP210xManufacturing.dll" and change the PID from 0xEA61 to 0xEA60.
    3. Install the VCP driver on the Mac
    4. Now, the CP210x device is ready to be used on your Mac with the VCP driver.

    USBXpress: http://www.silabs.com/products/mcu/Pages/USBXpress.aspx
    AN144SW: AN144SW
    http://www.silabs.com/Support Documents/Software/an144sw.zip
    The VCP driver is available for Mac OSX here:
    http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx

    If you run Parallels or VMware or another virtual system to run WeatherLink on Windows, in addition to running WeatherLink on the Mac, you need to perform the following additional step after Step 1 above (note that you do not need a PC, just use the Windows on the virtual machine for Steps 1-4 above and Step 1a below):

    1a. Install the VCP driver on the virtual machine for Windows.

    The VCP driver is available for Windows here:
    http://www.silabs.com/products/mcu/Pages/USBtoUARTBridgeVCPDrivers.aspx

    Now, the CP2102 will re-enumerate on Windows under the virtual machine. You will see that Windows is now recognizing it as a Virtual COM port device instead of a USBXpress device. In addition, you should see the CP2102 (with PID = 0xEA60) on your Mac.

    Hope this information helps and solves the problem for all of us.
  • c.burton Level 1 Level 1 (0 points)
    The solution I posted works for both the Mac and for a Mac running a virtual machine with Windows.
  • Robertmtk Level 1 Level 1 (0 points)
    Hi c.burton,

    did you tried this? Different PIDs for the Mac and Win Data logger! I was thinking about this some weeks ago but couldn't believed it. Strange why did they do this? And why didn't they told me when I talked to them?

    So i just have to change the PID from 0xEA61 to 0xEA60? If I get some time tomorrow I will give it a try. Keep you in touch.

    Robert
  • c.burton Level 1 Level 1 (0 points)
    Yes, I tried it and it seemed to work. Have not tried rebooting to see if everything still works. Why the PID is different for the PC and the Mac seemed strange to me, also. I was not that way previously (at least under Tiger, there was no need to change the PID to get the CP2102 to work on a Mac and a Mac virtual machine running Windows). Not sure why Davis and Silicon Labs cannot provide a driver with the correct PID, or at least corrects an older driver. Silicon Labs gave me the solution and Davis confirmed it.
  • garyshainberg Level 1 Level 1 (0 points)
    *** THANKS ***

    Guys, this worked perfectly and first time, using the CP210xSetIDs.exe is a little daunting but if you go slow and check what you are doing its OK.

    I will feed this back to the Davis support team, hopefully they will either post this on their support site or use it to help others.

    Again, thanks for the help.

    -Gary
  • c.burton Level 1 Level 1 (0 points)
    Davis has already been sent the full explanation and have acknowledged its receipt.
  • Robertmtk Level 1 Level 1 (0 points)
    Hi c.burton,

    thanks for your solution! That worked perfectly for me After changing the PID the data logger no longer is available as USB device in my Window VM. Instead it works as com device. I think thats why they have different PIDs.

    Great work
    Robert
  • Robertmtk Level 1 Level 1 (0 points)
    After some days using the logger I found some problems. First I cannot access the tty.SLAB_USBtoUART only the cu.SLAB_USBtoUART device. And after some time I have problems connecting (wakeup fails) the logger ... so I have to unplug and replug the USB logger.

    Does anyone has similar problems?