5 Replies Latest reply: Dec 28, 2009 3:15 PM by Acadia
Acadia Level 1 Level 1 (0 points)
I've been adding my CDs to my iTunes library. However, most of the albums I've been adding aren't showing up under "music".

I looked and the files that were imported into iTunes are in *.m4a format*.

I did some searching in Google and found the following:

+"All u have 2 do is download iTunes, set importing default to mp3. After u add the m4a 2 the library,just right-click on it and choose “convert to mp3″. It’s that easy."+

However, that isn't working for me.

Where do I set the importing default to .mp3?

I went into the Edit/Preferences and don't see an option for that. And when I currently right click, I don't have an option to convert to anything.

How do I convert the .m4a files to .mp3 so that I can get them to view in iTunes and ultimately on my iPOD Nano?

Thanks in advance

Nano, Windows XP Pro
  • 1. Re: .M4A Files
    Katrina S. Level 7 Level 7 (24,085 points)
    Where do I set the importing default to .mp3?
    itunes menu > Edit > Preferences > General tab


    http://support.apple.com/kb/HT1550?viewlocale=en_US
  • 2. Re: .M4A Files
    Chris CA Level 9 Level 9 (74,870 points)
    I looked and the files that were imported into iTunes are in .m4a format.

    M4A (file extension. This is an AAC file) is the default format for importing CDs into iTunes.
    How do I convert the .m4a files to .mp3 so that I can get them to view in iTunes and ultimately on my iPOD Nano?

    You don't need to convert them to mp3 for iTunes to use them. They will work just fine as AAC/MP4.
    I've been adding my CDs to my iTunes library. However, most of the albums I've been adding aren't showing up under "music".

    Are they showing up in iTunes anywhere?
  • 3. Re: .M4A Files
    Acadia Level 1 Level 1 (0 points)
    Katrina S, thank you. That worked well.

    Chris, the songs are showing up in iTunes under "Recently Added" +along with every other song/CD that I've added to iTunes.+ But most of the CDs that I've been adding are not showing up as albums in the Music area of iTunes.

    I now changed the preferences and tried the right click on a group of songs and have converted them to .mp3. Now the songs for the album are showing up as an album in the "musica" area of iTunes.
  • 4. Re: .M4A Files
    Chris CA Level 9 Level 9 (74,870 points)
    Chris, the songs are showing up in iTunes under "Recently Added" along with every other song/CD that I've added to iTunes. But most of the CDs that I've been adding are not showing up as albums in the Music area of iTunes.

    Then something in your iTunes is set up incorrectly.
  • 5. Re: .M4A Files
    Acadia Level 1 Level 1 (0 points)
    Could very well be. I find it a very complicated program and most of the time end up with 2 or even 4 of the same song in the library, and I can't figure out why either.

    After I installed iTunes the only thing I had changed was to put a check mark in the box to keep the iTunes folder organized. I had left everything at default install. Now I've changed it to import as .mp3. Those are the only changes that I have made to the iTunes settings.

    Now that I have the settings changed to import as .mp3, as soon as I finish importing a CD the album shows up under the Music Library area inside iTunes and I can import the cover art.

    Before the album wouldn't show up under the Music Library when iTunes was open, it would only show up under "Recently Installed Playlist".