Skip navigation
This discussion is archived

iPod Software Update Taking A Long Time...

5303 Views 4 Replies Latest reply: Mar 8, 2010 6:15 AM by naq59 RSS
Random2009x Calculating status...
Currently Being Moderated
Dec 28, 2009 8:27 AM
Okay, so i just got my iPod touch about 3 days ago. The apps aren't working they open for a second like quite a few peoples then it goes back to the home screen again.

I think it might be because i haven't got the most recent update (3.1.2)but when I go to update the new software it says it is going to take 11 hours to update it. I've started it and it has gone to 10 hours now but i really can't keep my laptop on for that long because my laptop will probably just shut itself down.

Did it take this long for anybody else?

Should it take this long?
Acer, Windows Vista
  • iNexxFear Level 2 Level 2 (380 points)
    Currently Being Moderated
    Dec 28, 2009 10:01 AM (in response to Random2009x)
    The problem you are having is based on your download connection from the apple site.

    Additionally during the past few days, alot of people have been requesting the firmware update from the apple servers.

    Are you still having this issue today, and what is your internet connection type at the moment.

    As for the app shut down, have you tried hard cycling the power on the ipod touch? Some apps request that you restart the device using the hard power cycle (power hold for 10 seconds, swipe the red bar, and then hold it until you see the apple logo... Sometimes there are a few times where app installs consume alot of extra space and by doing a cycle it will help with the not able to use the software issue you are having.

    As for the update, please do post back your connection type so we can help more!
    MacBook Pro 15" Unibody (Mid-2009), 2.8GHz w/500GB HDD, Mac OS X (10.6.2), Syncs with: (2x) Classics 160GB (09), Nano 5G, Touch 64GB, Apple TV
  • iNexxFear Level 2 Level 2 (380 points)
    Currently Being Moderated
    Dec 29, 2009 5:10 AM (in response to Random2009x)
    This is a very strange issue... I've seen a few others on here that have issues with getting thier apps to open on thier devices.

    I don't know the cause, or solution... Unfortunatley this is all that I can offer at the moment, I would also ask if this device is made for your area, and not imported from somewhere else. That could have another impact onto the syncronization & play issue.
    MacBook Pro 15" Unibody (Mid-2009), 2.8GHz w/500GB HDD, Mac OS X (10.6.2), Syncs with: (2x) Classics 160GB (09), Nano 5G, Touch 64GB, Apple TV
  • naq59 Calculating status...
    Currently Being Moderated
    Mar 8, 2010 6:15 AM (in response to iNexxFear)
    Here´s the solution I found another member had kindly provided a while back, it works but you might have to click on the cross in the iTunes window to stop the backup after having unclicked Sync Apps so that they are quickly removed from the ipod. In my case it was the World News app update which I downloaded Wifi which caused the trouble. The culprit app will probably take longer to be removed but afterwards everything´s OK again.
    http://www.ipodtouchfans.com/forums/showthread.php?t=93004
    MacPro3.1 Xenon 8 core 2.8Ghz, iMac dual 2.4,, Mac OS X (10.6), iPod Touch 2gen, Ipod Classic 20gb

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.