2 Replies Latest reply: Feb 3, 2010 6:58 PM by onesntwos
teknoftw Level 1 Level 1 (0 points)
I recently purchased an iMac 21.5". It is running Mac OSX 10.6.2 (Snow leopard). When I turn it on it passes the screen with the gear and the apple logo, but gets stuck on the blue screen, with only the cursor showing.

I have already tried:
1. Booting into safe mode and deleting all startup items.
2. Resetting PRAM and NVRAM
3. Running Disk Utility and repairing the disk.

Anyone have any suggestions on hwo to fix it?

iMac 21.5", Mac OS X (10.6.2)
  • Kappy Level 10 Level 10 (262,740 points)
    Try this:

    You will need to type some Unix commands. If you are not comfortable with this, I don't know of anything other than a re-install. But if you are careful, you should be OK. I recommend you print this out in a largish mono-spaced font so you don't miss any spaces (or add extra ones). Note that case is important.

    Be careful. Some of these commands are dangerous, since you are going to be root.

    Start up in Single-User mode by restarting the computer. After the chime press and hold down the COMMAND-S keys until you see white text on a black background. When this has finished you will see a prompt ending in '#', although there may be other messages. Enter the following commands after the prompt:

    /sbin/fsck -fy

    Press RETURN. Wait a few seconds for 8-10 lines of output. If the last line says repairs were carried out, repeat this command until you get a message 'The volume <yourdiskname> appears to be OK'. Then continue with:

    /sbin/mount -uw /
    cd /Library/Preferences
    rm com.apple.loginwindow.plist
    rm com.apple.windowserver.plist
    cd /Library/Caches
    rm -r *
    cd /System/Library
    cd /System/Library/Caches
    rm -r *
    Press RETURN after each command.

    This should now take you to a proper login screen after the normal boot sequence. You should then Repair Permissions by using Disk Utility (in your /Applications/Utilities folder).
  • onesntwos Level 1 Level 1 (0 points)
    I tried this on my mac pro, and didnt work. Any other ideas?