Previous 1 2 3 4 Next 57 Replies Latest reply: Jul 16, 2010 4:32 PM by SawwhetOwl
Terry Mosher Level 1 Level 1 (10 points)
Hey All,

I've been having a problem in Aperture 2.1.4. Every now and again, I get an ugly green box instead of my image. It can happen when I zoom in, when I crop, when I zoom out, or just about any time I am changing the view of the image. I'm on a 20" iMac (2.16 GHz Intel Core 2 Duo) with 3 GB of RAM and am running Snow Leopard 10.6.2.

I took the machine into an Apple store and they ran extensive tests on the video card and other hardware and everything checked out. Any idea on what's going on? It looks like this:

http://idisk.mac.com/fourmoshers//Public/GreenBox.tiff

Message was edited by: Terry Mosher

iMac 2.16 GHz Intel Core 2 Duo, Mac OS X (10.6.2)
  • Terence Devlin Level 10 Level 10 (134,485 points)
    This looks very like you've been struck with the bug that afflicts some users of 10.6, Aperture, iPhoto and/or Preview.

    Let Apple know that you've been affected too.

    Aperture menu -> Provide Aperture Feedback

    Regards

    TD
  • MikeWiseman Level 1 Level 1 (0 points)
    This problem appeared on the Aperture discussion pages almost as soon as Snow Leopard was released and seems to afflict a considerable number of users. I followed the advice to give Apple some feedback on this, as many others have done. To date there has been NO RESPONSE from Apple, not even an acknowledgement that it is a known issue, much less any serious attempt to fix it. I payed good money for both Aperture and Snow Leopard, and to have a new release of an OS break a core Apple product is beyond belief. Many folks are seriously considering switching to Adobe Lightroom, but again that costs more money, so we really are stuck until Apple stops behaving like Microsoft (releasing bruised versions of their OS) and fixes this.
    cheers
    Mike
  • mosaicmarj Level 1 Level 1 (0 points)
    anybody figure this one out?

    applecare wouldn't help me because my care i over, but i was at the genius bar yesterday and the guy tried to...he suggested checking consistency and rebuilding my database, which i did. didn't help.

    here's what's happening w/me:
    With the green screen situation, each time I do an edit and try to work with a single shot, it suddenly gets a colored layer over it of weird flourescent (sp) colors (mainly greens, but also magenta, yellow, sometimes a mix I think. Looks like noise--and looks corrupted.) Usually that image stays that way until I drag the image onto my desktop and then the image is fine and I can use it.

    also getting the spinning beachball. do you think they're related?

    urg...thanks! marj

    ps I have Ap 2.1.4 and I'm on an iMac with SL 10.6.2. Could be SL related, but I hope not.
  • Willy W. Level 1 Level 1 (5 points)
    I've been having the same problem now for quite some time. I THINK that it is connected to my installing Snow Leopard. But no solution as yet. Very aggravating.
  • lovinmymac Level 1 Level 1 (95 points)
    Do as the above poster said (terence devlin) and submit a bug report to Apple. You can do it from within the program via the Aperture or File menu (forgot which at the moment).

    The short answer to your assumption is that yes SL does break the use of Aperture for some. (I am one of them). It is not necessarily the Aperture program update (2.1.4) itself as I have reinstalled Aperture on Leopard with all updates (10.5.8 and 2.1.4) and have had no issues.

    As far as I can tell, the problem lies in the card drivers, Snow Leopard Code and Aperture programming code regarding OpenGL and/or CoreGraphics.

    To answer your anticipated question about my trouble shooting:
    I have done (in no particular order) the font, plist, permissions, new user account, new library, rebuild library, vacuum library, visual inspection of the motherboard (internal) capacitors, voltage/current checks on power supply, new ram, new HD...it became a quest as you can see.... I changed system settings, tried hidden parameter settings, ran developer toolkit utilities to search for error messages and odd behavior. I ran console and watched each line by line message as I performed each Aperture adjustment/task (or at least tried to...)
    Finally I reinstalled both Operating Systems (Leopard and Snow Leopard) separately on new drives AND installed Aperture 2.1.4 with a 150GB 30,000 image library on each drive separately. No peripherals, clean systems. No haxies (I do not use them) Nothing but the OS and Aperture and the same library. Aperture performed flawlessly on an external bootable drive in Leopard but not in Snow Leopard..in fact it performed worse and I had the corruption duly noted above and elsewhere.

    In my opinion, Apple should be shamed for being so tight lipped about this. It is a serious flaw that should be acknowledged to users. But to admit this without a patch or software solution in the works is an unspoken implication to have customers purchase new computers for a fix.

    Anyone notice the released updates for Logic Pro (2 since the release of SL) and Mainstage (also 2 since the release of SL) and Remote Desktop (also 2 since release of SL).....you get the idea? Aperture? Zilch.
  • razmaspaz Level 1 Level 1 (0 points)
    So I have the same problem. it got worse with the release of Aperture 3. Basically can't do anything with it. Too bad because this is a pretty sweet set of updates. Submitted a bug report too... Time will tell.
  • sfgate Level 1 Level 1 (0 points)
    Same issues, now with both Aperture 2 and 3. Especially noticeable when using new brushes.
  • veggie2u Level 1 Level 1 (0 points)
    I have the same issue. I don't have time for this **. Back to Lightroom 3 beta I go. Liked the new slideshow and book stuff, but I can't work with a program that just doesn't work.
  • Steve_J Level 1 Level 1 (0 points)
    I am having the same problem. Just realised it can only be a Snow leopard OS Bug. A 2.14 started to show this occasionally after 10.6 upgrade. Aperture 3.0 does it pretty much full time, and makes the use of Brushes impossible.

    Reported Bug, but suspect that Apple no longer has the skills on board to fix a problem with an ATI Radeon X1600 driver (especially as it cannot support CoreCL)

    Not too happy with the fact that my amazing Mac has been obsoleted as fast as a Windows PC.

    Sadder and Wiser
  • MikeWiseman Level 1 Level 1 (0 points)
    Are you sure that it is definitely a graphics card problem? I don't want to go out and buy a new mac just because Apple can't support it's own (not so old) hardware, but as it stands Aperture 3 is a right mess while this artifact keeps intruding on my workflow.

    I have reported the fault to Apple, but given previous experience with the same bug report for Aperture 2 (or Snow Leopard as the case may be) I don't hold out any hope of a response.

    This must be the worst bug fiasco I have encountered since I used to deal heavily with Microsoft products. I just expected Apple to rise above such mediocre customer service.

    'Nuff said, ******** makes me feel better, but doesn't solve the problem.
  • Gerard Klein Level 1 Level 1 (0 points)
    I had the same problems. Green blocks after nearly every adjustment. The 301 update did nothing to fix that. So I dug a little further (in Google, that is ) Seems to have gone away after putting Aperture in 32 bit mode. Which - on a 2.15 GHz iMac with 2 GB ram seems not an unreasonable option.
    It seems to be running a little faster than A2 but now I've got it fixed I can do more testing (and actually start enjoying A3 I hope...) and see if it stays away.
  • K2DMFJ Level 1 Level 1 (0 points)
    Use to get this type problem, but instead the pics would turn white. So I would close the program, shut down the machine, and step out for awhile. Come back, turn the machine back on, start Aperture and it would start working properly.

    Sometimes the program crashes but doesnt shut off. A hard or soft reboot is in order when this happens.
  • Otra Level 1 Level 1 (0 points)
    Glad I found this thread, though I'm not too happy to see that there doesn't seem to be a solution - yet.

    Aperture 3 was running just fine - and then I upgraded to Snow Leopard...in happiness because Aperture recently decided to support my camera's RAW...only to find these weird artifacts going on. As with others it is not all the time. Thankfully, it has not hurt the actual photograph.

    I'm not quite sure what one earlier poster meant about changing the BIts for Aperture but will look into this.

    It's too bad and here's hoping for a definitive update.
  • Reflective Turtle Level 1 Level 1 (25 points)
    One more voice to add. For me the problem started with an upgrade to SL while using 2.14. Now running 3.01 under SL 10.6.2 and the problem is worse. Seems that any adjustment that affects the tonal range of the photo will trigger the bug. As others have noted, use of brushes is especially effective at making things blow up.

    Have many screen shots that I could post for comparison.
Previous 1 2 3 4 Next