1 Reply Latest reply: Jan 26, 2010 9:08 PM by MowTin
zac1994 Level 1 Level 1 (0 points)
When I install iTunes the installation continues to the second copying files process then rolls back the action. Itthen continues installation but when an iphone is connected it says the software to install it is not there !?!? Tried this several times and no error codes are given just the rolling back action. Help please.

Windows XP
  • MowTin Level 1 Level 1 (0 points)
    This problem was driving me CRAZY but I fixed it.

    1. Vista's fault for horrible permissions
    2. Apple's fault for a horrible installer that rollsback with NO F#$# ERROR MESSAGE!

    The problem is that iTune's installer cannot do it's job because it cannot delete or edit a file or directory. It would be great if it told you what file is causing you the trouble but it doesn't.

    But there is a way to get that stupid installer to talk.

    Run iTunes from the command line. Here my iTunes is in F:\downloads and I'm telling it to write a log file to F:\downloads\ituneslog.txt

    F:\downloads>iTunesSetup.exe /l*v F:\downloads\ituneslog.txt

    Open the error log in a text editor and search for words like error or problem or fail. You'll probably find some file or directory it cannot copy or edit.

    Find the problem file. Right-click - properties - security make sure Administrators have "Full Control." (I'm assuming you are an Administrator on your computer)

    If that fails add your user name to the list and give yourself full control.

    If that still fails go to safe mode and try to delete the file.

    retry the installer. Rinse and repeat until all your problems go away.

    I hope this helps someone.