5 Replies Latest reply: Jan 7, 2010 5:50 PM by Ruler12
Ruth Everson Level 1 (95 points)
I'm new to the iTunes store and several times have received the following message: iTune component not installed (-42404). Try back later.

When I came back later - several times - I get the same message. Any suggestions?

iMac G5 (10.4.10); eMac (10.4.11); MacBook, Mac OS X (10.4.10)
  • Ruth Everson Level 1 (95 points)
    Checking back -- no answer to my question. How weird is that? Doesn't anyone have an idea what to do? I have iTuens 9.0 and was able to download a free podcast. However, when I tried to download a free single, I got the error message. I even e-mailed Apple support and they couldn't give me a straight answer.

    I have tried, with success, to download a free single using my Mac Book! There is something that hangs up when I use my eMac.

    I'm hoping someone has a at least one idea to try. Happy New Year!
  • roaminggnome Level 10 (94,465 points)
    You can see the system requirements here:


    Perhaps there is a hardware/software compatibility issue with itunes 9 and your emac.
  • Ruth Everson Level 1 (95 points)
    Thanks for the information on system requirements. Obviously, I'm unable to download HD movies, etc. because of my older processor (eMac) but shouldn't have a problem with music and podcasts.

    I did notice that there is a version of iTunes 9.0.2 and I downloaded that thinking that I didn't have the latest update. Since that update I don't get the 42404 error message anymore. That's an improvement.

    This is the message I received tonight: "Could not purchase <name of song.> The network connection was reset. Make sure your network connection is active and try again."

    Is this message referring to my connection to the Internet? Obviously, I'm online to access the iTunes store. Any suggestions to fix this new problem?

  • Ruth Everson Level 1 (95 points)
    I'm marking my question as answered! I returned to the iTunes store today and successfully downloaded some music. No error message. Don't know exactly why I had a problem yesterday. Maybe I'll figure it out someday.

    I think that downloading version 9.0.2 was the main solution. Thanks!
  • Ruler12 Level 1 (0 points)
    I got the same message after having to reinstall OSX and i did a permissions repair and that fixed the problem for me. If it happens to you again try that.