5 Replies Latest reply: Jan 7, 2010 4:57 PM by luvlabs
iKrisT Level 1 Level 1 (15 points)
My iPod Touch 2nd Gen suddenly will not connect to the WiFi after I downloaded the new 3.1.2. Even though the bars are all blue and the connection shows perfectly but none of the apps like Safari, Mail, YouTube, Weather, etc will connect. They all give errors "no connection". I have tried powering down my router. I have also RESET my iTouch. I have also Renewed the Lease. I have powered down the iTouch and reentered the DNS, password, etc. The connection on my desktop is fine and so are two other wireless computers through the same router. Nothing has changed except the new 3.1.2 software and now no connection.

I noticed the "Router" numbers are not showing up in the iTouch list after any these fixes.

Nothing seems to work even from all the great posts ideas about how to fix this. Any other ideas?

Message was edited by: iKrisT

iMac 2.66GHz Intel Core 2 Duo, Mac OS X (10.5.6), March 2009
  • 1. Re: iPod Touch not connecting to WiFi
    PeterY1234 Level 1 Level 1 (0 points)
    I don't know the answer, but if you find out, please let me know. I have already submitted similar post without reply. Surely someone knows what the issues are ?
  • 2. Re: iPod Touch not connecting to WiFi
    iKrisT Level 1 Level 1 (15 points)
    I am not sure about this, but I did try again yesterday to turn off the router and keep it off for about a minute. Again, no positive results. However, today my iPod Touch is connecting. I ONLY turned off the router. From many other off site posts I read about the matter, this was the best solution. LIke I said, it did NOT work for me until the next day. For reasons unknown, the Touch is connecting again. I am only guessing here, but suppose the router off for a minute or so fixed this issue, but not right away. Still baffled here, but happy it is working again.

    GOOD LUCK!!!
  • 3. Re: iPod Touch not connecting to WiFi
    Formanater Level 1 Level 1 (0 points)
    Okay guys I FOUND A FIX. First off i've had my itouch for a couple weeks and its worked like a champ with no problems then today it popped up saying "Invalid Argument" when i tryed to use Safari.
    The technical issue is that the IP address the itouch is using expires and you need to renew regularly which most people dont do until theres a problem.

    TO FIX THE PROBLEM
    Go into settings, tap on wifi, connect to your wireless network, once connected tap the blue arrow, next to your connected network, in the DHCP tab scroll to the bottom of the page, Tap the Renew Lease button 3 times then it will update your IP address and it should work.

    Also if that doesn't work, reset your router manually by unplugging the power waiting 30 seconds, powering it back up then doing the same steps above.
  • 4. Re: iPod Touch not connecting to WiFi
    luvlabs Level 4 Level 4 (3,610 points)
    Here's a series of steps that should correct the problem you are seeing:

    1. Power cycle your router
    2. Reset your network settings on the touch - tap Settings > General > Reset > Reset your network settings.
    3. When your iPod restarts, log back onto your network by tapping Settings > WiFi > Other
    4. Re-enter your SSID (network name), security setting, and password.

    If you are using WEP, use the hex value in the Key1 field of your router in place of the password. Better still, change your encryption to WPA-psk or WPA2-psk.

    If you continue to have problems, go to your router makers website and download and install the latest firmware for your router.
  • 5. Re: iPod Touch not connecting to WiFi
    luvlabs Level 4 Level 4 (3,610 points)
    Whether or not your lease expires is a function of the router/network setup you are using. Most routers have a default setting of "never expire". However, your suggestion is still a good one.