6 Replies Latest reply: Jan 24, 2010 8:24 AM by Gary J. Lieber
Hayo Baan Level 1 Level 1 (25 points)
I am unable to update my existing bootcamp 2.2 services to Snow Leopard's 3.0 version. This on a working Windows XP Pro installation with all the latest fixpacks and updates applied.

When I try to install it from the Snow Leopard install CD, the installer quits with error code 2727 (package corrupt???). Despite this error, the NVidia Drivers get updated/installed, but nothing else.

I've tried removing the existing Bootcamp installation in order to get bootcamp 3.0 to install. This got me a bit further, but in the end I still had no functioning bootcamp installation

Removing the existing Bootcamp 2.2 installation the official way, results in a (the same?) 2727 error as with the install of 3.0 over 2.2 so this leads me to suspect the 2.2 installation is somehow not correct.

Not to be let down by this, I tried removing the bootcamp services using Windows XP's own "Add/Remove Programs". This seemed to be successful, however after the mandatory reboot, the system tray still showed the bootcamp icon...
Inserting the Snow Leopard install CD, however, did start the bootcamp 3.0 installer and got it quite far through the install. In fact, only one thing seemed to have gone wrong: starting the Key Agent service. Retrying this did not help and the only option was to ignore it after which the installer finished and reported success and I rebooted as per instructions.

Everything seemed to have been installed fine (I could for instance access my HFS+ volumes), with one big omission: the system tray icon for bootcamp was gone as well as the support for the special keys (e.g., the eject key and the cmd key). Quite useless

Thankfully I had a very recent backup image of the Bootcamp partition ready so I have been able to restore it to a fully working (bootcamp 2.2) situation again. I'd very much like to upgrade to 3.0 though as the access to my HFS+ volumes is quite important to me.

Anyone else had this problem and/or knows how to get this fixed?

Mac Pro 8-Core 3.2GHz, Mac OS X (10.6.2), 6GB, 2x1TB