14 Replies Latest reply: May 5, 2010 2:26 PM by harveyp
jusben Level 1 Level 1 (0 points)
I started getting this message one day after copying some files onto my external harddrive (Hasn't worked since): "The iTunes Library.itl file is locked, on a locked disk, or you do not have write permission for this file." Does anybody know what this means? It pops up right after it installs and just before the iTunes window opens. I've downloaded it over and over again. It asks if I want it fixed or removed; I've tried both. Epic failure. Any suggestions?

Acer, Windows Vista
  • Katrina S. Level 7 Level 7 (24,090 points)
    The iTunes Library.itl file is the database that itunes uses to store ratings, play counts, etc. iTunes cannot run without it.


    The error message is saying you don't have proper Windows permissions to it.
    Is that one of the files you moved to the exHD?
  • AlmondJoy Level 1 Level 1 (0 points)
    I have the same problem. I have it on XP professional. Actually, I am using xcopy to backup files to external drive.

    Other post suggest unchecking the library.itl & music library xml file Read-Only option. But in my case, none of the file show Read-On option on.

    I have no clue.
  • Chris CA Level 9 Level 9 (76,960 points)
    Please reread Katrina's post you responded to.
    Change the permissions on the \Music\iTunes\ folder and all contents.
  • Golfgalr9 Level 1 Level 1 (0 points)
    Hi, I am having this very same problem. Did you get it resolved and if yes, how???

    Thank you

    Example:I was getting a compatibility error after upgrading from WindowsVista to Windows 7 that my Ipod was incompatible with the recent upgrade. Trying to solve the problem, I accidentally hit "Read Only" under security settings. Now I get the error message: The Itunes Music Library.itl file is locked on a locked disk, or you do not have permission for this file. There is NOT another option to unclick “Read Only”. How do I resolve both issues?
  • Leanne3333 Level 1 Level 1 (0 points)
    I just downloaded itunes 9 and received the same message. Can anyone give specific simple step by step directions in how to fix this as I am not very computer savy?

    Pl
  • Frodoknight Level 1 Level 1 (0 points)
    For XP users, one thing that worked for me was to change the permission on the /MyMusic/itunes folder (and all subfolders and files) so that it's not "Read-only". By right-clicking on the iTunes folder name, and selecting Properties, you will see the Read-only check box. Make sure it's unchecked.

    Good luck!
  • harveyp Level 1 Level 1 (0 points)
    Hi - I have the same locked disk issue running Vista. It seemed to occur when I was trying unsuccessfully to transfer music from an old ipod which was associated with my wife's PC and itunes account. I have deleted the old iTunes and reinstalled. I have unchecked the read only privileges in properties - nothing seems to work.

    Appreciate any help or insight on how others have solved this.

    Thanks in advance,
    Harv
  • Chris CA Level 9 Level 9 (76,960 points)
    I have unchecked the read only privileges in properties - nothing seems to work.

    Did you uncheck the *Read Only* attribute as well as change the Permissions under Security tab?
  • AHXtreme42 Level 3 Level 3 (540 points)
    hahahaha I MAY know the answer if the "read only" thing doesn't work! This happened to me a LONG time ago:

    Are you using Vista? and if so, is Windows Account Control on? If so, pardon my french, but turn that Shizit off.

    I remember I once turned Windows Account Control on (god knows why), you know, its that annoying message that asks you if you want to do anything you want to do? Yeah, well apparently for me it also didnt allow me to either load the library, or sometimes didn't let me edit any info.

    I can't guarantee this will fix it, but it's something I vividly remember from Vista.
  • harveyp Level 1 Level 1 (0 points)
    Man, I thought we had it there.

    I have turned off the UAC, rebooted - unchecked read only, checked permissions -it all looked good and still the same problem.

    Any suggestions - this is getting infuriating! Thanks again,
    Harvey
  • AHXtreme42 Level 3 Level 3 (540 points)
    Ok so since we're all getting desperate. Here's a quote from another forum which someone else posted saying it fixed the issue. Again though, no guarantees as this isn't from some official source.

    +"In Windows, some background processes can cause issues for other programs and processes. These conflicts can prevent applications such as iTunes and QuickTime Player from working correctly, opening, or even installing. You might be able to resolve these conflicts by disabling some items using the System Configuration Utility (MSCONFIG) in Windows XP. This utility is not included with Windows 2000.+

    +Important: Disabling third-party System Services and Startup Items can prevent some software or OEM hardware on your computer from working correctly. For example, this can affect the CD/DVD control buttons on portable computers.+

    +1. On the Start menu, click Run. A Run window (command prompt) appears.+
    +2. Type msconfig in the Open field and click OK. The System Configuration Utility opens.+
    +3. Click the General tab.+
    +4. Select the "Selective Startup" option.+
    +5. Deselect the "Load Startup Items" checkbox.+
    +6. Click the Startup tab.+
    +7. Select the "iTunesHelper" and "qttask" checkboxes in the list.+
    +8. Click the Services tab.+
    +9. Make sure that "Hide All Microsoft Services" is selected.+
    +10. Click Disable All.+
    +11. Select the iPodService checkbox in the list.+
    +12. Click OK.+
    +13. Click Restart.+

    +If following these steps resolves the issue, you may want to use the System Configuration Utility to turn on the third-party System Services and Startup Items one or a few at a time (restarting your computer after turning on the item or items) to identify which System Service or Startup Item is causing the conflict. You can turn all of them back on by selecting the Normal Startup option under the General tab of the System Configuration Utility window, but please note that this may cause the issue to recur."+

    Here's the source: http://www.unexplained-mysteries.com/forum/index.php?showtopic=54707
  • harveyp Level 1 Level 1 (0 points)
    Thank you. Just followed the instructions and same problem still occurs. I have since re-instated all the unchecked services etc just to make sure I don't inadvertently create further conflicts.

    For some reason, when I go to properties in the iTunes folder in My Music and uncheck read only, hit apply and it doesn't seem to recognise the command. I go back to properties and it still says read only. Any thoughts on this? Hope it helps.

    Rgds,
    Harv
  • harveyp Level 1 Level 1 (0 points)
    Hi Jusben, did you ever manage to resolve this issue? I'd be interested in any suggested fixes. Thanks, Harv
  • harveyp Level 1 Level 1 (0 points)
    Hi All, for future reference I have managed to get iTunes going again by uninstalling all Apple components and then re-installing.

    Cheers,
    Harv