12 Replies Latest reply: Mar 5, 2010 11:23 AM by Katrina S.
Okami-Chan Level 1 Level 1 (0 points)
So, I've had this problem for a while. When I click on certain songs in my library - say, to change some artist name so CAKE and Cake display as the same band - It won't let me change it. I go into 'Get Info', but all the boxes are a light gray and clicking on them does nothing. All my music is stored on a back-up drive, not my computer, but I have full read/write access to everything on the drive. This never happened with the older versions of iTunes (I'm running iTunes 9).

Anyone have a suggestion?

2 GHz Intel Core 2 Duo, Mac OS X (10.6.2)
  • turingtest2 Level 9 Level 9 (56,475 points)
    Possibly only reiterating what you already know, but just in case...

    It might be worth checking that you really do have have full access and also that the files in question (love Cake BTW) are not marked as Read-Only. For example data files copied from read-only media get given a read-only flag on the writable device. Alternatively moving data on an NTFS drive from one Windows installation to another can create security issues. In order to fix these, however, you first have to be able to find them.

    *Missing Security Tab in Windows XP*
    If you have Windows XP, and your hard drive is formatted as NTFS, you can set permissions on files so that only users you specify can access them. However, if your Windows XP computer is not part of a Domain on a network, you may notice that there is no Security tab when you right-click a file and choose Properties.

    To reveal the Security tab follow these steps:
    1. Open Windows Explorer, and choose Folder Options from the Tools menu.
    2. On the View tab, scroll to the bottom of the Advanced Settings and clear the check box next to "Use Simple File Sharing."
    3. Click OK to apply the change, and you should now have a Security tab when viewing the properties of a file or folder on an NTFS volume.

    *Fixing Permissions*
    Right-click on your top-level iTunes folder, click Properties. On the General tab clear the Read-only box if checked, then switch to the Security tab. Make sure that your own account (or Everyone) and SYSTEM have Full Control. Apply the changes. If for some reason you are not allowed to apply the change you should be able to use administrator status to take ownership of the folder after which you will be able to modify the security permissions.

    tt2
  • Okami-Chan Level 1 Level 1 (0 points)
    I have checked, and the permissions are all read/write. They're not locked, either - I made sure to check, locked and unlocked them, to no avail. I also checked that the folder was unlocked. For the rest - I'm running a mac, I reformatted the drive for mac, and have never used it with windows - so the Windows XP issues shouldn't apply.
  • turingtest2 Level 9 Level 9 (56,475 points)
    Okami-Chan wrote:
    ... *For the rest - I'm running a mac*, I reformatted the drive for mac, and have never used it with windows - so the Windows XP issues shouldn't apply.

    So you are, how careless of me not to notice. I don't have personal experience with Macs but I'm sure there are some threads regarding repairing disk permissions which are parallel to the Windows security issue.

    tt2
  • sadaunhe1 Level 1 Level 1 (0 points)
    THANK YOU!! I've been struggling with this same problem for two weeks! Now, it's fixed. Totally forgot to check the permissions tab for the drive.
  • Chris CA Level 9 Level 9 (77,720 points)
    Select the external drive in the Finder and right click - get info.
    Click the *Sharing & Permissions* tab and tick *Ignore ownership on this volume*.
  • bazzbozz Level 1 Level 1 (25 points)
    Maybe you can help me too . . . I tried the exercise you have described here but to no avail. I have a new HP computer w/Windows 7 & Itunes w/Itunes 9 d/l to my computer. I have most of my music files located on an external drive so as not to clog my main drive up. But I am unable to make any changes to my song info.
  • mikeftw Level 1 Level 1 (0 points)
    Ditto, I just put on Windows 7 (64bit) and installed iTunes ("64bit" version) - same problem after going to "add folder to library" then going to track properties in iTunes - everything is all greyed out, can't edit any info.

    Tried reinstalling, recreating library, taking ownership of files, checked permissions, tried setting files so they are not read only, nothing worked - but anyway, I never had to do any of this for previous installs of iTunes on XP, Vista or even Windows 7 Release Candidate - is it a problem with the new version of iTunes?

    Edit - I also tried running iTunes as administrator (compatibility tab) - didn't work either.

    Message was edited by: mikeftw
  • Katrina S. Level 7 Level 7 (24,090 points)
    Several folks I've helped had to turn off UAC to get past this.
    I don't recommend running your PC with UAC off, but as a temporary troubleshooting step, it will show if it's still some kind of windows permission problem.
  • bazzbozz Level 1 Level 1 (25 points)
    What is UAC & how can I turn it off? Is this a temporary fix or a fact finding exercise?? I too don't want to subject my new computer to any attacks unnecessarily if I can avoid it!
  • Katrina S. Level 7 Level 7 (24,090 points)
    User Access Control
    To temporarily turn it off:
    http://www.mydigitallife.info/2008/12/30/how-to-disable-and-turn-off-uac-in-wind ows-7/



    It's a fact-finding exercise, not a fix. Disconnect your network cable (or turn off your wireless) during this exercise if you are worried about attacks. Don't reconnect until you've turned UAC back on. Just see if your user ID can edit tracks in itunes with UAC off, already having full control and ownership of the file and parent folders of the track you're trying to edit.


    You could also try editing info on a track directly from Win Explorer.
  • mikeftw Level 1 Level 1 (0 points)
    Tried disabling UAC and I still couldn't edit. I didn't re-import my library after doing this tho.
  • Katrina S. Level 7 Level 7 (24,090 points)
    Rats. How about if you close itunes, then right-click it and choose "run as admin"?