13 Replies Latest reply: Jun 16, 2012 11:54 AM by Paulie Baseball
GeoJoeWPB Level 1 Level 1 (0 points)
I purchased a Belkin N 150 Router recently because I recd a new netbook for Christmas. I followed all of the instructions that came with the router and everything seemed to go smoothly.
The netbook seemed to be working great on the new wireless connection, but...
the next morning when my wife was using our Mac mini which has a "wired" connection to the router, certain websites loaded extremely slow or not at all.
When we disconnected the ethernet cable from the router and inserted it back into the mac...it was back to its "fast speed".
I tried disabling the firewall on the mac and then the router thinking it was the firewall but it didn't help.

Any ideas?

Mac Mini, Mac OS X (10.4.11)
  • kguy Level 2 Level 2 (415 points)
    Hi- try power cycling your router. First, disconnect any devices connected to it, unplug power, plug in, reconnect devices, and check your speed.
  • GeoJoeWPB Level 1 Level 1 (0 points)
    OK tried that. Several times in fact over the last week. Called belkin and they say its not the router because the wireless is working. ATT says they do not support any router but there own. I just tried the speed check, it was acceptable when the computer is connected to the modem, but when the computer is connected to router...the speed check didn't work. Finally, some pages load normally and quickly...but pages that have alot of content do not. I tried yahoo.com and what loaded was an index page.
  • GeoJoeWPB Level 1 Level 1 (0 points)
    Edit didn't go through so...
    Finally, some pages load normally and quickly...but pages that have alot of content do not.
    Well, not all pages. Pges that load normally are: You tube, etrade main page but not some pages, clearstation, amazon, ebay, the florida state university, realtor.com, Youtube works perfectly and quickly. Pages that do not or are slow: yahoo, mapquest, "apple communities discussion" (Request Timeout Page appears), ESPN loads but continues loading after the page seems to load. I tried yahoo.com and what loaded was an index page.
  • Boece Level 5 Level 5 (6,245 points)
    My hunch is that in the process of configuring this new equipment, you introduced a bum DNS (Domain Name Server) into the mix.

    DNSes turn internet names (like yahoo.com) into numbers, which is what the Internet actually uses to connect to other computers.

    There can be many internet names that compose a single modern website. Your Mac will use the first DNS in its list to try to resolve every web name on a webpage into relevant numeric addresses. If the DNS does not quickly return every resolved address, there will be a timeout, and then the Mac will use the next DNS in its list to try again.

    So I suggest you double-check the DNS entries in System Preferences, Network and also in your router. Make sure that whatever your settings are, that they are consistent in both devices and accurate.
  • GeoJoeWPB Level 1 Level 1 (0 points)
    DNS, IP, Default gateway?

    The belkin router says the DNS Address is ####

    Is that the same as the IP address or the Router #

    Can you take me step by step?
  • gadawgdoc Level 1 Level 1 (0 points)
    Just curious, did you ever get your problem solved. I have the EXACT same issue with my Belkin N router that I purchased last month. PCs work fine but mac is slow on internet. Called Belkin to no avail.
  • John Scott1 Level 2 Level 2 (300 points)
    I had a Belkin Router and finally returned it for the same issues. Some have said to try and use other DNS servers like Open DNS instead of your ISP's DNS servers.
    I tried this with some luck but finally decided that the Router just did not work well with my Mac Mini. I am using a Netgear one now and its seems fine?
    Also some have said to go into Mac's Network settings and turn off IVP6.
  • SimplyMac Level 4 Level 4 (2,360 points)
    I just got rid of my Belkin N+ router due to it constantly dropping the 'net.

    Just using Google I was able to find out that hundreds/thousands of others are experiencing the same issues with Belkin N routers.

    IMHO they are garbage. My internet connection would not only randomly drop wirelessly many times per day, but even hard-wired off one of the ethernet ports on the router. Pull the ethernet out of the router and put it directly from the modem into the computer and all was fast/good/solid connection. The router was definitely the weak link.

    Purchased new Airport Extreme 2 days ago and couldn't be happier.
  • gadawgdoc Level 1 Level 1 (0 points)
    Thanks for the info guys...I'm off to the store today to get a different brand. I'll donate this one to my mom. She has PCs only and wants wireless so should be good for her. At least not a total loss.
  • larrynyc Level 1 Level 1 (0 points)
    Look here and tell me if it matches your issue: A fix for random, slow, intermittent internet problem
  • kirk171 Level 1 Level 1 (0 points)

    I have a mac mini (2010) and a macbrook pro (2011), for some reason my mac mini is much slower for wired/wireless internet connections. What can i do to fix it?

  • Atizone Level 1 Level 1 (0 points)

    After trying a million different things to speed up my mac mini, DNS,firewall etc etc.

    I finally decided to take a look into my belkin router software. I tried resetting, static ip, all the usual stuff. BUT NO JOY.

    However, eventually I looked into RIP VERSION. My router defaults to RIP 2B which apparently carries more information. RIP 1 is universally supported. I switched it over to RIP 1 and rebooted router.

    WOW.  Ipad, pc and mac are all now blisteringly fast. No more drop outs, no speed issues.

    Give this a try, you never know.

  • Paulie Baseball Level 1 Level 1 (0 points)

    I had almost the same issue, started about a month ago and was only a problem on our two Macs running Tiger and Leopard (OS 10.4.11 and 10.5.8). All of our other devices (including Snow Leopard) were fine. This is also with a Belkin N+ router and the slow sites were only a few (Netflix, the Google family, etc.), pinging would hang with them as well, and only through the router - the Cable Modem direct connection was fine. After trying everything, turning off IPV6 in Network Preferences on the bum computers solved the problem. Thanks to John Scott1