1 2 Previous Next 15 Replies Latest reply: Jan 9, 2010 9:33 PM by msbeezy
Macless Dubai Level 1 Level 1 (110 points)
Dear All,

I have 2 of the Intel Gen2 SSD's, I have had them in Raid0 since I purchased them, since 10.6.2 I have had continual disk errors in Disk Utility, I decided 10 days ago to ditch the Raid0 and use them singly, I did a fresh instal of SL, and then copied my apps from my Time capsule, all was fine but now I'm getting disk errors again, and really slow performance specifically on save dialogs from Word and from print to PDF, I have to boot from sl disk once every 48 hours to repair the disk, I am at the end of my tether with this, my SSD is running the latest firmware, my home folder has been moved from the SSD to my WDC black Raid0, any ideas would be greatly appreciated.

Mac Pro Quad 2009, 8gb ram, 3 x WDC 1tb black, 2 x intel gen 2 ssd 80gb, 2 x 24" inch LED display,, Mac OS X (10.6.2), iPods, iPhone, Time Capsule, airports etc.
  • 1. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Samsara Level 4 Level 4 (1,320 points)
    Hi,

    What kind of disk errors is DU reporting? With Disk Permissions or Disk Verify and Repair?
    Chances are it's not the disks but a problem with files. Either TechTool Pro 5 or DiskWarrior can really help you out there. I have both but DiskWarrior is my app of choice in matters like this.

    Did you use Software Update or the downloadable stand alone installer to update to 10.6.2? Many prefer to use the full combo update to upgrade.
    http://www.apple.com/downloads/macosx/apple/macosx_updates/macosxv1062updatecomb o.html

    You can still download and try that from your desktop. It won't destroy any files and may help. It just reapplies the update over what is already there, perhaps filling in a few of the gaps that Software Update left out.

    On a separate note, because I don't think it's the SSDs, make sure the firmware for the Intels is up to date. This is for the benefit of the disks themselves and not for the system.

    As a last resort, or not because you have two disks, consider erasing one disk and installing Snow Leopard new from scratch, then quickly upgrade through and up to 10.6.2. See how stable that runs. If it runs well then you may consider dragging apps over from your other drives or install them fresh. Once your sure that everything is working well, clone that system to another drive, not one of the SSDs, set up your Raid again, then clone the new system back over to your Raid again.

    Best of luck to you.
  • 2. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Macless Dubai Level 1 Level 1 (110 points)
    Its file and folder counts that are always off by one or two, this one below is from just now,

    Verifying volume “Snow Leopard”
    Performing live verification.
    Checking Journaled HFS Plus volume.
    Checking extents overflow file.
    Checking catalog file.
    Checking multi-linked files.
    Checking catalog hierarchy.
    Checking extended attributes file.
    Checking volume bitmap.
    Checking volume information.
    Invalid volume file count
    (It should be 622367 instead of 622368)
    Invalid volume directory count
    (It should be 179127 instead of 179126)
    The volume Snow Leopard was found corrupt and needs to be repaired.
    Error: This disk needs to be repaired. Start up your computer with another disk (such as your Mac OS X installation disc), and then use Disk Utility to repair this disk.
  • 3. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Samsara Level 4 Level 4 (1,320 points)
    Hmm, I would suggest doing what it says then, a disk you're booted up from can't be repaired from there. You'll have to boot from the DVD or another system on your Mac and use DU from there. Again Diskwarrior or TTP5 may still help here.

    But that certainly points the problem to the disk or disks again. I may have been too quick to dismiss the possibility it's the disks. It would be odd though, and both disks especially so. Odd, but not impossible. I'm sorry to hear that is what is reported. I never want to see problems on that side of DU and have to say I rarely have.

    It's still early, I'm sure others will be checking in soon. In the meantime take DUs advice and try starting up from the system DVD. Also I'd be interested in what DU reports about a disk that was newly erased and partitioned.

    A "corrupt" volume. I'm not even sure what that really means. Sorry I couldn't have been more helpful.
  • 4. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Macless Dubai Level 1 Level 1 (110 points)
    This is about the twentieth time I have done this, I have also tried what you suggested with the spare drive, and I still get the same problems, I have posted the same on a few other sites, and the consensus seems to be the that the culprit is 10.6.2, both my drives are running the latest firmware. I have secure erased both of them, fresh installs, everything, I can't find anything wrong with the drive, it works flawlessly for anything between 12 to 48 hours, and then disk errors as posted above.

    I'm tempted to go back to Caviar Black, SSD/Intel/Apple are not ready for the playground.
  • 5. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Allan Eckert Level 8 Level 8 (41,525 points)
    Hi Dubaimac;

    If it were mine and it has done this 20 times, personally I would not trust the SSD of the RAID Array.

    First I would break the RAID Array and see if the SSD work correctly without. If that solves the problem then I would consider some other alternative rather then RAID. If it did not, I would sent theSSD back for replacement.

    Allan
    tiger
  • 6. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    The hatter Level 9 Level 9 (58,885 points)
    Okay, looks like you don't own a good 3rd party disk maintenance utility? or am I wrong? From years of heavy use, I would not be without Disk Warrior and probably one or more others.

    I still use 10K VelociRaptor. Rock solid and has been my replacement for SCSI - also tried true and tested and years of use, 15K boot drives and 10K for performance, but not really needed or viable today.

    Maybe SSD in my future.

    I also am waiting for 10.6 to reach its stride and get to 6-12 months, sort of the SP1. Every Mac OS has needed three or more updates to be production ready.

    Why secure erase? you mean 7-way write? if you want to insure they work, my advise is to install and do all the testing and certify the drives in Windows. Windows 7 has better TRIM and SSD support for now probably too.
  • 7. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Samsara Level 4 Level 4 (1,320 points)
    I'm tempted to go back to Caviar Black, SSD/Intel/Apple are not ready for the playground.

    I wouldn't be tempted, I would go back to the Caviar. I'd make sure 10.6.2, your software, and any additional hardware you have plays nice with that and the disk doesn't become "corrupt" over time. I don't know how much time to give it, but when you're satisfied, clone that system over to a FW Drive or something so at least you know you have a good system tucked away somewhere.
    And this didn't happen with 10.6.1, right? How long have you been using the SSDs?

    It gets me that this is something that appears over time. That I believe you're saying each time you manage to get DU to report no errors, sometime afterward it does again. Well, as I recently had pointed out to me again, flawed drives do crack under load. But two of them? And for something you really don't want to hear, many of us out here using SSDs have just not seen this, so it's hard to think the fault lies with 10.6.2. Granted I have Vertex and 1st gen 80gb Intels, could this be something only affecting the second gen Intels? I haven't heard that reported either, but who knows, yours may be the first of more to come. I know there are people here using the 2nd gen, maybe they'll write in (MsB, where are you?). From what I've read, the Intels have had more issues than other SSDs, but not of this nature as far as I know.

    So again, for my own clarity of mind only, you can get the problem fixed, no errors reported, and a short time later with use they just come back again, and you're saying that this has only come about since 10.6.2. It's bizarre.
    Well that leaves one fairly obvious thing to do and one thing you really should do.
    On the last, get DiskWarrior, it really is an outstanding program.
    On the first... Go back to 10.6.1.
    And on that also, tell us how long you've used 10.6.1 with the SSDs. Also, did you use the combo or Software Update to get to 10.6.2? Doing that, using SU, really has been a source of problems in the past.
    Also, while every Mac of the same model should be the same, frequently that doesn't seem to be the case. 1 person is affected by something, 10 people aren't. Can you yourself point to anything that may be making your Mac behave differently than the rest. Any special circumstances like heat or electricity?
    When I switched to SL it was a disaster for me until I did a clean install and rebuilt my system again. Many people were able to migrate things over successfully but that simply never worked for me. Not one thing could I migrate without it taking a toll on the performance of my Mac. I could never figure that out.

    I'm trying to think of things that might make SSDs more prone to damage than standard disks. But then again, it's not damage is it. It's corruption. Anyone here know exactly what that means? There is data and file corruption, but disk corruption? Are they the same?

    Well, lastly, and again, I can only think that by going back to an earlier OS can you be sure it's 10.6.2. If it turns out to be 10.6.2 only, then I would be glad to admit that's it, and be wary for my own benefit. In my case though I use DU, Diskwarrior and others utilities like Superduper a lot. I just haven't seen any indication of something similar happening. Please look into getting DiskWarrior. It's pricey but it's saved me on more than a few occasions and really I think it is worth it even if it is the only Utility program you can afford.
    I'd like to see your SSDs working with 10.6.2, but if they can't and they work well with an earlier OS, personally I'd drop 10.6.2 and stick with the SSDs. On the other hand if you have only a certain amount of time to get a refund on the SSD's, I'd exchange them for new ones or get a refund and buy a different make of SSD.
    It's a difficult issue and you must be extremely frustrated by now. But hang in there and I bet you'll get this sorted out.
  • 8. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    The hatter Level 9 Level 9 (58,885 points)
    Check this MacRumors thread, maybe you are onto something and can get to the bottom of what is wrong with Mac OS and SSD:
  • 9. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Samsara Level 4 Level 4 (1,320 points)
    Um... that is his thread, or did you know that.

    Well two things there that he didn't post here are the Drobo unit and his home folder being on a different drive. Whether either is accounting for the problem, I don't know.
    I don't know anything about Drobos, are there drivers involved? If so, maybe he should check for updates.
    And I'm not sure, but is his home folder on a disk other than his boot volumes, the SSDs? That would seem counter-intuitive. The SSD's, especially in a Raid, would be much faster than the other disk. That might create problems.
    I need to find the thread there that Wild Bill is referring to, "Intel G2's have an issue with 10.6.2 ??" If that was the case it would certainly narrow things down.

    Edit: Geez, how can there be 11 pages when I put that line in the search field? Not specific enough?

    Message was edited by: Samsara
  • 10. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Samsara Level 4 Level 4 (1,320 points)
    Well, no really... it at least goes up to 18 pages. 647 results with Intel G2's have an issue with 10.6.2 ?? in the search field. I wonder what "Another Mac Myst lover" would tell me.

    I guess it's this one though:
    http://forums.macrumors.com/showthread.php?t=834553&highlight=IntelG2%27s+have+an+issue+with+10.6.2%3F%3F

    Same old thing though. Mine works, mine doesn't work. Mine works has the edge.
    Thank God we don't have bright green smileys here...
  • 11. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Ein Level 2 Level 2 (410 points)
    My Intel G2 has been fine with 10.6.2 since it came out.
  • 12. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    johncode Level 1 Level 1 (0 points)
    Same here. Both of mine work fine in 10.6.2 in software RAID 0
  • 13. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    msbeezy Level 1 Level 1 (45 points)
    I have 3 of the same drives in raid 0 and get very good performance although one failed a week or so ago.Today it's replacement arrived from Intel. All three were ver G1 and they replaced the failed unit with a G2..guaranteed they would work ok together...Funny tho I had to try 4 or 5 times to get them into the stripe but I finally did..anyways..with regards to your drive if you have access to a windows OS Intel does provide a utility to check the health of their ssd drives (check their site) but only on windows. I also have a couple caviar drives (blacks) and I'd never give up the boot OS performance of the ssd's for them.
    Good luck
  • 14. Re: intel Gen 2 SSD 80GB Disk errors- OSX 10.6.2
    Samsara Level 4 Level 4 (1,320 points)
    Sorry to hear about the drive failure, Msbeezy, but glad to hear the gen 2 is working well with it's elders.
1 2 Previous Next