8 Replies Latest reply: Feb 26, 2010 3:34 PM by ashweee
Andy O'Neil Level 1 Level 1 (5 points)
My iPod Touch Mail application won't send emails from my Yahoo Small Business Email Account. +However, I can receive emails sent to my Small Business Email Account.+

My regular Yahoo Email account functions just fine-- I can send and receive emails without any problems.

Does anyone have any suggestions? Thoughts? Similar problems?

Thanks for taking the time.

Andy O'Neil

Dual 1.8 GHz PowerPC G5, Mac OS X (10.5.7), 2 GB DDR SDRAM
  • chaznsc Level 1 Level 1 (125 points)
    My guess is your ISP is blocking the outgoing mail. MAny ISP's dont allow "relaying" using their connection. Check and see if they will allow you to authenticate using your account username and password.
  • afisherman Level 1 Level 1 (20 points)
    I have the same problem with Road Runner. Email downloads fine from their POP server. Can not send through their SMTP server. Error message states "cannot connect to SMTP-server.....". I have been in touch with Apple, Road Runner and Belkin(router). They all point a finger at one another and no one knows how to resolve the problem. The really weird part is that once in a while I can actually send mail, but very seldom.
  • autochthon Level 1 Level 1 (115 points)
    I've got the same problem, here in Texas, with smtp-server.austin.rr.com.

    What's really wierd is, if ik take the iPod Touch to an Apple store nearby, or to some other wifi, I can send and receive email. (at least once, as a test). But it won't send roadrunner email from my home wifi (Belkin wireless) anymore. I thought this suggested that i have some kind of Belkin config issue. But the Belkin Tech in India was unable to figure out a solution. He suggested I call Apple Support.

    I was able to send roadrunner email once or twice when I first got the iPod Touch at Christmas, and then it stopped working.

    I am thinking that Roadrunner (that bastion of Customer Disservice) has some way of detecting iPod Touch and disabling its smtp-server service to it, for unknown reasons, once it notices that you are using an iPod Touch. It makes no sense to be able to send email from your desktop or laptop, connected wirelessly to a Belkin, but have the ability for iPod Touch in that same location, carefully and correctly configured, to almost immediately cease after just a couple of emails. I've gone over all settings dozens of times, tried all kinds of suggested workarounds posted online, and nothing works.

    I may go back to the Apple store and try a few more email sendings. If it suddenly stops working there, too, I'll really wonder if RR is maybe deliberately disabling the sending service after a couple of emails from ANY specific WiFi.
  • keyluv44 Level 1 Level 1 (0 points)
    try removing your user name and password from the outgoing server section. I did a test and it worked
  • Orchardman Level 1 Level 1 (0 points)
    Take a look at posts on thread "iPod Touch will not connect to wifi"
    I have a new 3rd Generation touch with much the same instability problems.
    I think Apple seemed to have launched a product that is just not capable or suitable for many users, no doubt some work fine but many are very flaky.
  • Julian Wright Level 7 Level 7 (34,860 points)
    Take a look at posts on thread "iPod Touch will not connect to wifi"

    Why? This thread is about email connectivity to outgoing email servers, not a general WiFi issue.
  • THETexJWP Level 1 Level 1 (0 points)
    +aka "Can't Connect To Server" error message+

    The other post above nailed the solution to this problem. I will reiterate...

    1. Go to Mail --> Preferences
    2. Click on "Accounts"
    3. At the bottom of the screen, click on Outgoing Mail Server (SMTP) --> "Edit SMTP Server List..."
    4. Click on "Advanced"
    5. Set Authentication to "None"
    6. Say OK & close
    7. Send email to your heart's content

    Hope this helps! I just finished upgrading from original G4 Mac mini to brand spanking new Core Duo 2 Mac mini, and this was driving me crazy. Thanks to the other poster for saving me from insanity!
  • ashweee Level 1 Level 1 (0 points)
    I had the same problem here's what you do

    clear cache and history

    goto mail
    click all email acounts and delete them an set them up again