4 Replies Latest reply: Jan 5, 2010 8:54 AM by rajeshpr
rajeshpr Level 1 Level 1 (0 points)
When i boot win7 64x for some reason the clock goes back to UTC 00. This only happens if i use MAC osx then restart the windows, it stays fine it I just use windows

Imac 24, Mac OS X (10.6.2)
  • The hatter Level 9 Level 9 (60,485 points)
    This still happens after you inserted Mac OS X DVD and installed Apple setup.exe with Boot Camp services and drivers?

    Normally an AppleTimeSwitcher gets added to resolve time synch.
  • rajeshpr Level 1 Level 1 (0 points)
    Yes, I have mac book and imac both have the same issue. On iMac it would install the apple updates so i just installed the drivers but the mac book has all the boot camp stuff.
  • Side_Step_Society Level 2 Level 2 (320 points)
    This is my solution for the time switch problem.

    "Run > RegEdit

    Find;
    HKEYLOCALMACHINE > SYSTEM > CurrentControlSet > Control > TimeZoneInformation

    Add key ( REG_DWORD type );
    RealTimeIsUniversal

    Double-click and set value to 1

    and

    If your clock is constantly out of sync even though it says the sync was successful, the problem could be that your computer is losing time because of a system clock problem. A workaround in this instance is to change the NTP client to update more often.
    Open regedit.exe through the start menu search box, and then find this registry key:
    HKEYLOCALMACHINE\SYSTEM\CurrentControlSet\Services\w32time\TimeProviders\NtpClient
    Double-click on the key on the right-hand side for SpecialPollInterval
    The default time period is 7 days calculated in seconds. If you wanted to change this to update every day, you would use 86400, or 60 seconds * 60 minutes * 24 hours * 1 day."

    Found these after hours of online searching.
  • rajeshpr Level 1 Level 1 (0 points)
    Thanks a million it worked.:)