Previous 1 2 3 4 5 Next 113 Replies Latest reply: Mar 14, 2016 10:14 PM by Belad Go to original post
  • richard.anter Level 1 Level 1
    Alright everyone, I finally got it fixed with the help of Cheryl @ Apple, the nicest woman on the planet! First, she had me create a new user and attempt to record. I did, and when I recorded, I had the same problem, which meant it's an issue with GarageBand, so the next step was to reinstall the software.

    I logged in as Administrator, and I went to the following folders:
    Macintosh HD\Library\Application Support > delete the GarageBand folder
    Macintosh HD\Library\Caches > delete anything with GarageBand in the name
    User\Library\Preferences > delete all files
    User\Library\Application Support > delete GarageBand folder

    Once I did this and reinstalled GarageBand from the Install DVD, it works perfectly like it used to!
  • herbshirt Level 1 Level 1
    @ OssieT - Do you mean do this every time??

    @ Everyone else - Has anyone been able to find a way to recover our old audio files? or are we kissing them goodbye?

    Would upgrading to Logic solve anything?
  • richard.anter Level 1 Level 1
    If you don't want to follow OssieT's advice, you can follow my directions, and it should work for you once and for all. Once you do it, you'll be back to normal again. You won't be able to recover your lost files. They're gone. Upgrading to Logic won't solve it.
  • herbshirt Level 1 Level 1
    k, installing now. Will let you all know how it goes.
  • herbshirt Level 1 Level 1

    I followed the directions above but now...

    I have re-installed but when I open GB it now asks for a valid Library folder at Library/Application Support/Garageband/ - There is in fact a folder there called Instrument Library but when I choose it GB is still not satisfied.

    I've tried rebooting my machine etc.
  • richard.anter Level 1 Level 1
    I'm not sure why that's happening, as I did not run into that issue upon reinstall. Did you try to search the web for that specific issue? You may need to reinstall again perhaps.
  • mugabe23 Level 1 Level 1
    Ok, so only the universal helpdesk solution (Have you tried rebooting? Have you tried logging in as a different user? Have you tried reinstalling the software? Have you tried reinstalling the OS?) does the trick?

    Before I wipe my installation along with all plugins, addons and personalised settings, I'd like to know why this has happened, and why a reinstall will guarantee that it doesn't happen again.

    Did this lovely Cheryl woman acknowledge the error at all, or hint about whether it was being addressed by Apple's software engineers?
  • edjgraphix Level 1 Level 1
    That happened to me on a song that I completed cause I copied it from one file and pasted into a newer file. THen I dumped the trash of the original file and the next time I tried opening my song... EVERYTHING EXCEPT THE DRUMS WERE GONE!

    I backed up my file with the drums and I started the song over from scratch. When it came time to do the drums, I had to use the drums from the file since my neck got strained putting the drum track on the original song (I'm a beginner that tries to rock out like a pro... that's how) and just before I copied and pasted, I decided to back up my files. THEN i copy and paste... it sounds good... I save it to iTunes... I notice an area to adjust and the **** drums were gone!

    SO, I get my saved files and start again... same thing happens. In the middle of the night I had an idea to turn the drum file into an apple loop. I drag and drop it into place and I haven't had any trouble since. I don't know if any of this can help you... but if it is because you copy from one file to another then delete the original file... save the copied piece as a loop first as a temporary work around so you don't lose any more recordings.

    I feel your pain!!! (I'm saying this with a Bill Clinton accent!)

  • HangTime Level 9 Level 9
    your's is a completely separate issue, easily solved:

    (Let the page FULLY load. The link to your answer is at the top of your screen)

  • herbshirt Level 1 Level 1
    Well I'm completely dead in the water after following that nice ladies suggestion.

    "...asks for a valid Library folder at Library/Application Support/Garageband/ ..."

    I've googled like crazy to find a solution, tried a few, nothing yet. So now I can't even open GB at all.
  • richard.anter Level 1 Level 1
    I'm not sure why it didn't work. That's exactly what did it for me...except now it's happened again. Now, I'm with you. I would like to be given a good explanation for this, but so far I have received none. I am going to reinstall the OS tomorrow. So much for that.
  • andydckent Level 1 Level 1
    This has been happening for some time now on my mac. Today I tried reverting back to garageband 08' and guess what, the same problem.... Please find us a fix apple!
  • poflynn Level 4 Level 4
    If you want to alert Apple to the problem use the Feedback menu item; this is a user to user forum.
  • dberni Level 1 Level 1
    Same thing happened to us after recording a 40 minutes podcast. I cannot believe this stuff happens, we obviously won't use GarageBand anymore to record our audio files, but still, I can't believe Apple has not given a solution to so many frustrated users. When you people talk about "the Apple way" what exactly do you refer? To the fact of telling you they take care of everything behind the scenes "don't you worry about saving the files, we'll handle it". And then they get lost forever! Not even a disk recovering took helped a bit. Really, I'm so ******.
  • herbshirt Level 1 Level 1
    Well I've tried all suggestions including re-installs, wiping files ( which is not recommended btw - took me a long time to get back to where I am now).

    Also as suggested sent some feedback to Apple for all the good that'll do.

    I primarily bought a Mac to record music. Everything I've recorded to date is lost forever and now I just lose each recording immediately once I relaunch.
Previous 1 2 3 4 5 Next